Re-enable multi-layer squashfs support

Bug #1561606 reported by Daniel on 2016-03-24
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

AFAIK, Casper supports booting when there is more than one squashfs file in the casper directory. At least, this _was_ supported under Ubuntu trusty which used aufs as union file system. Then there came utopic, wily, vivid which switched to overlayfs. This file system didn't support layering more than one ro sources in its early versions so that this feature didn't work anymore. The code in the casper script looks like a work-around about this by stacked mounting multiple overlayfs. Unfortunately, I've never seen a version of overlayfs which supported another overlayfs as source.

Since kernel 3.19, overlayfs officially supports multiple layers (http://www.phoronix.com/scan.php?page=news_item&px=MTg1Nzg), so it's time to rewrite this piece of code in the casper script.

Fully-working patch attached.

Daniel (hackie) wrote :

Btw it mainly affects all releases after Ubuntu 14.04 Trusty including the new 16.04 Xenial

The attachment "Fully-working patch for casper, tested with version 1.365 amd amd64" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Daniel (hackie) on 2016-04-07
summary: - Booting support with multiple squashfs files
+ Re-enable multi-layer squashfs support
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in casper (Ubuntu):
status: New → Confirmed
Richard Nelson (unixabg) wrote :

Greetings,

Please consider this patch also for resolution of the bug.

Richard Nelson (unixabg) wrote :

Greetings,

After more testing of the previous patch submitted, I discovered that I had the lower stack order inverted. Hence I have removed that patch and I am submitting this revised patch. This new patch has been tested with multiple additional squashfs files and is in working order for casper live operations.

I'm reviewing this.

I've more or less got independently to the same code as Daniel's. Any reason we should use your patch rather than Daniel's?

Changed in casper (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
milestone: none → ubuntu-17.05
Richard Nelson (unixabg) wrote :

Greetings,

Humble appreciation that you are addressing this bug! I submitted the patch because I believed it to solve the issue and, imo, my patch is very clean, less intrusive, and does not introduce new variables. Please test the patch and confirm for yourself with not just one extra partial squashfs update (I call them PSU files), test with several and test stacking order.

To make the PSU files I just ripped the iso and made PSU files, several times, using live-partial-squashfs-updates , I believe it is should be in live-tools package, but here is git

https://github.com/unixabg/live-medium-install-tools/blob/master/scripts/live-partial-squashfs-updates

Then composed iso again with the PSU files and tested that it did stack on Live. As I recall the PSU files do not get installed during installation, which I how it should be imo.

Thank you for the dialog and your consideration of my patch.

Daniel (hackie) wrote :

But also compare with my patch, as I am the original reporter of this request :-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.381

---------------
casper (1.381) artful; urgency=medium

  * scripts/casper: Do overlay stacking properly. (LP: #1561606)
  * hooks/casper: Switch from overlayfs to overlay, to make sure we properly
    enable using overlay rather than aufs on images.

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 26 Apr 2017 15:10:57 -0400

Changed in casper (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions