Can't install software in Xubuntu Gutsy Gibbon beta LiveCD

Bug #147306 reported by Vincent on 2007-09-30
6
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Unassigned

Bug Description

On the LiveCD of Xubuntu Gutsy Gibbon beta, I am unable to install any software. When I try to add an application using Add/Remove... it hangs. Then I killed it with Ctrl+Alt+Esc, and killed Python using System Monitor. However, when I start a new instance of Add/Remove... afterwards, it says "Another instance of Synaptic is running in non-interactive mode".

On a fresh boot of the LiveCD (so not in the same session) when I tried to install Flash from withing Firefox I was told the installation of Flash had failed and I was presented with a button that said "Manual Install". Declining that, I tried to install Flash using Add/Remove... I had the same problem as described above.

At yet another fresh boot on a *different* computer, I first tried to open a terminal and type "sudo apt-get install recordmydesktop" so that I would be able to record what went wrong. However, this, too, hung at:

ubuntu@ubuntu:~$ sudo apt-get install recordmydesktop
Reading package lists... 0%

Mike Dahlgren (dahlgren) wrote :

Thanks for your bug report! Correct me if I'm wrong but I don't see anyway that you could install packages when using the live cd. The issue is that the cd-rom is read only and there most likely isn't enough memory to store _Everything_ so it just fails. IT probably should be more graceful, but I can't see this as being incorrect. Really the live cd is just there to show the system off and not as a real desktop solution.

  Thanks,
     ~ Mike

Mike Dahlgren (dahlgren) wrote :

For the reasons stated in the comments I am closing this bug out, If you feel that this is in error please re-open this bug.

   Thanks,
        ~ Mike

Vincent (vinnl) wrote :

"Correct me if I'm wrong but I don't see anyway that you could install packages when using the live cd. The issue is that the cd-rom is read only and there most likely isn't enough memory to store _Everything_ so it just fails. IT probably should be more graceful, but I can't see this as being incorrect. Really the live cd is just there to show the system off and not as a real desktop solution."

That's not quite true. It should be able to install everything into RAM. However, I'm running the LiveCD from my USB drive in "persistent" mode so everything I install should be saved to my USB drive upon shutdown. Worked in Edgy and Feisty.

Nathan Handler (nhandler) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in casper:
status: New → Incomplete
Vincent (vinnl) wrote :

I can't recall experiencing this issue with live CD's of Xubuntu 8.04 so I've marked it as Fix Released (that's correct isn't it?).

Changed in casper:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers