Vivid DVD fails to reboot or shutdown w/o hard reset

Bug #1436715 reported by Erick Brunzell on 2015-03-26
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Critical
Mathieu Trudel-Lapierre
Vivid
Critical
Mathieu Trudel-Lapierre

Bug Description

Following up on bug #1432285 I've tested both the Ubuntu and Ubuntu GNOME 20150326 amd64 images and now when you select either reboot or power-off the prompt to remove the live media and press enter is displayed, then the disc is ejected, but after removing the disc and pressing enter nothing happens.

It's easy to reproduce:

(1) Boot the Vivid live DVD to the live DE

(2) Select either reboot or power-off and condfirm your choice

(3) When the DVD is ejected remove the DVD as directed and press enter

You'll then see that pressing enter does nothing.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: casper 1.356
ProcVersionSignature: Ubuntu 3.19.0-10.10-generic 3.19.2
Uname: Linux 3.19.0-10-generic x86_64
ApportVersion: 2.16.2-0ubuntu4
Architecture: amd64
CasperVersion: 1.356
CurrentDesktop: Unity
Date: Thu Mar 26 07:52:11 2015
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150326)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Erick Brunzell (lbsolost) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1436715

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in casper (Ubuntu):
status: New → Confirmed
Elfy (elfy) wrote :

Noted in virtual machines.

Seen graphic corruption in virtualbox after pressing enter at restart into your new install.

Seen hang in virtualbox after pressing enter at restart into your new install.

Seen hang in kvm after pressing enter at restart into your new install.

In neither was the Press Enter to eject media screen seen

Erick Brunzell (lbsolost) wrote :

I tested on two different sets of bare metal and the prompt to remove media and press enter appeared as expected, and the disc ejected as expected, the only part that failed was pressing enter which did absolutely nothing.

Maybe if the prompt is not appearing in some instances that problem would actually be related to bug #966480? But I know from past experience that even though the prompt didn't appear pressing enter would still work, just new users would have no idea what to do in those cases.

Jonathan Riddell (jr) on 2015-03-27
Changed in casper (Ubuntu):
milestone: none → ubuntu-15.04
tags: added: kubuntu
Changed in casper (Ubuntu):
importance: Undecided → Critical
Erick Brunzell (lbsolost) wrote :

This is not a duplicate of bug #966480. In this scenario the prompt for removal does appear, and the disc is ejected, it is only that pressing the enter key does nothing and since the disc is no longer running the only option is to hit the reset button, if one exists. In cases where a reset button does not exist there really is no option other than killing the power.

Brendan Perrine (walterorlin) wrote :

I get this on a core 2 duo laptop booted with the i386 iso of lubuntu.

tags: added: i386
tags: added: rls-v-incoming
Changed in casper (Ubuntu Vivid):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.359

---------------
casper (1.359) vivid; urgency=medium

  * Do a better job at caching files we might need for plymouth and systemd
    on shutdown. (LP: #1436656)
  * debian/casper.service: Order the casper service just before final.target
    so it's running at a better point in time on shutdown.
  * scripts/casper-bottom/25disable_cdrom.mount: mask the cdrom.mount task,
    so it doesn't unncessarily spin trying to unmount the cdrom, which casper
    will do. (LP: #1436715)
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 13 Apr 2015 14:50:24 -0500

Changed in casper (Ubuntu Vivid):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers