Vivid live DVD fails to provide means to eject disc

Bug #1432285 reported by Stephen Michael Kellat on 2015-03-15
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

Test Case: Install (manual partitioning) in Xubuntu Desktop amd64 for Vivid Daily

Excerpt from the test case:

13. Wait for the installer to finish
    An 'Installation Complete' dialog appears
14. Click the Restart now button
    GUI is shut down, a prompt to remove media and press Enter appears
15. Remove the disc and press enter
    The machine is rebooted

Failed at step 14 as no prompt to eject disc was provided. System rebooted instead and tried to restart installation process. I had to hold down the power button to shut the laptop down, manually eject the disc, and then restart the machine to bring it up normally.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.19.0-9.9-generic 3.19.1
Uname: Linux 3.19.0-9-generic x86_64
ApportVersion: 2.16.2-0ubuntu3
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Mar 14 23:12:46 2015
InstallationDate: Installed on 2015-03-15 (0 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150314)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1432285

tags: added: iso-testing
summary: - amd64 installater fails to provide means to eject disc
+ amd64 installer fails to provide means to eject disc

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Erick Brunzell (lbsolost) wrote :

Probably more of a casper or syslinux bug than ubiquity itself because even if you just boot the live DVD and select Restart the disc is never ejected, no prompt is given, and the DVD just reboots unless you're either quick enough to enter BIOS (or UEFI setup) or press a key when the human + keyboard image appears at the bottom of the screen so you can select Boot from first hard drive from the advanced boot menu.

Erick Brunzell (lbsolost) wrote :

Not arch specific and also effects use of live DVD w/o installing OS so changed title accordingly.

summary: - amd64 installer fails to provide means to eject disc
+ Vivid live DVD fails to provide means to eject disc
Dave Morley (davmor2) wrote :

A secondary issue is that with the UEFI menu there is no boot from HDD so you are stuck with a dvd you can not eject, you can't boot to HDD, and you can not eject the dvd in menu mode either, you have to power down the system hard and the use the manual release on the drive to eject the dvd.

Erick Brunzell (lbsolost) wrote :

Things are actually a bit worse with the Ubuntu 20150325 amd64 image, after clicking on restart you end up with just a black screen and no key combination will bring up a TTY or complete the reboot process, so about the only thing you can do is eject the disc and perform a hard reboot.

This would rather be an issue in casper than in ubiquity; moving to systemd means that the behavior of casper on shutdown (a sysv init script) isn't maintained.

I'm fixing this now.

affects: ubiquity (Ubuntu) → casper (Ubuntu)
Changed in casper (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
status: Confirmed → Triaged
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.356

---------------
casper (1.356) vivid; urgency=medium

  * Replace the casper init script with a systemd service which starts a new
    /sbin/casper-stop script; maintains the current behavior of caching data
    and prompting before ejecting a possible CD-ROM. (LP: #1432285)
  * debian/control: add dh-systemd to Build-Depends.
  * debian/rules:
    - don't apply postinst scripts from installinit; also don't start the
      systemd units on install.
    - run debhelper with systemd support.
 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 25 Mar 2015 23:16:27 -0400

Changed in casper (Ubuntu):
status: In Progress → Fix Released
Erick Brunzell (lbsolost) wrote :

Not quite there, pressing enter fails to complete the reboot or shutdown procedure. I filed bug #1436715 as a follow up.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers