Ubuntu

ubuntu 13.10 unable to boot on live usb (busy box - initramfs)

Reported by Sébastien DUBOIS on 2013-10-18
188
This bug affects 38 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Unassigned

Bug Description

First, excuse me for my English I'm French.

I download ubuntu 13.10 64 bits iso. I check the MD5 sum and all is OK.
I create the live usb with usb-creator-gtk from my ubuntu 13.04.

I reboot my computer, it starts on the usb stick with the first ubuntu screen and stop on a black screen with busybox and initramfs.

I have try the same usb key on another computer and its works.

I have try to make a live usb of ubuntu 13.04 and it works correctly.

Some informations about my hardware configuration :
    - motherboard : z77X-D3H
    - RAM 8Go
   - CPU : Intel Core i7-3770K
   - graphic card : from the CPU

Edit:
For information same problem with kubuntu 13.10 and xubuntu 13.10

tags: added: live usb
Lo_pescofi (corbieres) wrote :

I've same problem with same protocol install.
Just different :
I create the live usb with start disk(usb) creator from my ubuntu 12.04

HW config :
AMD Athlon(tm) 64 Processor 3500+
Motherboard A8N-E ASUSTeK Computer INC.
graphic card NV43 [GeForce 6600] NVIDIA Corporation

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnomeradio (Ubuntu):
status: New → Confirmed
Nikita (gn-pavlodar) wrote :

I installed Ubuntu 13.10 (64) from DVD, not USB.
After few seconds loading from dvd-disk, I saw black screen:
=-=====----=-=-=-
BusyBox...
(initramfs)
=-=====----=-=-=-

:(

Motherboard: Gigabyte Z68AP-D3
CPU: i3-2120
GPU: GeForce 9800 GT

Karim Latouche (karim-latouche) wrote :

Same here!
Tried to install from dvd and got the same result on one box but got it working on the other.

Motherboard ASUS
GPU Radeon 5xxx

Alex Mekkering (a-launcupad-d) wrote :

Same here!

I created the USB stick from the official Ubuntu 13.10 Desktop 64 bits iso with Universal USB Installer.
I tried to boot in UEFI and BIOS mode, both with this same effect.

Motherboard: ASRock Z87 Extreme 6
CPU: Intel Core i5-4570

pavel bursa (bursap) wrote :

Same here!
USB stick (created by lili or startup disc creator), and also DVD from the official Ubuntu 13.10 Desktop 64 bits iso ends with initramfs.

Motherboard: ASUS P5Q3
CPU: Intel Pentium Dual Core E6300 (2.8GHz)
GPU: NVIDIA GeForce GT640
RAM: 8 GB

BTW, the USB and DVD both worked for Ubuntu 12.04 LTS like charm for the same BIOS setup.

description: updated

I have this problem also.

My bootable usb stick was created in ubuntu 12.04 x64 with unetbootin.

Default and install options of unetbootin both were tried - boh fail (busybox initramfs).

laptop: clevo p150em

Reyes Yang (reyes-yang) wrote :

Same problem on my Lenovo U410 laptop. USB stick based on Ubuntu 13.10 64bit.

ross (ross-rossmoore) wrote :

Same problem on my desktop. Hang on, who does this work for?
Core i3, Gigabyte motherboard. Haven't had any issues until this.

ross (ross-rossmoore) wrote :

gnome radio?? not sure that package is relevant here.

affects: gnomeradio (Ubuntu) → ubuntu
Sébastien DUBOIS (seb-ipsa) wrote :

Excuse me for this mistake.
It is the first time I create a report for Ubuntu.

John Cottier (j-cottier) wrote :

I had a similar issue with a 13.10 live DVD. It was fine until I had a new SATA 2TB drive, then I could not run or install from the DVD, I just got busybox and initramfs error and the PC was locked.

I read that this might be a SATA bios issue and the tip was to change the SATA mode or choose RAID option, I have no SATA mode menu in mi BIOS (Dell E521) for SATA so I chose the RAID option. It made no difference for me, but then I tried disconnecting both my HDD SATA drives and voila! it worked fine. Once installed I could plug the other HDD's back in and its still works fine.

Sébastien DUBOIS (seb-ipsa) wrote :

I have also a secondary Sata hard drive.
I just try to disconnect it and test to boot on live DVD and live USB.
Both works without my secondary hard drive connected.

Thank you for this tip.

Have you more information about this “SATA bios issue”?

ross (ross-rossmoore) wrote :

Hmm, well this is pretty buggy. I'm not about to pull apart my computer to get this to boot, I'd rather move to another distro.

Lionel Blestel (lblestel) wrote :

Hi, same problem with me

USB stick 8Go created with unetbootin and ubuntu 13.10 x64

Intel Core 2Duo
Ram 2Go
HD 750 Go + HD 1000 Go + SSD 60Go

Actually, my desktop works more less fine with Ubuntu 12.04 32bits

Many comments of this issue are about x64 version
Is it a 64 bits issue ?

I no longer have this problem.

This is my setup and changes that I tried.

Clevo P150EM (custom BIOS by prema)
  SSD (windows)
  HDD (general data)
  mSATA SSD (ubuntu)

I know the problem wasn't with the boot media itself. I tried different USB ports, usb sticks and usb creator software packages (YUMI, unetbootin, Universal USB Installer, and dd), all of which gave failed boot with 13.10 x64 (initramfs). The same live USBs worked fine on my desktop computer.

I installed 12.04 x64 and thenafter 13.04 x64 which worked fine.
I could successfully upgrade 13.04 to 13.10.
I flashed my BIOS back to the stock versions supplied by CLEVO, but still had the same problem with the 13.10 live usb.
I disconnected all disks (HDD SSD) apart from the mSATA.
I tried formatting the mSATA disk with gparted live usb (new partition table and new partitions) - still no luck.
I noticed on my 13.10 install (upgraded from 13.04) that nautilus listed a few extra partitions under "Devices" that I didn't recognise. When I selected these partitions they failed to mount.

These looked like they were being picked up somehow from when I was playing around with archlinux and btrfs (whole disk filesystem, compression no partitions), despite my attempts and deleting all existing partitions with gparted and creating a new partition table.

I zeroed the disk with dd, after which I could install 13.10 successfully from live usb.

So possible solution is zeroeing disk with dd? someone my be able to suggest more from what I found.

hope that helps

hhmze (hhmze-n) wrote :

Problem solved (at least for me)!

This is valid for all PC's!

1. Remove all HDD's physically
2. Configure in BIOS your SATA port(s) "hot-swap-capeable"
3. Boot your PC with the Ubuntu 13.10 Live CD/USB device
4. Ignore error: "no physical device found"
5. If you are on GUI-level re-attach your HDD(s) and install Ubuntu

The problem occurs espacially if your previous installation contains a Software-Raid (mdadm) in combination with full encryption (cryptsetup)

Good luck!

I had the same problem, but I was able to install 64-bit Ubuntu Studio 13.10 from DVD to (PNY 120GB) SSD after I removed my secondary HDD (Samsung Spinpoint F1 640GB) power+SATA cables. After installation I put the cables back and now the system works with both drives connected to PC.

My PC setup:
- MB: Gigabyte GA-MA790XT-UD4P
- HDD1: PNY 120GB SSD (SSA2S120GC2DE08-TA / SSD9SC120GEDE)
- HDD2: Samsung Spinpoint F1 640GB SATA (HD642JJ)
- RAM: 2 X G.Skill 4GB DDR3-1600 (F3-12800CL9D-4GBNQ)
- Graphics: Palit GeForce GTS250 - 1GB DDR3 Green Edition (NE3TS25NFHD02)
- DVD: Samsung SH-S223B/BEBE
- CPU: AMD Phenom II X4 905e (HD905EOCGIBOX)

Lo_pescofi (corbieres) wrote :

If I summarize all the comments, it is not possible to install Ubuntu 13.10 if you have multiple hard disks connected.
Does anyone have successfully installed 13.10 with more than one disc connected ?
Personally, I have a disc for OS (and another for datas (/home) . I concluded that I can not uses this distrib.... :-(
Thank's

Lo_pescofi (corbieres) wrote :

Oupps... sorry, no "(" after word "OS"

Olmo Rupert (squaricdot) wrote :

removing all physical hard drives works for me too. the live cd starts.

i had two drives. removing one of them was not enough.

wolfgang (wolfgang-fuchs) wrote :

I solved the issue by physically disconnecting one of my 4 drives, installing 13.10 with Live-USB, and reconnecting the one HDD.

WDC WD5000AAKX-00ERMA0 (15.01H15) *
WDC WD1500ADFD-00NLR5 (21.07QR5)
SanDisk SDSSDP128G (2.0.0) - root
WDC WD5000AAKS-65YGA0 (12.01C02) *

* one of them was disconnected (I'm not sure which one)

Perttu Mäkelä (cirbre11) wrote :

I'm personally running a pretty complicated setup with four hard drives, so I'd really like to avoid having to unplug them for installation. Has anyone found any solutions to this problem that doesn't require mucking with the computer guts?

Uli Fahrenberg (fahrenberg) wrote :

So, same problem here.

Live 13.10 USB key created with usb-creator-gtk, tried on a Dell Latitude E6400.

Yesterday, with an unformatted hard disk, it worked: live system came up without trouble.

Today, with a harddisk formatted ext4 (whole disk; no partitions), doesn't work. Boot bails out with an initramfs busybox prompt.

mu3en (mu3en) wrote :

so... the stable Ubuntu release cannot be installed on systems with more than one hard drive, or hard drives formatted with btrfs (in this case both are true).

someone could probably safely decide may be important for modern systems...

sure, tear your (notebook factor) hardware apart (including the ones needed to install to), maybe use a single MBR partition to install Ubuntu... or maybe just use a distribution with a bootable installer instead.

Carl (carl-pair-a-links) wrote :

And I can't remove the internal disks as it voids my warranty, nor can I reformat the disk as it has Win 7 on it for support reasons. Looks like this needs a higher priority to get fixed as I am still stuck on 12.04 (at least it is LTS).

Sébastien DUBOIS (seb-ipsa) wrote :

For information.

Same problem with the daily build, december 4th, of trusty (Ubuntu 14.04 LTS) with the 3.12 kernel.

For my part I have two dd formatted with etx4.

Carl (carl-pair-a-links) wrote :

I had the same problem on a BIOS system. I have another laptop with 2 disks but it used UEFI to boot. It worked fine. Maybe try changing your boot system.

Sébastien DUBOIS (seb-ipsa) wrote :

With my configuration, UEFI and BIOS mode on my mother board GIGABYTE z77X-D3H can't start ubuntu live (USB or DVD) since ubuntu 13.10 with 2 disks connected.

Eromatic (eromatic) wrote :

Same problem here with ubuntu-13.10-desktop-amd64 (21ec41563ff34da27d4a0b56f2680c4f), but with booting on a live DVD. I already have ubuntu-12.10-desktop-i386 installed on one of the hard drives, but haven't been able to do a clean install or test of ubuntu-13.10-desktop-amd64 due to running into the busy box - initramfs wall.

-Computer-
Processor : 4x AMD Athlon(tm) II X4 640 Processor
Memory : 4125MB (973MB used)
Operating System : Ubuntu 12.10
-Display-
Resolution : 1600x900 pixels
OpenGL Renderer : GeForce 9500 GT/PCIe/SSE2/3DNOW!
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : ICE1724 - Chaintech AV-710
Audio Adapter : HDA-Intel - HDA ATI SB
-Input Devices-
 AT Translated Set 2 keyboard
 Logitech Unifying Device. Wireless
 Generic X-Box pad
 Media Center Ed. eHome Infrared Remote Transceiver
 HDA ATI SB Line
 HDA ATI SB Rear Mic
 HDA ATI SB Line Out
 MCE IR Keyboard/Mouse (mceusb)
-Printers-
No printers found
-SCSI Disks-
ATA WDC WD2500YD-01N
ATA ST31000528AS
ATA ST1000DM003-1CH1
HL-DT-ST DVD-RAM GH22LS30
ATA WDC WD400EB-00CP
ATA MAXTOR STM320082
-BIOS-
Date : 04/18/2012
Vendor : American Megatrends Inc.
Version : 4.6.5
-Board-
Name : A960M-M3
Vendor : ECS

David Given (dg-cowlark) wrote :

I've just seen this problem --- but in possibly a more useful context...

I am building a machine. It's got one DVD drive and one disk. I am repeatedly installing a disk, booting a livecd, and examining the disk to see what's on it, deciding I don't want to wipe this one, and moving on to the next one in the pile.

I get this error with *one specific drive*. With other disks installed in its place, everything is fine. So it's got nothing to do with the SATA settings or graphics card, because they haven't changed.

The one peculiarity of the disk that failed is that it doesn't have a partition table --- the filesystem occupies the entire disk. Zeroing out the first few kilobytes of the disk solves the problem and everything boots.

So I'd suggest that there's something wrong with the way the boot script is probing the disk. The filesystem had been correctly found; I was able to mount it using the file in /dev/disk/by-uuid. However, there wasn't an entry for the DVD. I don't know enough about how /dev/disk/by-uuid is populated to be able to point at a specific component, but I bet it's getting terminally confused by an invalid MBR partition table. I'd be really interested to know whether the other people who've ran into this were using brand new disks or disks with a GPT partition table.

Addendum for the desperate:

The disk can be zeroed from the initramfs prompt, using this command:

dd if=/dev/zero of=/dev/sda

Let it run for a few seconds and reboot (you can't ctrl+C it). THIS IS INCREDIBLY DANGEROUS and do not do it on a machine with ANY data on it you want to keep!

E King (eakst7) wrote :

If it helps anyone, I'm attaching casper.log, dmesg, and the results of ls -l /dev from a failure.

E King (eakst7) wrote :

This problem can be recreated in a trivial VirtualBox environment by attaching a virtual disk image with no partition table, such as a btrfs volume occupying an entire device directly. I've attached a virtual disk image of such a device. Simply attach this device as the only harddisk to a vanilla VirtualBox instance and boot an ubuntu live cd image.

Martin Olsson (mnemo) wrote :

I spent hours trying to boot from a 13.10 usb stick today and yesterday; wondering if the USB stick had bad sectors, trying various BIOS settings and also trying various different .iso to USB writing software like usb-creator-gtk and unetbootin etc.

I'm very disappointed that Ubuntu shipped with this bug present; it feels arrogant/evil to waste people's time like this. I feel like I have been kicked in the balls, really.

purpleoptic (jonothon-nihill) wrote :

Bug seems to be present in the 14.04 (daily) iso as well

E King (eakst7) on 2014-01-09
affects: ubuntu → casper (Ubuntu)
Alex Mekkering (a-launcupad-d) wrote :

I can confirm that my installation (see comment #5) also contains HDD's without partition table.
In fact, most of them (except the boot disk) are completely occupied as btrfs volume, so no MBR or GPT is present at these disks.
My boot disk uses GPT and I boot using UEFI.

Sébastien DUBOIS (seb-ipsa) wrote :

Same for me.
No partition table in the second HDD (ext4).

Phil Wyett (aura-yoda) wrote :

Could you try todays trusty (14.04) live image please?

I have had this issue for some time and images from 2014-01-09 have booted fine with multiple hard disks in my boxen.

Phil Wyett (aura-yoda) wrote :

One note. Most Gigabyte motherboards struggle booting off a USB created with the USB creator app because it does not use FAT 16.

For gigabyte motherboards I use this method for non persistant live ISO USB sticks.

Blank USB stick...

# Change X to device to be wiped.

sudo dd if=/dev/zero of=/dev/sdX bs=4096

Write ISO to disk...

# Change file.iso for path/name of your ISO image.
# Change X to device to be wiped.

sudo dd bs=4M if=file.iso of=/dev/sdX && sync

Then try boot it.

Phil Wyett (aura-yoda) wrote :

Re #39

For writing ISO to disk the line should be.

  # Change X to device to be written to.

Sorry, a typo in my own cheat sheet file. :-)

Sébastien DUBOIS (seb-ipsa) wrote :

I try fresh trusty iso (2014-01-11).
I still have the same problem.

Berk Akinci (berka) wrote :

This bug affected me as well; it wasted about 5 hours...
Is it possible to work around this bug by blacklisting any modules? It is appearing to me like the liveCD initramfs doesn't take the blacklists I attempted.

Rar-Kai (rarkai) wrote :

I am having this same problem and I installed this machine from ubuntu over USB in the past, so i know its not because i changed anything. *sigh*

Rar-Kai (rarkai) wrote :

I was able to fix this for myself following instructions here:

https://help.ubuntu.com/community/USB%20Installation%20Media

UNetbootin (Windows or Linux)

UNetbootin automates this task by providing a GUI to create a bootable Ubuntu Live USB drive from an ISO file, and can be run from both an installed Windows or Linux system, or from a liveCD.

Optional: If you need to activate the original Ubuntu livecd boot menu, for example if you want to disable the framebuffer or read the Ubuntu livecd HELP screens and cheatcodes, please make these changes to your USB drive after your UNetbootin installation is completed:

1) Delete the SYSLINUX.CFG file or rename it to be SYSLINUX.OLD

2) Enter the ISOLINUX folder and rename the ISOLINUX.CFG file to be SYSLINUX.CFG. You may or may not need to rename ISOLINUX.BIN to SYSLINUX.BIN, but it won't hurt.

3) Move up to the top level and rename the ISOLINUX folder to be SYSLINUX

purpleoptic (spacefighter209) wrote :

I didnt use unetbootin to generate my usbstick so I'm not sure unetbootin is the problem. I managed to fix it by removing hard-drives until I found the one that caused it to crash to busybox prompt and deleting all the partitions and re doing it in gparted.

E King (eakst7) wrote :

This has nothing to do with the manner in which the USB stick is created. Per comment #33, the
problem can be triggered using the original Live CD ISO mounted as a virtual CD to a VirtualBox
machine in which the only hard disk attached has an unexpected partition table, such as a full volume
BTRFS filesystem.

alak (alak35) wrote :

same here but with ubuntu 12.04.3 busy box - initramfs "no medium live system thing(forgot error mesagge)" . how to fix this? i tried solution above still not work.

Marcos Cardoso (magnnusmacmay) wrote :

Also here with my system.
Not being able to boot live (DVD and USB) Kubuntu 13.10.
The specs are Core 2 Duo, 4GB, 1TB+160GB+160GB+40GB.

I was thinking that it is may be due some sort of mapping to merge as RAID the both disks with 160GB, some nvraidmapper drive, even though I don't have any RAID config. But I'm seeing here that the problem is spread out.

grub (all+ubuntu) wrote :

I used unetbootin and the tip in #44 worked for me. Thanks.

I had a similar problem with booting a live CD ubuntu gnome 13.10, just could not boot it on a Packard Bell TE69KB, so I ended up, by disabling the secure boot and UEFI in the BIOS plus fastboot in win8. I could then boot the live DVD. At this point, I decided to keep this config and try to install ubuntu 13.10. Big mistake, as it installed but the win8 was still there along with some other partitions. I then uninstalled ubuntu . Then i installed ubuntu 13.10 secure by using the whole disk, as I didn't want win8 on the machine at all!!. This has worked out OK, but there is now a problem with the boot-up, there is an error but it still boots up into ubuntu 13.10. There is also a problem with it not shutting down properly, which I'm sure can be fixed either through the BIOS config or graphic card config. Anyway, enough of my ranting, hope this helps somebody.

Eromatic (eromatic) wrote :

#31
I've been able to narrow down my issue to a single hard drive (ATA ST1000DM003-1CH1 (/dev/sdc)). With this hard drive disconnected from the computer, the liveUSB is bootable into the live ubuntu 13.10 64bit OS. An fdisk list states that Disk /dev/sdc doesn't contain a valid partition table. I can recall that this drive was formated through the Disks application, using Partitioning (GPT) under Ubuntu 12.10 32bit. This drive (Seagate) was also a new drive at the time. The hard drive is mountable under a Ubuntu 12.10 32bit install and has shown no issue in reading from and writing to the drive.

Doing (sudo fdisk -l) has shown:

Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

Disk /dev/sdc doesn't contain a valid partition table

Disks application info for /dev/sdc:

SMART assessment- Disk is OK (31° C / 88° F)
Volumes - Drive label / 1.0 TB Ext4
Size - 1.0 TB (1,000,204,886,016 bytes)
Device - /dev/sdc
Contents - Ext4 (version 1.0)
Drive is mounted

(Note that the Device doesn't show as /dev/sdc1.)

In addition, this recent test was done using a USB flash drive loaded through unetbootin to live boot Ubuntu 13.10 64bit. This boot issue is also seen in the current daily builds of Trusty 32bit & 64bit. Assuming that a drive does not contain a valid partition table as seen by fdisk -l, then the live OS boot attempt will fail. LiveUSB testing of Ubuntu 13.04 32bit has shown no such boot issues with this hard drive connected to the computer.

Same problem as in the comment #51 here. :

:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 têtes, 63 secteurs/piste, 19457 cylindres, total 312581808 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x0005625d

Périphérique Amorçage Début Fin Blocs Id. Système
/dev/sda1 * 2048 30300159 15149056 83 Linux
/dev/sda2 30302206 312580095 141138945 5 Étendue
/dev/sda5 30302208 225614707 97656250 83 Linux
/dev/sda6 311531520 312580095 524288 82 partition d'échange Linux / Solaris
/dev/sda7 225615872 311517183 42950656 83 Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Disk /dev/sdb: 750.2 GB, 750156374016 bytes
255 têtes, 63 secteurs/piste, 91201 cylindres, total 1465149168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Identifiant de disque : 0x00000000

le disque /dev/sdb ne contient pas une table de partitions valable

E King (eakst7) wrote :

I finally figured out a workaround.

I was able to boot into a live session by passing the "live-media=" parameter from the boot menu, specifying the device path of my USB device.

(See http://manpages.ubuntu.com/manpages/hardy/man7/casper.7.html for a description of the live-media parameter.)

I was using a Live Lubuntu Trusty nightly, so the specifics instructions may vary, but here's what I did:
1. Boot from my USB stick
2. At the boot menu, highlight "Try Lubuntu without installing"
3. Press F6 to bring up the kernel command line
4. Add "live-media=/dev/xxx1" to the end of the line (but before the final double hypen).

In my case, the path I needed was /dev/sde1, but you will have to use the path to your install media.

Luuk Paulussen (luuk) wrote :

Yes, as above I also used a workaround similar to the one above. I found it here:
http://life.paperblog.com/howto-fix-linux-mint-ubuntu-install-from-usb-failure-drops-to-busybox-328258/
I added LIVEMEDIA=/dev/sdc1

I definitely started looking with the attitude that there was no way that I was going to remove the hard drives to install my OS.

It looks like something is looking on the wrong disk for the installer.

Eromatic (eromatic) wrote :

Using the information as provided by #53 & #54, I was able to boot into the liveOS of Ubuntu 14.04 with the problem hard drive connected, and that the hard drive is detected by the liveOS.

With a Unetbootin liveUSB of Ubuntu 14.04, I did the following:

(Finding the LiveUSB /dev/***1)

1) Allow the liveUSB to boot into the Busybox initramfs command prompt.
2) At the (initramfs) command prompt, type in: blkid
3) From the produced drive list, I assumed that the only TYPE="vfat" that was listed had corresponded to the liveUSB flash drive, as that was the only connected device using FAT32. The vfat in my case was listed for /dev/sdf1
4) To reboot the computer, at the (initramfs) prompt, type in: reboot

(Second part using Unetbootin liveUSB)

1) Highlight "Try Ubuntu without installing".
2) Press the Tab key to bring up the boot parameters.
3) I then changed my line of:

/casper/vmlinuz.efi initrd=/casper/initrd.lz file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash -- persistent

to

/casper/vmlinuz.efi initrd=/casper/initrd.lz file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash live-media=/dev/sdf1 -- persistent

4) Hit enter to continue with the boot into the liveOS.

If using Unetbootin for your liveUSB, one could also make the command persistent by editing the syslinux.cfg that is on the root directory after the creation of the liveUSB. There you should be able to apply the "live-media=/dev/***1" (replace *** with your liveUSB location value) to the "append" lines for "^Try Ubuntu without installing" and "^Install Ubuntu".

Example:

label ubnentry1
menu label ^Try Ubuntu without installing
kernel /casper/vmlinuz.efi
append initrd=/casper/initrd.lz file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash live-media=/dev/sdf1 -- persistent

label ubnentry2
menu label ^Install Ubuntu
kernel /casper/vmlinuz.efi
append initrd=/casper/initrd.lz file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash live-media=/dev/sdf1 -- persistent

Sébastien DUBOIS (seb-ipsa) wrote :

Workaround with live-media parameter to capser works for me.
Thank you for this tip.

Nikita (gn-pavlodar) wrote :

Hello guys. I downloaded Daily Build (12-Mar-2014 07:50) trusty-desktop-amd64.iso - http://cdimage.ubuntu.com/daily-live/current/
Problem was solved for me. Try it.
Hurrah ))

Melissa B (starredsteria) wrote :

I just downloaded the current trusty image today too, but it did not work when installing from DVD with two HDDs connected. Fortunatley I found this thread so was at least able to install after disconnecting one if them. I was going to lose my mine if I didnt find a solution :)

Also didnt work when booting from USB but my guess is that is because I have a Gigabyte 880GM-D2H motherboard.

I tested with the 14.04 Daily build. Does not fix bug. I still get intramfs prompt when booting from DVD and USB stick.

I am running a core I-7 processor and have one 3TB drive with BTRFS and one 3TB drive with EXT4. Oddly unplugging my BTRFS drive and my DVD drive is required to boot from USB. Obviously this is not a very useful solution since it means I cannot use the live disk to install Ubuntu. This seems like a pretty major bug to me.

Also of note, I am able to boot both Debian stable and testing with no problems in both DVD and USB installs without unplugging any drives. This implies it is a specific issue to the Ubuntu kernel since it only effects Ubuntu based distros. I can confirm Mint has the same issue. I've had this problem on Mint and Ubuntu Main since 13.04.

Eromatic (eromatic) wrote :

The trusty-desktop-i386.iso build from 13-Mar-2014 07:48 is still showing the busybox prompt. Workaround with "live-media=/dev/xxx1" remains needed to continue with the boot. (The workaround is also compatible for Mint.)

Eromatic (eromatic) wrote :

The casper package has updated to 1.339 in Trusty. Daily build trusty-desktop-i386 as of 20-Mar-2014 07:50 corrects the busybox boot issue that was seen on the computer with the attached hard drive which did not contain a valid partition table. (The bug is fixed for me.)

Related bug that brought the changes for casper 1.339:
https://bugs.launchpad.net/ubuntu/+source/casper/+bug/1293811

Sébastien DUBOIS (seb-ipsa) wrote :

With the today daily buil of trusty-desktop-amd64.iso, the bug is also fixed for me.

Changed in casper (Ubuntu):
status: Confirmed → Fix Committed
ggallozz (ggallozz-gmail) wrote :

Yessss ! solved from me toot thanks to EKing

 Adding "live-media=/dev/xxx1" to the end of the line (but before the final double hypen)

worked, that's it

hope *buntu developers fix that asap

ggallozz (ggallozz-gmail) wrote :

sorry, i' say "solved for me too"

Hi all,

I downloaded the daily build ( trusty-desktop-i386.iso - 25-Mar-2014 ) and i think this problem persists. I had to add "live-media ..." to make it work.

Diesel (erickit) wrote :

I tried the newest trusty... also same issue. Installing 13.10 or Trusty worked fine for me until I replaced my normal HD for a SSD. I currently have a 24GB Cache and a 450GB SSD. The cache is just formatted with FAT32 to be used for my Linux Distro since I don't need it for a cache anymore.

Anyways, I've tried things I read online like disabling USB 3.0, trying all my USB ports, using AHCI, multiple USB keys, etc...

However, when I type "blkid" my USB key does not show up. Just my partitions on my SSD and cache.

da6930p (da6930p) wrote :

I've downloaded dccff28314d9ae4ed262cfc6f35e5153 md5 hashed ubuntu-14.04-desktop-amd64.iso using pendrive linux tool I've made installation USB.

When i choose install this error occurs. Any comments?

Using HP EliteBook 6930p as notebook.

Diesel (erickit) wrote :

I have verified that this issue with the Lenovo Twist was due to the current BIOS 1.65. Lenovo staff confirmed this. Downgrade to 1.62 until 1.66 comes out.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers