Live CD shutdown can't remove CD

Bug #119309 reported by jerrylamos on 2007-06-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Ricardo Pérez López
hal (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Ricardo Pérez López

Bug Description

On shutdown, CD ejects then immediately is closed by Ubuntu. No time to remove the CD. The CD is then locked and will not eject when the pushbutton is pressed.

jerrylamos (jerrylamos) wrote :

On Gutsy 20070612, today's update, on IBM NetVista 2GHz Pentium 4, problem still there. CD ejects then immediately closes and won't re-open.

On "Restart", does the same thing eject & close. Pushing enter gets a ^M on the screen. Ctrl-Alt-Del gets a message about the system going down for reboot at which point it does nothing. Time for hardware reset button push.

Anything to try? Jerry

jerrylamos (jerrylamos) wrote :

Problem fixed on Tribes 5 & 6 of Gutsy.
Jerry

Jones D. Le (joneslee85) wrote :

bug reopened
I encountered the same bug with gutsy beta

Luke Yelavich (themuso) wrote :

Did you experience the problem with the final release of Ubuntu gutsy?

Changed in casper:
assignee: nobody → gquigs
status: New → Incomplete
David Wilson (mcs6502) wrote :

I encountered exactly this problem with 8.10 (Intrepid) beta desktop CD.

Procedure:

Boot Intrepid beta Ubuntu Desktop CD.
Select Shutdown.

Results:
Ubuntu shuts down, ejects CD tray, closes CD tray, locks CD tray.
System waits for user to press Enter.
System powers off with CD still in drive.

I tested this on two different systems (P4 with SiS chipset and Pentium Dual Core with nVidia chipset).

jerrylamos (jerrylamos) wrote :

Intrepid does the same trick on my Compaq Presario. Reboot or shutdown opens CD and immediately closes it, and will not let me open it up again. On occasion in investigating Intrepid bugs I fire up a Hardy CD Live which works fine.

Jerry

Bryan Quigley (bryanquigley) wrote :

Does this occur with a specific cd-rom drive? Or is this with any?
Please include what drives you are all using, "dmesg | grep CD-ROM"
Thank you.

David Wilson (mcs6502) wrote :

Very interesting. I have tested this problem on 4 different computers with 5 optical drives. 3 of the 5 drives demonstrate the problem while 2 do not.

System #1
[ 22.257970] scsi 1:0:1:0: CD-ROM IDE DVD-ROM 16X 3.10 PQ: 0 ANSI: 5
[ 22.258549] scsi 2:0:0:0: CD-ROM SONY CD-RW CRX210E1 2YS2 PQ: 0 ANSI: 5
[ 22.321922] Uniform CD-ROM driver Revision: 3.20
[ 22.322031] sr 1:0:1:0: Attached scsi CD-ROM sr0
[ 22.323256] sr 2:0:0:0: Attached scsi CD-ROM sr1

The CD-RW drive retracts before the disc can be removed. The DVD-ROM does not.

System #2
[ 5.181475] scsi 4:0:1:0: CD-ROM LITE-ON DVDRW LH-18A1P GL0C PQ: 0 ANSI: 5
[ 5.201576] Uniform CD-ROM driver Revision: 3.20
[ 5.201660] sr 4:0:1:0: Attached scsi CD-ROM sr0

This system demonstrates the problem.

System #3
[ 9.346415] scsi 1:0:1:0: CD-ROM AOpen 12X DVD-ROM/ASH R23 PQ: 0 ANSI: 5
[ 9.440945] Uniform CD-ROM driver Revision: 3.20
[ 9.441143] sr 1:0:1:0: Attached scsi CD-ROM sr0

This system does NOT demonstrate the problem.

System #4
[ 7.907274] scsi 1:0:1:0: CD-ROM LITE-ON DVDRW SHW-1635S YS0F PQ: 0 ANSI: 5
[ 7.991793] Uniform CD-ROM driver Revision: 3.20
[ 7.991925] sr 1:0:1:0: Attached scsi CD-ROM sr0

This system does demonstrate the problem.

Observation: the two drives that do not show the problem are DVD-ROM while the three that do are CD-RW or DVD-RW.

P.S. Should this bug's "Affects" field be updated from Casper to Intrepid?

Changed in casper:
assignee: bryanquigley → nobody
status: Incomplete → Confirmed
David Wilson (mcs6502) wrote :

Ignore my P.S. above - I now know what Casper refers to.

System #5

[ 8.011625] scsi 1:0:0:0: CD-ROM HITACHI DVD-ROM GD-2500 0101 PQ: 0 ANSI: 5
[ 8.100079] Uniform CD-ROM driver Revision: 3.20
[ 8.100353] sr 1:0:0:0: Attached scsi CD-ROM sr0

This one worked properly and matches my previous observation re ROM vs RW drives.

I also tried a DVD-RW burner in an external USB enclosure on system #4:

[ 9.310309] scsi 1:0:1:0: CD-ROM AOpen 12X DVD-ROM/ASH R23 PQ: 0 ANSI: 5
[ 9.453221] Uniform CD-ROM driver Revision: 3.20
[ 9.453422] sr 1:0:1:0: Attached scsi CD-ROM sr0
[ 14.412905] scsi 3:0:0:0: CD-ROM DVD DUAL GO-W0404A 0050 PQ: 0 ANSI: 0
[ 14.427629] sr 3:0:0:0: Attached scsi CD-ROM sr1

This worked properly but as it was not on a motherboard IDE channel I don't know if this data point should be included.

Bryan Quigley (bryanquigley) wrote :

See if you can reproduce this bug on the command line with the eject command.

As expected - we are running a Live CD after all...

$ sudo eject cdrom1
umount: /cdrom: device is busy.
...
eject: unmount of '/cdrom' failed

I have the same problem with Intrepid beta Live CD, as you can see here:

https://bugs.edge.launchpad.net/ubuntu/+source/casper/+bug/277560

Bryan Quigley (bryanquigley) wrote :

How about system #1 with two drives. Could you have the LiveCD in the one that works, and try eject on the one that has the bug?

David Wilson (mcs6502) wrote :

Booting Intrepid in DVD-ROM and inserting a CD into CD-RW drive after
system boots behaves normally - can right click CD icon on desktop and
select Eject or use "eject cdrom1" at shell prompt - CD is unmounted
and tray ejects - disc can be removed and button must be pressed to
retract tray. No sign of problem.

On 10/7/08, Bryan Quigley <email address hidden> wrote:
> How about system #1 with two drives. Could you have the LiveCD in the
> one that works, and try eject on the one that has the bug?
>
> --
> Live CD shutdown can't remove CD
> https://bugs.launchpad.net/bugs/119309
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I now have the problem with the installed Intrepid. I put a DVD movie into the DVD drive, then I eject it (either pressing the hardware button or using right-click -> Eject), and the drive tray closes immediately.

Bryan Quigley (bryanquigley) wrote :

Apparently windows users will occasionally get this as well (http://www.windowsbbs.com/hardware/77230-dvd-drive-opens-then-closes-before-i-can-put-disk.html)

They said on there that the hardware might be going bad. If you have Windows installed or dual-booted on any of the affected machines, see if you can reproduce this on it, try ejecting with the physical button and through My Computer.
If you don't have Windows, try the physical button when inside the BIOS (or booting up).

Please try multiple times, as apparently it can work every now and then, with and without media in the drive.

jerrylamos (jerrylamos) wrote :

On my dead stock completely working Compaq Presario with nothing but Ubuntu's on it, Intrepid Beta CD Live reboot or shutdown opens & closes so quick I can't get the CD out, and even after pushing enter won't let me remove the diskette, not until reboot resets the computer or until I power on after shutdown.

My Via motherboard Intel Celeron 32 bit does exactly the same thing, won't let me remove the disk with rapidfire open-close. I have to do a hardware reset to eject the CD.

The only reason I think this Thinkpad stays open is because it has a manual close.

Jerry

David Wilson (mcs6502) wrote :

Bryan, I have been using my System #2 in Windows with no problems ejecting discs. Furthermore, if I boot my Ubuntu 8.04 (Gutsy) i386 Desktop CD to live session desktop and then shut it down in the same way as for Intrepid, the tray is ejected at the appropriate time and remains out until I press the eject button on the drive.

My two computers works OK in Windows. However, both computers shows the "open-and-immediately-close CD drive" issue.

I just tried with the latest Intrepid live CD, and the problem is still here.

And the Intrepid I've installed in one of my computers is affected by this bug as well, so every time I eject the CD (either using hardware button or via Nautilus), the CD tray opens and immediately closes.

I've included hal as a possible bug source, because the problem affects both live & installed systems.

In my installed system, if I do:

$ sudo /etc/init.d/hal stop

and then unmount (manually) the inserted CD, then I press the hardware eject button on the CD drive and the tray remains opened.

Bug #271202 could be a duplicate of this one (or vice versa, maybe?)

Brian Murray (brian-murray) wrote :

For Intrepid users this bug is likely related to bug 283316.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers