Cannot boot usb live media: hardcoded paths to udevadm (2013.05.24 daily live)

Bug #1184066 reported by Christopher Patrick on 2013-05-25
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Critical
Colin Watson
cryptsetup (Ubuntu)
High
Colin Watson
systemd (Ubuntu)
High
Martin Pitt

Bug Description

Ubuntu Desktop images doesn't boot from USB and the user is dropped to a busybox prompt with the message : "Unable to find a medium containing a live file system"

On tty7 the following error is displayed "/init: line 7: /sbin/udevadm: not found"

both i386 and amd64 affected
not reproducible in virtualbox
not reproducible in dvdrom

TEST CASE:
1. Download Saucy desktop iso build >= 2013.05.24
2. Burn it to a USB stick:
    $ sudo dd if=saucy-desktop-amd64.iso of=/dev/sdX bs=4M
(replace X by the letter corresponding to your stick - be careful to not write to your hard drive)
3. Boot from the stick

ACTUAL RESULT:
After a while, boot failed and the message "(initramfs) Unable to find a medium containing a live file system" is displayed.

from casper/initrd.lz:
njin@njin:~/Ubuntu$ ls -l sbin
total 1920
-rwxr-xr-x 1 njin njin 31536 mag 25 13:29 blkid
-rwxr-xr-x 1 njin njin 1416 mag 25 13:29 brltty-setup
-rwxr-xr-x 1 njin njin 225152 mag 25 13:29 btrfs
-rwxr-xr-x 1 njin njin 46800 mag 25 13:29 cryptsetup
-rwxr-xr-x 1 njin njin 21168 mag 25 13:29 dmraid
-rwxr-xr-x 1 njin njin 6822 mag 25 13:29 dmraid-activate
-rwxr-xr-x 1 njin njin 67536 mag 25 13:29 dmsetup
-rwxr-xr-x 1 njin njin 23072 mag 25 13:29 dumpe2fs
-rwxr-xr-x 1 njin njin 175232 mag 25 13:29 fsck.btrfs
-rwxr-xr-x 1 njin njin 35384 mag 25 13:29 hwclock
-rwxr-xr-x 1 njin njin 43888 mag 25 13:29 kpartx
-rwxr-xr-x 1 njin njin 43584 mag 25 13:29 losetup
-rwxr-xr-x 1 njin njin 914368 mag 25 13:29 lvm
lrwxrwxrwx 1 njin njin 9 mag 25 13:29 modprobe -> /bin/kmod
-rwsr-xr-x 1 njin njin 39704 mag 25 13:29 mount.cifs
-rwxr-xr-x 1 njin njin 10240 mag 25 13:29 mount.fuse
lrwxrwxrwx 1 njin njin 12 mag 25 13:29 mount.ntfs -> /bin/ntfs-3g
lrwxrwxrwx 1 njin njin 12 mag 25 13:29 mount.ntfs-3g -> /bin/ntfs-3g
-rwxr-xr-x 1 njin njin 81632 mag 25 13:29 plymouthd
lrwxrwxrwx 1 njin njin 9 mag 25 13:29 rmmod -> /bin/kmod
lrwxrwxrwx 1 njin njin 3 mag 25 13:29 vgchange -> lvm
-rwxr-xr-x 1 njin njin 10560 mag 25 13:29 wait-for-root

original description:

I made the USB stick with USB startup creator in precise. Tested sha256sum and it checked out. When i rebooted into the USB stick i get following error message
Busybox v1.20.2 (Ubuntu 1:1.20.0-8ubuntu1) built in shell (ash)
Enter 'help' for a list of built-in commands.
(Initramfs) Unable to find a medium containing a lice file system.

description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1184066

tags: added: iso-testing
description: updated
description: updated
Changed in syslinux (Ubuntu):
status: New → Confirmed
summary: - Cannot boot live session 2013.05.24 daily live
+ Cannot boot live session
tags: added: saucy
affects: syslinux (Ubuntu) → casper (Ubuntu)
summary: - Cannot boot live session
+ Cannot boot live session [missed udevadm and udevd]
description: updated

dunno, sorry
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

summary: - Cannot boot live session [missed udevadm and udevd]
+ Cannot boot live media [missed udevadm and udevd]

Critical: As requested by njin (seems reasonable if it's dead in the water)
added media date back to title.

summary: - Cannot boot live media [missed udevadm and udevd]
+ Cannot boot live media [missed udevadm and udevd] (2013.05.24 daily
+ live)
Changed in casper (Ubuntu):
importance: Undecided → Critical
Fabio Marconi (fabiomarconi) wrote :

Hallo Dave,
I've removed the date because it is reproducible in today's builds too.
Thanks
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

description: updated
description: updated
description: updated
Dave Gilbert (ubuntu-treblig) wrote :

hmm, that last update about it not being reproducable in virtualbox is odd; if it was missing something from the image then why would it make any difference if booted in virtualbox?

I'm also confused by some of the earlier description; there seem to be two things described:
   * an init missing udevadm
   * a 'unable to find medium...' message

is it only the udevadm one happening now or both?
Are you still using the same thumbdrive image in virtualbox?

summary: - Cannot boot live media [missed udevadm and udevd] (2013.05.24 daily
+ Cannot boot usb live media [missed udevadm and udevd] (2013.05.24 daily
live)
description: updated

OK, lets go back to how you got the thumb drive image.
The original message said that you built the image using a USB startup creator on precise.

Is that still true?

You shouldn't need to do that, you should be able to just dd the image onto a thumbdrive.

Dave

Yes I used USB startup creator at first dried not work so I dd the image and it did not work for me either.

Fabio Marconi (fabiomarconi) wrote :

Hallo Dave
Let me clarify:
I've booted normally the image from the usb key and it run splash screen, plymouth, then jump
into busy box with the message mentioned by cpatrik08.
I run again excluding plymouth and i've obtained a lot of:
/init: line 7: /sbin/udevadm: not found
I've extracted initrd.lz and effectively the file (udevadm) is not present in /sbin.
I've opened the initrd.lz of raring to compare and in Raring it exist (/sbin/udevadm) and I've also noted the lack of udevd.
The bug is not reproducible in Vbox because it start from cdrom - dvdrom

Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

I confirm what Fabio said. It fails when booting from a USB stick not in a VM, when the boot screen is disabled "/init: line 7: /sbin/udevadm: not found" is displayed on tty7 and after a while on tty1 the user is dropped tu busybox and the message "Unable to find a medium containing a live file system." is displayed

Changed in casper (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
description: updated
Colin Watson (cjwatson) wrote :

Martin, I'm going to remove the various hardcoded paths which are part of what caused this; but could you also change /usr/share/initramfs-tools/hooks/udev to copy the /sbin/udevadm symlink as well as its new /bin/udevadm target, for maximum compatibility with initramfs scripts we may have missed?

Changed in systemd (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Martin Pitt (pitti)
Changed in casper (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)

Fabio: udevd is in /lib/systemd/systemd-udevd now.

summary: - Cannot boot usb live media [missed udevadm and udevd] (2013.05.24 daily
+ Cannot boot usb live media: hardcoded path to udevadm (2013.05.24 daily
live)
Changed in cryptsetup (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) on 2013-05-28
Changed in casper (Ubuntu):
status: Confirmed → Fix Committed
Changed in cryptsetup (Ubuntu):
status: Triaged → Fix Committed
summary: - Cannot boot usb live media: hardcoded path to udevadm (2013.05.24 daily
+ Cannot boot usb live media: hardcoded paths to udevadm (2013.05.24 daily
live)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.333

---------------
casper (1.333) saucy; urgency=low

  * Remove hardcoded paths to udevadm (LP: #1184066).
 -- Colin Watson <email address hidden> Tue, 28 May 2013 11:19:12 +0100

Changed in casper (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

> could you also change /usr/share/initramfs-tools/hooks/udev to copy the /sbin/udevadm symlink as well as its new /bin/udevadm target

Oh, of course. Sorry that I missed that.

Changed in systemd (Ubuntu):
status: Triaged → In Progress
Martin Pitt (pitti) on 2013-05-28
Changed in systemd (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cryptsetup - 2:1.4.3-4ubuntu3

---------------
cryptsetup (2:1.4.3-4ubuntu3) saucy; urgency=low

  * Remove hardcoded paths to udevadm (LP: #1184066).
 -- Colin Watson <email address hidden> Tue, 28 May 2013 11:27:27 +0100

Changed in cryptsetup (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 202-0ubuntu8

---------------
systemd (202-0ubuntu8) saucy; urgency=low

  * debian/udev.{preinst,postinst,postrm}: Disable udevadm trigger during
    upgrades, to cause installation failures of packages which call udevadm
    trigger without depending on udev. (LP: #1182948)
  * debian/extra/initramfs.hook: Copy /sbin/udevadm compatibility symlink into
    initramfs. (LP: #1184066)
 -- Martin Pitt <email address hidden> Tue, 28 May 2013 13:13:42 +0200

Changed in systemd (Ubuntu):
status: Fix Committed → Fix Released
Fabio Marconi (fabiomarconi) wrote :

@ cpatrick08
tomorrow will be good.
Thanks to help to improve Ubuntu.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

ubuntu 20130528.1 works

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

tags: added: verification-done
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers