Kubuntu 12.10 bcmwl install failure

Bug #1065827 reported by Scott Kitterman on 2012-10-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Undecided
Martin Pitt
Precise
Undecided
Unassigned
Quantal
Undecided
Martin Pitt
casper (Ubuntu)
Critical
Colin Watson
Precise
Undecided
Unassigned
Quantal
Critical
Colin Watson

Bug Description

Failed for Kubuntu final. Install was with no network. Even though bcmwl-kernel-source is seeded in Kubuntu's ship-live, either doesn't look for it or doesn't find it and tries to download from archive.ubuntu.com, which is unreachable due to no network.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: jockey-kde 0.9.7-0ubuntu11
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
CasperVersion: 1.327
CurrentDmesg:
 [ 42.841138] r8169 0000:04:00.0: >eth0: link down
 [ 42.842220] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
 [ 42.844635] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
 [ 605.128386] r8169 0000:04:00.0: >eth0: link up
 [ 605.129245] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Date: Fri Oct 12 05:51:09 2012
LiveMediaBuild: Kubuntu 12.10 "Quantal Quetzal" - Release i386 (20121012)
MachineType: Dell Inc. Inspiron 1011
PackageArchitecture: all
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/username.seed boot=casper maybe-ubiquity initrd=/casper/initrd.lz quiet splash --
SourcePackage: jockey
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/20/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: CN0Y53
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A00
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd03/20/2009:svnDellInc.:pnInspiron1011:pvrA00:rvnDellInc.:rnCN0Y53:rvrA00:cvnDellInc.:ct8:cvrA00:
dmi.product.name: Inspiron 1011
dmi.product.version: A00
dmi.sys.vendor: Dell Inc.

Scott Kitterman (kitterman) wrote :
summary: - bcmwl install failure
+ Kubuntu 12.10 bcmwl install failure
description: updated
Changed in jockey (Ubuntu):
importance: Undecided → High
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1065827

tags: added: iso-testing
Scott Kitterman (kitterman) wrote :

It's in the pool in the ISO:

/pool/restricted/b/bcmwl/bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu2_i386.deb

Changed in jockey (Ubuntu Quantal):
milestone: none → ubuntu-12.10
Scott Kitterman (kitterman) wrote :

There is no CD source in /etc/apt/sources.list, so it's not looking in the local pool.

Changed in jockey (Ubuntu Quantal):
status: New → Triaged
Scott Kitterman (kitterman) wrote :

It didn't find the CD (this is a USB, actually) repository to install non-free drivers during install either.

Martin Pitt (pitti) wrote :

Turns out this is a bug in building the images.

Changed in jockey (Ubuntu Quantal):
milestone: ubuntu-12.10 → none
status: Triaged → Invalid
Colin Watson (cjwatson) wrote :

This is actually a casper regression from bug 909919, and one we need to fix for release.

affects: jockey (Ubuntu Quantal) → casper (Ubuntu Quantal)
Changed in casper (Ubuntu Quantal):
assignee: nobody → Colin Watson (cjwatson)
importance: High → Critical
milestone: none → ubuntu-12.10
status: Invalid → Triaged
no longer affects: ubuntu-cdimage
Colin Watson (cjwatson) wrote :

There is something else going on here which I don't understand. After fixing the casper regression, software-properties -> Additional Drivers is able to install packages from the CD and thus correctly installs bcmwl-kernel-source on demand. However, it fails to actually load the wl module; and, if I load that module by hand, I still don't appear to get a new network interface. There seem to be multiple problems here.

Martin Pitt (pitti) wrote :

This happens with both u-d-common as well as jockey, but both do nothing more than just apt-get installing the package. Apparently there's something wrong with the module? I'm testing this now on my Atom netbook which has a Broadcom wifi card.

affects: ubuntu-drivers-common (Ubuntu Quantal) → bcmwl (Ubuntu Quantal)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.328

---------------
casper (1.328) quantal; urgency=low

  * Fix path to .disk/info in 41apt_cdrom (LP: #1065827).
 -- Colin Watson <email address hidden> Fri, 12 Oct 2012 12:05:15 +0100

Changed in casper (Ubuntu Quantal):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

So apparently we have two bugs in bcmwl:

- postinst needs to "modprobe wl", or more elegantly, call udevadm trigger on broadcom wlan devices to get the module loaded.
- even after "modprobe wl" the driver doesn't detect any devices; that definitively worked in earlier releases on my netbook (14E4:4315), so this might be a kernel/driver version incompatiblity?

Martin Pitt (pitti) wrote :

The second point is because the b43 driver claims the device by default. Right now the package is designed to work after a reboot, but if we want it to work right after installation, we'd need something like

  rmmod b43 ssb || :
  modprobe wl || :

at the end of the postinst.

Changed in bcmwl (Ubuntu Quantal):
status: New → Triaged
Martin Pitt (pitti) wrote :

Uploaded fixed bcmwl to quantal unapproved.

Changed in bcmwl (Ubuntu Quantal):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 5.100.82.112+bdcom-0ubuntu3

---------------
bcmwl (5.100.82.112+bdcom-0ubuntu3) quantal; urgency=low

  * debian/bcmwl-kernel-source.postinst: Mirror the actions of the installed
    modprobe.d files, i. e. rmmod the b43 driver and try to modprobe wl, so
    that this package works right after installation. (LP: #1065827)
  * debian/bcmwl-kernel-source.postinst: Drop duplicate #DEBHELPER# token. It
    does not currently expand to anything, but it looks confusing.
 -- Martin Pitt <email address hidden> Fri, 12 Oct 2012 14:00:38 +0200

Changed in bcmwl (Ubuntu Quantal):
status: Fix Committed → Fix Released

Hello Scott, or anyone else affected,

Accepted bcmwl into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/bcmwl/6.20.155.1+bdcom-0ubuntu0.0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Adam Conrad (adconrad) on 2013-01-17
Changed in bcmwl (Ubuntu Precise):
status: New → Fix Committed
Changed in casper (Ubuntu Precise):
status: New → Invalid
Scott Kitterman (kitterman) wrote :

Since the bug is for a no network install, how do I test this?

Timo Jyrinki (timo-jyrinki) wrote :

I'd think something along this should work:
1. Put http://cdimage.ubuntu.com/precise/daily-live/current/ (or http://cdimage.ubuntu.com/kubuntu/precise/daily-live/current/) i386 version onto bootable USB stick
2. Replace the bcml-kernel-source .deb at pool/restricted/b/bcmwl/ with a .deb from https://launchpad.net/ubuntu/+source/bcmwl/6.20.155.1+bdcom-0ubuntu0.0.1/+build/4226259
3. Boot.
4. I guess the installation needs to be mimicked with dpkg -i, but then again the actual installation/image bug supposedly was only in quantal and already fixed, and the remaining bug that needs now verification in precise is solely about the driver package itself.

Daniel Manrique (roadmr) wrote :

Hi!

I did a test of this in a Dell Vostro 1520, which has this broadcom chip:

0e:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)

This can use either b43 or wl. First, I did a 12.04.1 installation, with no updates, and no 3rd-party driver installation.

Then I manually installed firmware-b43-installer. This pulled a bunch of firmware files and after that I was able to connect to a wireless network, the module loaded OK.

With things working like this, I installed bcmwl-kernel-source, it pulled version 5.100.82.38+bdcom-0ubuntu6.1 from precise-updates. It compiled the kernel module, the network interface disconnected for a moment and then came back up. I verified the wl module was loaded. I'm still able to access the network.

OK, next I removed (purge) both bcmwl-kernel-source and firmware-b43-installer. The b43 module tries to load but complains about missing firmware. I reinstalled firmware-b43-installer and went back to the point where b43 is working.

I added the -proposed repository and reinstalled bcmwl-kernel-source. It downloaded and installed version 6.20.155.1+bdcom-0ubuntu0.0.1. Again, the interface went down for a moment, then automatically back up with the new module. I confirmed with lsmod that wl is loaded and b43 is not. I'm still able to ping and access the network.

So even though I was unable to reproduce the original failure, at least the new package seems to behave correctly in this scenario, this should cover against the most severe regressions.

Steve Magoun (smagoun) wrote :

I worked with Daniel on the testing in comment #18. Based on the fact that the driver loads automatically upon installation (as described in the changelog entry related to this bug) I'm marking this as verification-done

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.20.155.1+bdcom-0ubuntu0.0.1

---------------
bcmwl (6.20.155.1+bdcom-0ubuntu0.0.1) precise-proposed; urgency=low

  [ Alberto Milone ]
  * New upstream release (LP: #923809).
  * Add 0004-Add-support-for-Linux-3.2.patch:
    - Make sure the patch can always be applied.
  * Add 0005-Add-support-for-Linux-3.4.0.patch:
    - Thanks to Eugene San for the patch (LP: #994255).
  * debian/control:
    - Drop all the dependencies on the linux-headers.
  * debian/dkms.conf.in:
    - Always apply all patches (LP: #1020059).

  [ Martin Pitt ]
  * debian/bcmwl-kernel-source.postinst:
    - Silence the errors from rmmod about the modules not being
      loaded. This is fully expected, and just causes confusion,
      as well as autopkgtest failures.
    - Mirror the actions of the installed modprobe.d files,
      i.e. rmmod the b43 driver and try to modprobe wl, so
      that this package works right after installation.
      (LP: #1065827)
    - Drop duplicate #DEBHELPER# token. It does not currently
      expand to anything, but it looks confusing.
  * debian/rules, debian/bcmwl-kernel-source.modaliases:
    - Drop parsing of src/src/wl/sys/wl_linux.c, as the current
      upstream version dropped all useful vendor matches in its
      pci_device_id struct and now has a broken modalias. Keep
      a static debian/bcmwl-kernel-source.modaliases instead
      which matches on any Broadcom network device (vendor 14E4
      class 02 subclass 80). This brings back a proper
      "Modaliases:" package header (LP: #1089943).
 -- Alberto Milone <email address hidden> Thu, 17 Jan 2013 12:38:17 +0100

Changed in bcmwl (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers