Ubuntu

[FFe] [needs-packaging] caribou

Reported by Jeremy Bicha on 2011-09-09
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
caribou (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Caribou is GNOME 3's replacement for gok. It is a themeable on-screen keyboard and library. The standalone caribou tries to intelligently place itself next to the active text input. Unfortunately this doesn't work well in Firefox or in full-screen terminals for instance. It still may improve to be a good competitor to onboard or the basic library could be built into an appropriate Ubuntu-themed screen keyboard similar to what GNOME Shell 3.2 does.

Because Caribou has now been built into GNOME Shell 3.2, we need to get it in the Ubuntu 11.10 repositories or else we risk shipping either an out-of-date GNOME Shell or an ugly patch. Since it is now part of GNOME Core, we can expect it to be maintained.

ricotz has been working with the Debian GNOME team on packaging:
http://anonscm.debian.org/viewvc/pkg-gnome/packages/experimental/caribou/

gnome-control-center has been patched in Ubuntu to load onboard when the screen keyboard has been activated so having caribou in the archives will not interfere with onboard. gnome-control-center could set and look for a gsettings string that sets the preferred on screen keyboard. I don't think we should block caribou based on the g-c-c patch. It should still be possible to run caribou manually (from the command line for instance).

Unfortunately, caribou 0.3.91 doesn't actually run (at least not in standalone mode):
https://bugzilla.gnome.org/show_bug.cgi?id=658533
GNOME Shell doesn't need caribou to work though, just that it's installed.

Jeremy Bicha (jbicha) on 2011-09-09
description: updated
tags: added: needs-packaging
description: updated
description: updated
description: updated
Martin Pitt (pitti) wrote :

I'm ok with this as it doesn't break control-center, and blocks gnome-shell updates. Supposedly upstream will work on the startup failure in standalone mode.

Changed in ubuntu:
status: New → Confirmed
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - [FFe] [needs-packaging] caribou
+ [needs-packaging] [FFe] [needs-packaging] caribou
Changed in ubuntu:
importance: Undecided → Wishlist
Jeremy Bicha (jbicha) on 2011-09-10
summary: - [needs-packaging] [FFe] [needs-packaging] caribou
+ [FFe] [needs-packaging] caribou
Martin Pitt (pitti) wrote :

Luke and I discussed that this morning. Unfortunately there is no easy way to make the old at-spi and the new at-spi2 stack work in parallel, so we need to eliminate the last few reverse dependencies of the old at-spi. dasher was already updated, gok is the last relevant one. So because gok is totally broken now, the urgency for caribou rised a lot, so FFE granted.

Changed in ubuntu:
importance: Wishlist → High
Jeremy Bicha (jbicha) wrote :

caribou 0.3.92 works so I'm attaching a branch...or we could just wait for it to be released in Debian experimental.

Martin Pitt (pitti) wrote :

I fixed the two wrong field names in debian/copyright (see lintian), and uploaded. Thanks!

Dmitry Shachnev (mitya57) wrote :

This bug was fixed in package caribou - 0.3.92-0ubuntu1

---------------
caribou (0.3.92-0ubuntu1) oneiric; urgency=low

  * Initial release (LP: #845300)
 -- Jeremy Bicha <email address hidden> Fri, 23 Sep 2011 13:45:16 -0400

affects: Ubuntu Oneiric → caribou (Ubuntu Oneiric)
Changed in caribou (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers