Drop dependencies on qtdeclarative5-* transitional packages

Bug #1583079 reported by Timo Jyrinki on 2016-05-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webapps-sprint
Low
Alberto Mardegan
address-book-app (Ubuntu)
Undecided
Renato Araujo Oliveira Filho
camera-app (Ubuntu)
Undecided
Unassigned
content-hub (Ubuntu)
Undecided
Unassigned
dialer-app (Ubuntu)
Undecided
Unassigned
gallery-app (Ubuntu)
Undecided
Unassigned
kubuntu-meta (Ubuntu)
Undecided
Unassigned
mediaplayer-app (Ubuntu)
Undecided
Unassigned
messaging-app (Ubuntu)
Undecided
Unassigned
notes-app (Ubuntu)
Undecided
Unassigned
pay-service (Ubuntu)
Medium
Timo Jyrinki
reminders-app (Ubuntu)
Undecided
Unassigned
telephony-service (Ubuntu)
Undecided
Unassigned
u1db-qt (Ubuntu)
Undecided
Unassigned
ubuntu-html5-theme (Ubuntu)
Undecided
Unassigned
ubuntu-keyboard (Ubuntu)
Undecided
Unassigned
ubuntu-push-qml (Ubuntu)
Undecided
Unassigned
ubuntu-settings-components (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings-online-accounts (Ubuntu)
Undecided
Timo Jyrinki
ubuntu-touch-meta (Ubuntu)
Undecided
Unassigned
ubuntu-ui-extras (Ubuntu)
Undecided
Unassigned
ubuntuone-credentials (Ubuntu)
Medium
Timo Jyrinki
unity-webapps-qml (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Olivier Tilloy

Bug Description

** Please include offered MPs in your next landings of the projects **

With Ubuntu 16.04 LTS as the recommended deadline many packages managed to transition to qml-module-xyz package naming from the qtdeclarative5-xyz-plugin package naming (bug #1342031). The next step is to update all packages that depend on transitioned qtdeclarative5-xyz-plugin to depend on the proper qml-module-xyz packages instead.

The goal is to then drop the transitional packages now that 14.04 LTS -> 16.04 LTS upgrades are secured for all the packages that made the transition before 16.04 LTS release.

You can run the following (not 100% complete) to automate this:

sed -i 's/qtdeclarative5-accounts-plugin/qml-module-ubuntu-onlineaccounts/' debian/control
sed -i 's/qtdeclarative5-qtcontacts-plugin/qml-module-qtcontacts/' debian/control
sed -i 's/qtdeclarative5-ubuntu-ui-toolkit-plugin/qml-module-ubuntu-components/' debian/control
sed -i 's/qtdeclarative5-ubuntu-thumbnailer0.1/qml-module-ubuntu-thumbnailer0.1/' debian/control
sed -i 's/qtdeclarative5-qtquick2-plugin/qml-module-qtquick2/' debian/control
sed -i 's/qtdeclarative5-online-accounts-client0.1/qml-module-ubuntu-onlineaccounts-client/' debian/control
sed -i 's/qtdeclarative5-window-plugin/qml-module-qtquick-window2/' debian/control
sed -i 's/qtdeclarative5-xmllistmodel-plugin/qml-module-qtquick-xmllistmodel/' debian/control
sed -i 's/qtdeclarative5-folderlistmodel-plugin/qml-module-qt-labs-folderlistmodel/' debian/control
sed -i 's/qtdeclarative5-localstorage-plugin/qml-module-qtquick-localstorage/' debian/control
sed -i 's/qtdeclarative5-test-plugin/qml-module-qttest/' debian/control
sed -i 's/qtdeclarative5-ubuntu-web-plugin/qml-module-ubuntu-web/' debian/control
sed -i 's/qtdeclarative5-quicklayouts-plugin/qml-module-qtquick-layouts/' debian/control

Related branches

description: updated
Alberto Mardegan (mardy) on 2016-05-18
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
Changed in webapps-sprint:
assignee: nobody → Alberto Mardegan (mardy)
milestone: none → sprint-23
status: New → Confirmed
no longer affects: ubuntu-push (Ubuntu)
Timo Jyrinki (timo-jyrinki) wrote :

Since this does not require much brain power, I can provide branches. Just take care of adding them to your landings.

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
assignee: Alberto Mardegan (mardy) → Timo Jyrinki (timo-jyrinki)
description: updated
dobey (dobey) on 2016-05-19
Changed in pay-service (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
importance: Undecided → Medium
status: New → In Progress
Changed in ubuntuone-credentials (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
importance: Undecided → Medium
status: New → In Progress
description: updated
description: updated
David Barth (dbarth) on 2016-05-31
Changed in webapps-sprint:
importance: Undecided → Low
David Barth (dbarth) on 2016-05-31
Changed in webapps-sprint:
milestone: sprint-23 → backlog
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pay-service - 15.10+16.10.20160520-0ubuntu1

---------------
pay-service (15.10+16.10.20160520-0ubuntu1) yakkety; urgency=medium

  [ CI Train Bot ]
  * Resync trunk.

  [ Rodney Dawes ]
  * Add pep8 and pyflakes3 test rules. Clean up the warnings from pep8
    and pyflakes. (LP: #1421343)
  * Get rid of the glib usage entirely as we don't need it any more.
    Also remove the vendorized glib bindings. (LP: #1580195)
  * Use the ual API to get the icon path for the app for in-app
    purchases. (LP: #1582396)

  [ Timo Jyrinki ]
  * Stop depending on transitional packages. (LP: #1583079) Run wrap-
    and-sort -a -t on the packaging. (LP: #1583079)

 -- Rodney Dawes <email address hidden> Fri, 20 May 2016 14:27:32 +0000

Changed in pay-service (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-credentials - 15.11+16.10.20160608

---------------
ubuntuone-credentials (15.11+16.10.20160608) yakkety; urgency=medium

  [ Rodney Dawes ]
  * Don't exit 1 on non-errors, and set -e to exit on normal errors.
    (LP: #1503190)
  * Remove the superfluous validateInput method.

  [ Timo Jyrinki ]
  * Stop depending on transitional packages. (LP: #1583079) Run wrap-
    and-sort -a -t -s on the packaging. (LP: #1583079)

 -- Rodney Dawes <email address hidden> Wed, 08 Jun 2016 16:31:42 +0000

Changed in ubuntuone-credentials (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings-online-accounts - 0.7+16.10.20160610-0ubuntu1

---------------
ubuntu-system-settings-online-accounts (0.7+16.10.20160610-0ubuntu1) yakkety; urgency=medium

  [ Alberto Mardegan ]
  * Immediately accept degenerate requests from unconfined processes
    (LP: #1582824)
  * Replace incorrect usage of UbuntuColors (LP: #1581047)
  * Update pot file for translations (LP: #1533091)
  * Open popups in an overlaid webview (LP: #1428591)
  * Skip tests on arm64 (LP: #1585942)

  [ Alberto Mardegan, Timo Jyrinki ]
  * Stop depending on transitional packages. (LP: #1583079)

 -- Alberto Mardegan <email address hidden> Fri, 10 Jun 2016 09:46:37 +0000

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+16.10.20160615.1-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+16.10.20160615.1-0ubuntu1) yakkety; urgency=medium

  [ Michael Sheldon ]
  * Add support for Latvian keyboard layout (LP: #1539121)
  * Don't send preedit events when preedit is disabled (LP: #1448145)
  * Support all types of space character when checking for autocaps and
    double space full-stop insertion
  * Add icon to keyboard autopilot test application to avoid bug
    #1591192
  * Ensure wide characters (e.g. Chinese) fit on 'Next' key (LP:
    #1588635)
  * Fix emoji autopilot tests

  [ Timo Jyrinki ]
  * Stop depending on transitional packages. (LP: #1583079)

 -- Michael Sheldon <email address hidden> Wed, 15 Jun 2016 12:45:56 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: New → Fix Released
Changed in reminders-app (Ubuntu):
status: New → Fix Committed
Simon Quigley (tsimonq2) on 2016-08-16
summary: - Drop depedencies on qtdeclarative5-* transitional packages
+ Drop dependencies on qtdeclarative5-* transitional packages
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-extras - 0.2+16.10.20160824.1-0ubuntu1

---------------
ubuntu-ui-extras (0.2+16.10.20160824.1-0ubuntu1) yakkety; urgency=medium

  [ Florian Boucault ]
  * Fix image orientation in photo image provider for Qt>=5.5

  [ Timo Jyrinki ]
  * Stop depending on transitional packages. (LP: #1583079) (LP:
    #1583079)

 -- Kaleo <email address hidden> Wed, 24 Aug 2016 15:47:28 +0000

Changed in ubuntu-ui-extras (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.4+17.04.20161109.1-0ubuntu1

---------------
ubuntu-system-settings (0.4+17.04.20161109.1-0ubuntu1) zesty; urgency=medium

  [ Daniel van Vugt ]
  * Allow scroll speed multipliers up to 3.0; since the default speed in
    (LP: #1607240, #1627567)

  [ Ken VanDine ]
  * Updated example plugin to work with current SDK
  * Fixed pep8 failure

  [ Timo Jyrinki ]
  * Stop depending on transitional packages. (LP: #1583079) (LP:
    #1583079)

  [ jonas-drange ]
  * Drop “at” from “Updated at <date>” string

 -- Ken VanDine <email address hidden> Wed, 09 Nov 2016 15:27:26 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: New → Fix Released
Olivier Tilloy (osomon) on 2016-11-15
Changed in unity8 (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.15+17.04.20161129-0ubuntu1

---------------
unity8 (8.15+17.04.20161129-0ubuntu1) zesty; urgency=medium

  [ Albert Astals Cid ]
  * Fix PreviewProgress implicitHeight (LP: #1641943)
  * Adapt to dummy notification being gone
  * Fix autopilot test_lock_screen tests
  * Autopilot: Add more applications to the list for wider screens
  * Fix autopilot DashHelperTestCase.test_search
  * Also install the Screens mock
  * Give default value to gu-px size

  [ Andrea Azzarone ]
  * Set Mir.cursorName to "grabbing" on first mouse press on a window
    decoration. Don't wait for press+motion. (LP: #1618078)
  * Do not show a divider between each quicklist entry but just between
    each section, similar to how unity7 does. (LP: #1637478)

  [ Andrea Cimitan ]
  * Fix white text (LP: #1644468)
  * Make MascotLoader in CardCreator flat
  * Make the remaining UbuntuShape flat
  * added dropshadow from panel indicators to dash page header extra
    panel, so there is right shadow when the extra panel is narrow
  * Look up for expandable template dash category flag

  [ Brian Douglass ]
  * Added a setting to enable/disable the indicator dropdown menu.

  [ Daniel d'Andrada ]
  * There's no need for WindowDecoration to access the appDelegate

  [ Lukáš Tinkl ]
  * Enable brightness (laptop backlight) handling on desktop/laptop PCs
    (LP: #1595947)

  [ Michael Zanetti ]
  * disable spread interaction while locked (LP: #1641578)

  [ Andrea Azzarone, Michał Sawicz ]
  * Implement launcher tooltips.

  [ Olivier Tilloy ]
  * Remove dependency on transitional package. (LP: #1583079)

 -- Michał Sawicz <email address hidden> Tue, 29 Nov 2016 09:43:33 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in address-book-app (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers