Camera app can be uninstalled permanently.

Bug #1528955 reported by eDeviser on 2015-12-23
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Unassigned
Software Center Agent
Undecided
Unassigned
camera-app (Ubuntu)
High
Unassigned

Bug Description

When I do long-tapping on the camera app icon, the app store is opened, showing the camera app's descrition.
Then it is possible to click on "Uninstall" to unistall the camera app.
After that the camera app is uninstalled and no photos can be taken, so far so good.

But then it is not possible to reinstall the camera app, because the app can't be found in app store by searching for "camera".

This happened on Nexus 4 in stable channel.
This did NOT happen on Nexus 4 in rc-proposed channel.
This happened on Aquaris E4.5.

Further information here:

eDeviser (wolle3) wrote :
Jacques MEULI (jacques-k) wrote :

This happened also on my Aquaris E4.5

Problems appear after ota 8,5 update
camera app frezze when activate or no the flash.
uninstall camera app with long press
no appear in ubuntu store for reinstall
I'm bloked also

Changed in camera-app:
importance: Undecided → Critical
Changed in camera-app (Ubuntu):
importance: Undecided → High
Changed in camera-app:
importance: Critical → High
Jacques MEULI (jacques-k) wrote :

A provisional answer here:
https://answers.launchpad.net/ubuntu/+source/camera-app/+question/277509

This solution worked on my Aquaris 4,5UE and camera app is working fine now.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in camera-app (Ubuntu):
status: New → Confirmed
Anupam (anupam207) wrote :

@Jacques MEULI (jacques-k) glad the solution worked for you too! But I have a small issue after reinstalling the camera-app using apt-get, I have two functioning camera apps in app menu now; one in the second row as usual, amongst the "featured" apps (along with phone, messaging, browser, clock etc.) and the other is listed alphabetically among all the other apps. The one in the "featured" apps is the updated one while the other is stuck on an older version (no shutter mute option, HDR can be enabled in video mode etc.). Long pressing this other camera icon takes me to a page with only an open button and two word info (see screenshot). Do you have the same issue?

Jacques MEULI (jacques-k) wrote :

If it can help, the deb file of the camera apps for ubuntu touch for manual reinstall

Jacques MEULI (jacques-k) wrote :

Hello anupam, I don't have yout issue, very strange.

I'm not ubuntu touch os specialist, but maybe your camera binary was not deleted when you accidentaly uninstall it, only the shortcut on main screen ? When you have reinstalled the system encountered the old version and put it also in the main scope ?

Do you have reinstalled this app after ota9 update or before ? for me it was in OTA 8,5.

Maybe look with apt-cache search camera-app if you have the both app with different version number ? If yes you can choose to uninstall the one you don't want, with one linux command like this "apt-get uninstall camera-appXXXXX"

Possibly another solution using apps like "tweakgeek" or "ubuntu touch tweak tool".

Very bad solution, you look for the location of the apps with "find / -name "camera"" in the terminal, look for the main app folder, look for the oldest version and delete it and refresh main scope or reboot, maybe the unliked app diseapear, but at your own risk :-(

I've put the .deb camera app if it can help anyone to manually reinstall.

Anupam, if I was In your situation, I keep the two version in case of :-)

Anupam (anupam207) wrote :

I think the right place to report this bug is Software Center Agent
https://launchpad.net/software-center-agent

no longer affects: camera-app
Jean-Baptiste Lallement (jibel) wrote :

This is usually because the camera in the store depends on a version of the framework higher than the version on your device. This can happen if :
- you didn't upgrade to latest OTA and a new version of the camera has been published to the store,
- or a newer version of the camera has been published to the store before the new framework is available on stable (in this case it's a mistake to have published the app)

It is not a bug in the camera but a limitation of the click store.

Changed in software-center-agent:
status: New → Invalid
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions