Camera not usable when application unfocused while in recording mode

Bug #1524885 reported by Roberto Mier Escandon on 2015-12-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
camera-app (Ubuntu)
High
Ugo Riboni

Bug Description

Steps to reproduce:
- open camera app
- record a video (or simply press on button to switch to video recording mode)
- leave camera app in background
- open contacts app
- create a new contact
- press on the + to fill the picture section
- select camera as source of the picture

Expected:
- I can take a picture (picture button enabled, record video button disabled)

Result:
- Instead, the record video button is enabled and i cannot switch to photo mode because its button is disabled.

Bill Filler (bfiller) on 2015-12-11
Changed in camera-app (Ubuntu):
assignee: nobody → Ugo Riboni (uriboni)
importance: Undecided → High
Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww02-2016
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → Confirmed
Ugo Riboni (uriboni) wrote :

The problem is more general than that: whenever switching away from camera-app while the app is in video mode the app will end up in an unusable state: unable to record and unable to switch away from video mode.

Changed in camera-app (Ubuntu):
status: New → In Progress
summary: - Camera after video recording not usable from Contacts app
+ Camera not usable when application unfocused while in recording mode
Bill Filler (bfiller) on 2015-12-15
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Florian Boucault (fboucault) wrote :

Now works with latest release of camera.

Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Changed in camera-app (Ubuntu):
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers