HDR fail on patterned high contrast image

Bug #1519766 reported by royden on 2015-11-25
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
camera-app (Ubuntu)
High
Florian Boucault

Bug Description

Meizu MX4 Ubuntu Touch rc-proposed r178

camera app v. 3.0.0.604

Background: I was taking general forest shots successfully and then tried a close-up of a frost dusted spider web. Capture animation displayed but nothing got shown in Photo Roll aside of the Ubuntu spinner. General shots still succeeded. This happened twice in field, second time with frost dusted, repetitively patterned moss. This was version v3.0.0.595.

Reproduction: place black mosquito net over back-lighted opaque perspex and photograph from 15-20 cm distance (see attachment), with HDR function enabled and phone held steady.

Expected outcome: image captured.

Actual outcome: no image shown in Photo Roll. .Jpeg image file is present in Pictures but corrupt (see attachment), even if viewed on PC. For me, this result is invariable with my test image setup.

It appears that regularly patterned, high contrast scenes cause the HDR routine to "choke". A few months back I saw this with HDR in a high contrast general scene without realising what caused it. Note, camera shake under HDR results in captured image.

With Camera v. 3.0.0.595, the issue would persist even with normal shots after the HDR one. With v. 3.0.0.604 disabling HDR allows image to be captured.

royden (ryts) wrote :
royden (ryts) wrote :
royden (ryts) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in camera-app (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

I can reproduce on arale rc-proposed 178.
Open the photo in comment 1 on a PC with any image viewer, enable HDR on the arale and take a picture of the screen of the PC. The resulting picture is corrupted and after 3 shots the camera hangs.

Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → ww02-2016
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

I don't know if it is relevant but there is the following message in camera-app logs:

QObject::startTimer: Timers cannot be started from another thread
file:///usr/lib/arm-linux-gnueabihf/qt5/qml/Ubuntu/Components/1.3/DraggingArea.qml:27: ReferenceError: MathUtils is not defined

Also attached the output of logcat.

Note that a reboot is required to make the camera work again.

Additional settings of the camera were:
- location tagging off
- highest resolution

Changed in camera-app (Ubuntu):
importance: Undecided → High
Matthew Paul Thomas (mpt) wrote :

royden, on the mailing list you wrote: "if registered with Gallery via File Manager, the file displays
with a 'music-note' thumb". Please report that as a separate bug in the File Manager; images should never have music thumbnails, whether they are corrupt or not.

Bill Filler (bfiller) on 2015-12-15
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in camera-app (Ubuntu):
status: Confirmed → In Progress
Changed in camera-app (Ubuntu):
assignee: nobody → Florian Boucault (fboucault)
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in camera-app (Ubuntu):
status: In Progress → Fix Committed
Changed in camera-app (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers