Photos made with back camera sometimes are unavailable in gallery

Bug #1512257 reported by Nicola on 2015-11-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Pat McGowan
camera-app (Ubuntu)
High
Florian Boucault
thumbnailer (Ubuntu)
Undecided
Unassigned

Bug Description

[Using Aquaris E.4.5]

Sometimes when I take a picture with the back camera it will appear with a "music icon" in the gallery (making it impossible to view)
Also, pictures made with the front camera works fine.

So I must restart my device to make the front camera work again.

Here is a screen capture of what I see in my gallery...

Thanks!

Nicola (jackoswebsolutions) wrote :
description: updated
Pat McGowan (pat-mcgowan) wrote :

@nicola, can you open the photo and is it ok?
Can you see the photo int he camera roll?
Guessing somehow the thumbnail was generated wrong

Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
status: New → Incomplete
summary: - Photo made with front camera sometimes are unaviable in gallery
+ Photos made with front camera sometimes are unavailable in gallery

@Pat, negative I can't see them... let me know if I can help in some way

Michi Henning (michihenning) wrote :

Added camera-app.

Nicola, are you saying that, at some point, the camera app stops working? Or is the camera-app working fine and you then don't see the thumbnail for a photo you have taken?

Are you able to get a terminal session on the phone? If so, it would help us if you could send the logs for the thumbnailer and the camera-app around the time you see a new photo failing to produce a thumbnail.

description: updated
Michi Henning (michihenning) wrote :

Also, if you bring up the app switcher (long swipe from the right edge) and kill the gallery app (swipe up), and then re-start the gallery app, do the thumbnails appear?

Nicola (jackoswebsolutions) wrote :

Hi Michi,
the camera don't stop working, i can make more photos but all becomes unavaiable... and I must restart.
sometimes it happens, sometimes not..so I don't know how to reproduce the issue using terminal too..

Maybe can be helpful if I send you a corrupt picture when the issue comes up again?

Michi Henning (michihenning) wrote :

So, after a re-start, the thumbnails start showing up correctly? If so, there is nothing wrong with the photo itself, otherwise you'd never see a thumbnail at all for that photo. If not, there is something wrong with the photo, in which case attaching one of the non-working photos would hep.

Also please let me know whether killing and re-starting the gallery app fixes it.

Michi Henning (michihenning) wrote :

Also, please let us know, when you see the non-working photos in the gallery app, whether you can get a working one with the photo scope.

Nicola (jackoswebsolutions) wrote :

never used the photo scope on my phone, but I can confirm: killing the gallery app (or restart the device) don't fix it.

thanks!

Nicola (jackoswebsolutions) wrote :

I made a mistake in the bug title! I'm talking about the back camera. The front camera always works fine!

Michi Henning (michihenning) wrote :

So neither re-start nor reboot fixes the problem? Can you please attach one or two of the images that fail? You can find them under ~phablet/Pictures/com.ubuntu.camera/...

To get the photo off the device, connect the phone to a host via USB and run "adb pull /home/phablet/Pictures/com.ubuntu.camera/<filename> <output_filename>"

summary: - Photos made with front camera sometimes are unavailable in gallery
+ Photos made with back camera sometimes are unavailable in gallery
Michi Henning (michihenning) wrote :

Pawel is seeing this: http://imgur.com/a/j2yoW

Seems different though, because the original bug report says that default art (music icon) is shown.

Michi Henning (michihenning) wrote :

I can reproduce this with rc-proposed build 278 on Mako. I'm seeing the same thing as Pawel, with the gallery app showing nothing (just white background) where a thumbnail should be.

To reproduce, start out with a clean cache (thumbnailer-admin clear) and an empty photo roll, and with neither gallery nor camera running.

Take twenty pictures with the camera.

Start the gallery app from the launcher. For me everything works fine at this point, thumbnails show up as expected.

Go back to the camera app (via launcher). Take ten more shots.

Go back to the gallery (via launcher). At this point, the gallery app showed the problem briefly and then crashed, so I re-started the app. After doing that, it showed the thumbnails correctly.

Go back to the camera app, take ten more pictures, back to gallery-app, etc. Eventually, the problem will show up (if the gallery app doesn't crash).

I have verified from the thumbnailer trace that, each time I return to the gallery app, the app asks for thumbnails for the newly-added images (plus a bunch of others), and the thumbnailer correctly returns those.

So, this very much looks like a gallery app problem, not a thumbnailer one.

Setting to "triaged" for thumbnailer so we can track it.

Changed in thumbnailer (Ubuntu):
status: New → Triaged
Changed in thumbnailer:
status: New → Triaged
Changed in gallery-app (Ubuntu):
importance: Undecided → Critical
no longer affects: thumbnailer
Nicola (jackoswebsolutions) wrote :

@ Michi

Yes, i confirm too with krillin. But sometimes the art icon appear instead thumbnail/photo, so them are impossibile to view.
I'm working on it to find a procedure to reproduce the "art icon bug"...

I'll let you know if I find more :-)

Thanks!

Bill Filler (bfiller) wrote :

@nicola
Do you happen to have HDR turned on in camera-app? (swipe up from bottom edge will reveal the option to set HDR mode)

@michi
I think the problem you are describing is something different and we should file a separate bug. I believe Nicola's problem is the images are actually getting corrupt whereas your problem is a bug with gallery.

no longer affects: camera-app
no longer affects: gallery-app (Ubuntu)
Changed in camera-app (Ubuntu):
status: New → Incomplete
importance: Undecided → High
assignee: nobody → Florian Boucault (fboucault)
status: Incomplete → Triaged
Michi Henning (michihenning) wrote :

I've opened a separate bug for gallery app: https://bugs.launchpad.net/ubuntu/+source/thumbnailer/+bug/1521365

Nicola (jackoswebsolutions) wrote :

Yeah Bill, HDR on!

Changed in thumbnailer (Ubuntu):
status: Triaged → Invalid
Florian Boucault (fboucault) wrote :

@nicola I believe we identified and solved your issue with the latest release coming up real soon. Let us know if you still experience the issue.

Changed in camera-app (Ubuntu):
status: Triaged → In Progress
Changed in canonical-devices-system-image:
status: Incomplete → In Progress
Nicola (jackoswebsolutions) wrote :

Good, I will test it up, thanks! :-)

Bill Filler (bfiller) on 2016-01-26
Changed in canonical-devices-system-image:
status: In Progress → Incomplete
Changed in camera-app (Ubuntu):
status: In Progress → Incomplete
Nicola (jackoswebsolutions) wrote :

Confirmed! Fixed!

Changed in canonical-devices-system-image:
status: Incomplete → Fix Committed
importance: Undecided → High
milestone: none → ww02-2016
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers