The delete media dialog (or share the video dialog) will appear without being choosen in photoroll

Bug #1494145 reported by quandan on 2015-09-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
camera-app
Fix Released
High
Florian Boucault
camera-app (Ubuntu)
High
Florian Boucault

Bug Description

current build number: 109
device name: arale
channel: ubuntu-touch/rc-proposed/meizu.en
last update: 2015-09-10 06:07:46
version version: 109
version ubuntu: 20150910
version device: 20150818-0b38025
version custom: 20150814-887-8-46

Steps:
1.Open the camera
2.Take a video with any length
3.Swipe to photoroll
4.Tap the top right corner menu ,There will be :share,delete,edit
5.Tap Edit, the menu disappeared and the video will be full screen
6.Tap the top right corner again

Expectation:
After step 6#, there isn't any option to be chosen

Actual result:
The delete media dialog (or share the video dialog) will appear without being choosen in photoroll, and pops up the confirmation dialog

Notes:It happens every time

Related branches

Changed in camera-app (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in camera-app (Ubuntu):
assignee: nobody → Florian Boucault (fboucault)
status: Confirmed → In Progress
Changed in camera-app:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Florian Boucault (fboucault)
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww02-2016
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package camera-app - 3.0.0+16.04.20151120-0ubuntu1

---------------
camera-app (3.0.0+16.04.20151120-0ubuntu1) xenial; urgency=medium

  [ Albert Astals Cid ]
  * Add missing return in AdvancedCameraSettings::mediaControlFromCamera

  [ Bartosz Kosiorek ]
  * Fix plural form (LP: #1323373)
  * Improve camera performance by optimized size of the png and svg
    files, without changing visual appearance (used compresspng.com and
    compressor.io)

  [ Benjamin Zeller ]
  * Make sure camera-app cmake project works out of the box in the SDK:
    Enable click mode by default Disable click mode in debian rules file
    Add variable UBUNTU_MANIFEST_PATH variable so QtC knows where to
    look for the manifest file Rename camera-apparmor.json =>
    camera.apparmor (editor support) Copy qmldir file to builddirectory
    so QML2_IMPORT_PATH set by QtC does actually work Automatically
    substitute the click architecture in the manifest file Renamed
    manifest.json => manifest.json.in, since manifest file can now be
    specified by the project file (UBUNTU_MANIFEST_PATH) renamed:
    camera-apparmor.json => camera.apparmor manifest.json =>
    manifest.json.in

  [ Florian Boucault ]
  * Slideshow view: hiding the header closes the options menu. (LP:
    #1494145)

  [ Richard Huddie ]
  * Fix for https://bugs.launchpad.net/camera-app/+bug/1514408 (LP:
    #1514408)

  [ Robert Ancell ]
  * Use new QML package names for qml-module-qtquick2, qml-module-
    qttest, qml-module-qtquick-window2, qml-module-qtpositioning.

  [ Sebastien Bacher ]
  * Use the red color for the Delete button as recommended by design

 -- Florian Boucault <email address hidden> Fri, 20 Nov 2015 15:36:19 +0000

Changed in camera-app (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Changed in camera-app:
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers