Camera froze taking picture and would no longer show a preview

Bug #1475895 reported by Pat McGowan on 2015-07-18
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
camera-app (Ubuntu)
High
Florian Boucault

Bug Description

MX4 running 59 from rc-proposed

Zoom fully, took 1 picture which worked fine, took a second picture and the view froze, and the picture was not taken.
Stopped the app.
Started the camera again, the view is black and the controls cause the camera to freeze.
A reboot cleared it.

Pat McGowan (pat-mcgowan) wrote :
Pat McGowan (pat-mcgowan) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in camera-app (Ubuntu):
status: New → Confirmed
Changed in camera-app:
status: New → Confirmed
importance: Undecided → High
Changed in camera-app (Ubuntu):
importance: Undecided → High
Bill Filler (bfiller) on 2015-11-30
no longer affects: camera-app
Changed in canonical-devices-system-image:
milestone: none → ww02-2016
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
status: New → Triaged
Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you?
Thanks in advance.

Changed in canonical-devices-system-image:
milestone: ww02-2016 → none
status: Triaged → Incomplete
royden (ryts) wrote :

Testing the fix released for Bug #1519766 (and likely #1478693) I can reliably freeze the camera-app (v. 3.0.0.616) on rc-proposed Arale r227 by taking HDR images.

Freeze happens around the 3rd or 4th shot of the same subject as reported in Bug #1519766.

HDR shots of shaded lamp in semi-dark room (taking up 3/4 of view) trigger freeze on 4/5th shot.

HDR shots of lamp on small table at distance in semi-dark room do not reliably trigger freeze.

Normal shots do not trigger freeze, with or without zoom AFAIKS.

Freeze comprises either the viewfinder holding the image of the attempted capture and app being no longer responsive and needing to be closed. Re-opening produces "Cannot access camera" error message screen, with access permission or some other error as cause. Reboot needed to regain camera function.

Other freeze seen was a return of the viewfinder to a dark screen, and the same error message screen appearing.

Original reporter did not mention HDR, so I defer to better judgement as to where this bug belongs.

royden (ryts) wrote :

https://bugs.launchpad.net/ubuntu/+source/camera-app/+bug/1519766/comments/6

The above comment by jibel seems to include the sort of hang I refer to here, in his case after 3 shots.

royden (ryts) wrote :

Attached is a sub-set of syslog across a series of photos that failed on the 4th one.

royden (ryts) wrote :
Bill Filler (bfiller) on 2016-01-23
Changed in canonical-devices-system-image:
status: Incomplete → Confirmed
milestone: none → ww08-2016
Florian Boucault (fboucault) wrote :

Moving to separate bug and letting Pat answer on the original issue.

New bug: https://bugs.launchpad.net/ubuntu/+source/camera-app/+bug/1537774

Changed in camera-app (Ubuntu):
status: Confirmed → Incomplete
Changed in canonical-devices-system-image:
status: Confirmed → Incomplete
Pat McGowan (pat-mcgowan) wrote :

Cannot reproduce it although not sure I ever could, lets leave incomplete for now and take off the milestone

Changed in canonical-devices-system-image:
milestone: ww08-2016 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers