Camera black with Qt 5.5

Bug #1450346 reported by Timo Jyrinki on 2015-04-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Zoltan Balogh
camera-app (Ubuntu)
Medium
Unassigned
qtubuntu-camera (Ubuntu)
Medium
Timo Jyrinki
ubuntu-ui-toolkit (Ubuntu RTM)
Undecided
Timo Jyrinki

Bug Description

The camera app is simply black on Qt 5.5.

Update: camera app does not start.

More information about Qt 5.5 at https://wiki.ubuntu.com/Touch/QtTesting
---
ApportVersion: 2.17.2-0ubuntu1
Architecture: armhf
DistroRelease: Ubuntu 15.04
InstallationDate: Installed on 2015-04-28 (2 days ago)
InstallationMedia: Ubuntu 15.04 - armhf (20150428-033424)
Package: qtvideo-node
PackageArchitecture: armhf
Tags: third-party-packages vivid
Uname: Linux 3.4.0-6-mako armv7l
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm autopilot cdrom dialout dip plugdev sudo tty video
_MarkForUpload: True

Related branches

apport information

tags: added: apport-collected third-party-packages vivid
description: updated

apport information

apport information

Timo Jyrinki (timo-jyrinki) wrote :
Timo Jyrinki (timo-jyrinki) wrote :

This can't be retested currently because bug #1461897 prevents successful running of Qt 5.5 on phone.

Timo Jyrinki (timo-jyrinki) wrote :

Qt 5.5 final is now testable on the phone and the bug persists.

Changed in qtvideo-node (Ubuntu):
importance: Undecided → Critical
Changed in camera-app (Ubuntu):
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in camera-app (Ubuntu):
status: New → Confirmed
Changed in qtvideo-node (Ubuntu):
status: New → Confirmed

@ Timo Jyrinki

When setting priority to an Ubuntu package, keep in mind that is prioritization among all the available packages in Ubuntu.

So by setting this bug to "critical" you are saying that it has equal importance as bugs that render the operating system unusable, allows malicious users to hack into the system, or damages user data. Which obviously isn't the case, but rather an issue in an specific application that, even when it's important, it doesn't make the rest of the system harmful or useless.

Because of that, and because this application isn't in the "main" repository, I'm lowering this bug importance to "medium". If you are planing to include the application in the "main" repository, please feel free to raise its importance to "high". Thank you.

Changed in camera-app (Ubuntu):
importance: Critical → Medium
Changed in qtvideo-node (Ubuntu):
importance: Critical → Medium
Timo Jyrinki (timo-jyrinki) wrote :

./camera-app: symbol lookup error: /usr/lib/arm-linux-gnueabihf/qt5/plugins/mediaservice/libaalcamera.so: undefined symbol: _ZN12QMediaPlayer12setAudioRoleENS_9AudioRoleE

Timo Jyrinki (timo-jyrinki) wrote :

qtubuntu-camera needed porting to the new role API, but that does not seem to be enough alone.

Now the camera log says "Cannot create signal socketpair" but this is actually an existing UI Toolkit bug #1484004 that is not properly fixed yet. So it's possible/probable camera-app itself will not require any fixes.

affects: qtvideo-node (Ubuntu) → qtubuntu-camera (Ubuntu)
Changed in qtubuntu-camera (Ubuntu):
status: Confirmed → In Progress
description: updated
Timo Jyrinki (timo-jyrinki) wrote :

I managed to fix the UITK bug properly now, and camera started working! So, all that is needed is qtubuntu-camera porting and UITK fix.

Changed in camera-app (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
status: New → In Progress
Changed in qtubuntu-camera (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Zoltan Balogh (bzoltan) on 2015-12-05
affects: ubuntu-ui-toolkit (Ubuntu) → ubuntu-ui-toolkit (Ubuntu RTM)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtubuntu-camera - 0.3.3+16.04.20151202.1-0ubuntu1

---------------
qtubuntu-camera (0.3.3+16.04.20151202.1-0ubuntu1) xenial; urgency=medium

  [ Florian Boucault ]
  * New release: Support the new AudioRole API in addition to the old
    (LP: #1493851) (LP: #1450346) Make it possible to set resolution at
    application startup by not Don't reset the zoom level when only
    switching recording mode. Allow disabling shutter sound via the
    running process having set a QSettings key. Query the supported
    flash modes directly from Android instead of hardcoding them. Enable
    zoom when in video recording mode, if supported by hardware. Ensure
    the flash is correctly set on recording mode switch added:
    .qmake.conf (LP: #1450346, #1493851)

  [ Timo Jyrinki ]
  * New release: Support the new AudioRole API in addition to the old
    (LP: #1493851) (LP: #1450346) Make it possible to set resolution at
    application startup by not Don't reset the zoom level when only
    switching recording mode. Allow disabling shutter sound via the
    running process having set a QSettings key. Query the supported
    flash modes directly from Android instead of hardcoding them. Enable
    zoom when in video recording mode, if supported by hardware. Ensure
    the flash is correctly set on recording mode switch added:
    .qmake.conf (LP: #1450346, #1493851)

  [ Ugo Riboni ]
  * New release: Support the new AudioRole API in addition to the old
    (LP: #1493851) (LP: #1450346) Make it possible to set resolution at
    application startup by not Don't reset the zoom level when only
    switching recording mode. Allow disabling shutter sound via the
    running process having set a QSettings key. Query the supported
    flash modes directly from Android instead of hardcoding them. Enable
    zoom when in video recording mode, if supported by hardware. Ensure
    the flash is correctly set on recording mode switch added:
    .qmake.conf (LP: #1450346, #1493851)

 -- Florian Boucault <email address hidden> Wed, 02 Dec 2015 10:41:30 +0000

Changed in qtubuntu-camera (Ubuntu):
status: In Progress → Fix Released
Łukasz Zemczak (sil2100) wrote :
Download full text (6.8 KiB)

This bug was fixed in the package ubuntu-ui-toolkit 1.3.1742+15.04.20151209-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-ui-toolkit (1.3.1742+15.04.20151209-0ubuntu1) vivid; urgency=medium

  [ Zoltán Balogh ]
  * Enable building the UITK tests in any case.
  * Remove Q_Q(UCStyledItemBase) because of unused variable warning.
  * Resolve Trusty specific compiler issue not resolving QPointer data on
    connections.
  * Use only the object name when selecting sections and labels in tests.

  [Zsombor Egri ]
  * Update BottomEdge with UI/UX agreed during the sprint. Fixes LP: #1368811.
  * BottomEdge component. Fixes LP: #1368811.
  * Remove build failure on Xenial caused by deprecated Qt functions.
  * Fix BottomEdgeHint consumes activeFocusOnPress handling. Fixes LP: #1517777
  * Migrate DirectionalDragArea from Unity8, named as SwipeArea. Original code
    (from lp:unity8) by: Daniel d'Andrada <email address hidden>.
  * Delete QQuickView when the application quits. Fixing segfault caused by the
    dangling objects in GestireDetector.
  * BottomEdgeHint API changes, deprecating state property, introducing locked
    property to drive visuals lock and click handling.
  * Fixing CheckBox and Switch getting checked property altered after clicked()
    signal is emitted. Fixes LP: #1510919.
  * Add ListItem.swipeEnabled property to block swiping when overlay MouseArea
    is used to drag content. Fixes swiping when leading/trailing actions list
    is empty. Fixes LP: #1500409, LP: #1500416.
  * Follow the new design in BottomEdgeHint.
  * Provide import version information for StyledItem and remove theme.version
    obsolete property.
  * Use QQuickItemChangeListener to listen parent changes, skipping the meta
    object model. Convert UCThemingExtension into a Q_INTERFACE so object_cast<>
    can work with it saving the need to memorise on an item whether it is an
    extended item or not.
  * Set mouseAttached to false to revert regression in UITK gallery.
  * Remove BottomEdgeHint from UITK gallery's MainPage.qml which occludes with
    the bottom-up dragging of the ListView.

  [ Benjamin Zeller ]
  * Avoid unnecessary updates for i18n strings.
  * "MathUtils.clamp, min value should not be bigger than the max value".
    Fixes LP: #1520557.
  * Move MathUtils to Cpp.

  [ Loïc Molinari ]
  * UbuntuShape - Fixed deprecation logging issues.
  * This fix prevents logging a deprecation warning for "image", "color" and
    "gradientColor" properties when the import version is less than 1.3. The
    logging of properties used internally (through the old image wrapper) have
    been removed too since the user might not even have used them.
    Fixes LP: #1519414.

  [ Christian Dywan ]
  * Enable gallery target in qmake.
  * Don't set activeFocusOnPress on TextField but on child only.
    Fixes LP: #1486274, LP: #1513897.
  * Make runtest.sh work out of the box again.
  * Explicitly handle keyboard anchoring in dialog foreground.
    Fixes LP: #1376763.
  * Remove GestureDetector in favor of SwipeArea in BottomEdgeHint. Also make
    possible to assign Action to the ...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → High
milestone: none → ww02-2016
status: New → Fix Committed
importance: High → Medium
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers