Split out Kexi database plugins

Bug #676398 reported by Jaroslaw Staniek on 2010-11-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calligra (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: koffice

Kexi depends on too many optional packages. Each database driver should be packaged separately for the best user experience. For example there is no need for user of file databases to install PostgreSQL or Sybase package(s).

We have this updated HOWTO for several years already in the source tree, would you like to use it?

https://projects.kde.org/projects/playground/libs/predicate/repository/revisions/master/entry/README.PACKAGERS

Feel free to request more information.

summary: - Kexi Package Way Too Monolytic
+ Kexi Package Way Too Monolithic

Alessandro,

Since you did the last koffice update, could you have a look at this?

Jonathan Riddell (jr) wrote :

I don't see installing a couple of database access libraries as being a problem. libsybdb5, libxbase2.0-0 and libpqxx-3.0 aren't large and don't require installing the actual database server.

Splitting up kexi would have people install and run kexi then wonder why it wasn't connecting to their preferred database. Working out that you have to install another package isn't a great user experience.

>> Kexi Package Way Too Monolithic
>> https://bugs.launchpad.net/bugs/676398

On 17 November 2010 15:24, Jonathan Riddell <email address hidden> wrote:
> I don't see installing a couple of database access libraries as being a
> problem.  libsybdb5, libxbase2.0-0 and libpqxx-3.0 aren't large and
> don't require installing the actual database server.

Jonathan,
I have to disagree. All distros properly packaging Kexi have the splitting.
What you say is not excuse for giving up with splitting. Lack of time is.
But the issue was reported to Debian years ago in the time of KOffice
1.4 and now to Ubuntu.

> Splitting up kexi would have people install and run kexi then wonder why
> it wasn't connecting to their preferred database.  Working out that you
> have to install another package isn't a great user experience.

The idea of recommended packages can address that.
In next version plugins would depend on kspread and maybe on openoffice.
Would it make sense to make Kexi dependent on those? This degrades its value.
Would you also add this dependency?

--
regards / pozdrawiam, Jaroslaw Staniek
 http://www.linkedin.com/in/jstaniek
 Kexi & KOffice (http://kexi-project.org, http://identi.ca/kexi,
http://koffice.org)
 KDE Software Development Platform on MS Windows (http://windows.kde.org)

>> Splitting up kexi would have people install and run kexi then wonder why
>> it wasn't connecting to their preferred database. Working out that you
>> have to install another package isn't a great user experience.
>The idea of recommended packages can address that.

How? Either it gets installed when you install kexi or it doesn't and you have to work out how to install it. If kexi had a UI prompt for "you need to install plugin foo, click here to install it" using PackageKit that would solve the problem.

On 17 November 2010 18:15, Jonathan Riddell <email address hidden> wrote:
>>> Splitting up kexi would have people install and run kexi then wonder why
>>> it wasn't connecting to their preferred database.  Working out that you
>>> have to install another package isn't a great user experience.
>>The idea of recommended packages can address that.
>
> How?  Either it gets installed when you install kexi or it doesn't and
> you have to work out how to install it.  If kexi had a UI prompt for
> "you need to install plugin foo, click here to install it" using
> PackageKit that would solve the problem.

Jonathan
Yes, that's what I plan... we're going to have a lot of plugins
anyway, so we'll have to provide feature both for downloadable scripts
from distro-independent locations and binaries from
official/unofficial sources.

--
regards / pozdrawiam, Jaroslaw Staniek
 http://www.linkedin.com/in/jstaniek
 Kexi & KOffice (http://kexi-project.org, http://identi.ca/kexi,
http://koffice.org)
 KDE Software Development Platform on MS Windows (http://windows.kde.org)

Changed in koffice (Ubuntu):
importance: Undecided → Wishlist
summary: - Kexi Package Way Too Monolithic
+ Split out Kexi database plugins
Heimen Stoffels (vistaus) wrote :

I wonder why other distro's do package it properly then...

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Rohan Garg (rohangarg) wrote :

Calligra now has 4 split packages for kexi database drivers ( mysql, Sybase, xbase and PostgreSQL ). Please see https://launchpad.net/ubuntu/+source/calligra/1:2.3.87-0ubuntu1 for the fixed package

Changed in calligra (Ubuntu):
status: New → Confirmed
Rohan Garg (rohangarg) on 2012-03-05
affects: koffice (Ubuntu) → calligra (Ubuntu)
Changed in calligra (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers