Creating a new document on a screen with 768px height places the 'create' button outside of the screen

Bug #1561615 reported by Set Hallstrom on 2016-03-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Calligra
Fix Released
High
calligra (Ubuntu)
Medium
Unassigned

Bug Description

When creating a new document, the button to confirm the options of the newly created document is placed outside of the screen in the bottom.

It is however possible to move the window up using alt-mouseclick-drag. But being a blender user, i always disable this function.

(i reported this bug using ubuntu-bug whcih brought me here. it is a bug in krita though... hoping calligra is what krita is called on launchpad)

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: krita 1:2.9.7-0ubuntu11
ProcVersionSignature: Ubuntu 4.4.0-15.31-lowlatency 4.4.6
Uname: Linux 4.4.0-15-lowlatency x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CasperVersion: 1.368
CurrentDesktop: XFCE
Date: Thu Mar 24 16:07:47 2016
LiveMediaBuild: Ubuntu-Studio 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: calligra
UpgradeStatus: No upgrade log present (probably fresh install)

I try to create a new file, everything is fine. Nothing is out of the norm other than the fact that the window is too big (the window that pops up when you create a new file). The window being too big prevents me from clicking "create file" thus preventing me from even being able to paint. I'm on a Windows 8 if that helps. I'm new to Krita.

Reproducible: Always

Steps to Reproduce:
1.Create a file (Ctrl+N)
2.Click on either custom document or create from clipboard
3.You will notice that you can not re-size or change the window
4.You can't click on "create file"

Actual Results:
That is exactly what happens. Everything else works (Changing background colors, number of layers, PPI setup, etc.) except you (I can't) can't click on "Create file" due to the window being too big and I also can not re-size the window. I also am not able to "scroll" down the window itself. Very frustrating.

Expected Results:
Either allow said user to re-size the window or maybe have the window not be too large?

I am on a windows 8. I downloaded it off of the Chrome browser. It is a 64-bit. Hope I helped.

The size has been changed a few days ago. The next 3.0 version will have it.

Set Hallstrom (sakrecoer) wrote :
Set Hallstrom (sakrecoer) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1561615

tags: added: iso-testing
Ross Gammon (rosco2) wrote :

I can confirm this in my Ubuntu Studio Yakkety VM. I have linked to an upstream bug that claims it has been fixed in the future krita version 3.0.

As a workaround, you can click on the krita icon on the top left of of the "create" window and chose "Move". Then you can drag the window up and click on the "create" button.

Changed in calligra (Ubuntu):
status: New → Confirmed
Changed in calligra:
importance: Unknown → High
status: Unknown → Fix Released
Changed in calligra (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.