[Regression] Does not return cover

Bug #1899700 reported by Linda Lean on 2020-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre (Ubuntu)
Undecided
Unassigned

Bug Description

When I run `ebook-meta --get-cover a.png x.epub` on https://files.lilf.ir/tmp/What%27s%20Her%20Name%20in%20Hufflepuff%20-%20ashez2ashes.epub , I get this error and no cover images:

```
Traceback (most recent call last):
  File "/usr/lib/calibre/calibre/ebooks/metadata/epub.py", line 227, in get_metadata
    cdata = get_cover(raster_cover, first_spine_item, reader)
  File "/usr/lib/calibre/calibre/ebooks/metadata/epub.py", line 211, in get_cover
    return render_cover(first_spine_item, zf, reader=reader)
  File "/usr/lib/calibre/calibre/ebooks/metadata/epub.py", line 197, in render_cover
    return render_html_svg_workaround(cpage, default_log)
  File "/usr/lib/calibre/calibre/ebooks/init.py", line 114, in render_html_svg_workaround
    data = render_html_data(path_to_html, width, height)
  File "/usr/lib/calibre/calibre/ebooks/init.py", line 133, in render_html_data
    result = fork_job('calibre.ebooks.render_html', 'main', args=(path_to_html, tdir, 'jpeg'))
  File "/usr/lib/calibre/calibre/utils/ipc/simple_worker.py", line 252, in fork_job
    return two_part_fork_job(env, priority, cwd)(
  File "/usr/lib/calibre/calibre/utils/ipc/simple_worker.py", line 168, in two_part_fork_job
    listener, w = create_worker(env, priority, cwd)
  File "/usr/lib/calibre/calibre/utils/ipc/simple_worker.py", line 130, in create_worker
    address, listener = create_listener(auth_key)
  File "/usr/lib/calibre/calibre/utils/ipc/server.py", line 141, in create_listener
    l = LinuxListener(address=address, authkey=authkey, backlog=backlog)
  File "/usr/lib/calibre/calibre/utils/ipc/server.py", line 110, in init
    self._listener._unlink.cancel()
AttributeError: 'NoneType' object has no attribute 'cancel'
No cover found
Title : What's Her Name in Hufflepuff
Author(s) : ashez2ashes
Publisher : www.fanfiction.net
Tags : Humor, Friendship, In-Progress, Hannah A., Susan B., Harry Potter, FanFiction, Last Update: 2020/06/18, OC, Last Update Year/Month: 2020/06, Eloise M.
Languages : eng
Published : 2018-08-20T19:30:00+00:00
Identifiers : url:https://www.fanfiction.net/s/13041698/1/
Comments : There's still a lot to explore and experience in a world full of magic even if you never become a main character. In Hufflepuff house, you'll make friendships that will last a lifetime. Also, we have a table of infinite snacks. Gen/Friendship. First Year Complete.
```

This never happened before, and I have recently upgraded my Calibre, so it's probably a regression.

Linda Lean (leanlinda) wrote :

Update: My guess is that the old version used to generate a cover from the first "page" of the ebook when it found no genuine covers, and the new version doesn't do this. I really like the old behavior, any way to get it back, or any alternatives?

Distro packages are not supported here. Distro packages are supported by
your distro.

If you cannot reproduce your problem with
https://calibre-ebook.com/download_linux then it's not a bug in calibre
and you need to ask your distro to fix their intersection of

calibre source code version
python version
qt5 version
various other python module dependencies, or versions thereof

Specifically, the error traceback you reported has been reported several
times here, and continues to be not a bug. You didn't specify the
version of calibre or the operating system you used, but I'm betting
it's a 4.99.x unsupported beta version packaged by debian and derivatives.

tl;dr update to calibre 5.0 or greater, your problems will disappear. Or
tell your distro if they really want to package broken betas, they need
to sync updated versions of those broken betas from Debian, and do so
*promptly*.

 status invalid

Changed in calibre:
status: New → Invalid
Linda Lean (leanlinda) wrote :

Thanks, you were right. (That https://calibre-ebook.com/download_linux failed to install the other day, that was I used Ubuntu's own version.)

Eli Schwartz (eschwartz) wrote :

Norbert Preining, the Debian maintainer, has kindly agreed to try to get Ubuntu updated. Further discussion here: https://lists.debian.org/debian-devel/2020/10/msg00103.html

tags: added: not-our-bug ubuntu-bug
affects: calibre → calibre (Ubuntu)
Changed in calibre (Ubuntu):
status: Invalid → New
Daniel Letzeisen (dtl131) wrote :

"AttributeError: 'NoneType' object has no attribute 'cancel'"

I think you found another way to hit this bug: https://bugs.launchpad.net/ubuntu/+source/calibre/+bug/1898904

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers