startup problem on ubuntu 20.04

Bug #1899035 reported by elwood on 2020-10-08
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
calibre (Ubuntu)
Undecided
Unassigned

Bug Description

from syslog:
Oct 8 16:24:07 n-pc systemd[1754]: Started Application launched by gnome-shell.
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: Traceback (most recent call last):
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: File "/usr/bin/calibre", line 20, in <module>
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: sys.exit(calibre())
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: File "/usr/lib/calibre/calibre/gui_launch.py", line 73, in calibre
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: main(args)
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: File "/usr/lib/calibre/calibre/gui2/main.py", line 543, in main
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: listener = create_listener()
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: File "/usr/lib/calibre/calibre/gui2/main.py", line 514, in create_listener
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: return Listener(address=gui_socket_address())
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: File "/usr/lib/calibre/calibre/utils/ipc/server.py", line 110, in __init__
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: self._listener._unlink.cancel()
Oct 8 16:24:07 n-pc calibre-gui.desktop[299116]: AttributeError: 'NoneType' object has no attribute 'cancel'
Oct 8 16:24:07 n-pc systemd[1754]: gnome-launched-calibre-gui.desktop-299116.scope: Succeeded.

in terminal:
$ /usr/bin/calibre
Traceback (most recent call last):
  File "/usr/bin/calibre", line 20, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 73, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 543, in main
    listener = create_listener()
  File "/usr/lib/calibre/calibre/gui2/main.py", line 514, in create_listener
    return Listener(address=gui_socket_address())
  File "/usr/lib/calibre/calibre/utils/ipc/server.py", line 110, in __init__
    self._listener._unlink.cancel()
AttributeError: 'NoneType' object has no attribute 'cancel'

calibre version:
4.99.4+dfsg+really4.12.0-1build1
ubuntu-focal-universe

ubuntu:
$ uname -a
Linux linux-pc 5.4.0-48-generic #52-Ubuntu SMP Thu Sep 10 10:58:49 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

$ python --version
Python 3.8.5

I do not provide support for people using distro provided packages. If you are using a distro provided package, uninstall it and install the official calibre binary from https://calibre-ebook.com/download_linux and if you can reproduce the bug with that, re-open the ticket. Of course, if you are already using the official binary, apologies and feel free to re-open the ticket immediately :)

 status invalid

Changed in calibre:
status: New → Invalid
elwood (elwood-b) wrote :

ok :)

uninstall

going to download page, install
run
$ calibre --version
calibre (calibre 5.2)

work, but syslog contains:

 gnome-shell[2005]: Window manager warning: Invalid WM_TRANSIENT_FOR window 0x520000e specified for 0x520000c.

gopinath (gopinathv) wrote :

@elwood:
I also faced the same issue (happened after some updates that I did yesterday). I found a workaround by calling calibre-server in command line, and used browser to access the server on the port 8080. This way, we don't get to see the layout that we had or metadata we added to the library or any user entered info. But it serves my purpose temporarily to locate and open from a single window instead of searching through multiple folders inside calibre directory.

I hope some other update fixes it soon.

gopinath (gopinathv) wrote :

If there is a way to keep the existing user entered info, I would love to switch to the official binary version as Kovid pointed out above. @Kovid, can you please suggest a way to keep the structure/custom info as we uninstall distro provided calibre and install official binary version. Thanks. Calibre is a fantastic tool that is a must for every reader to organize and save time.

Kovid Goyal (kovid) wrote :

Just do it, using the official binaries wont affect any user data.

Indeed, changing the program binaries does not have any effect on your
library or settings.

It's the same program either way, libraries can be copied anywhere and
settings are detected based on the program name ("calibre") not the
people who gave you the binary.

Programs very rarely, if ever, care about where you get them from when
determining which user data to read.

Eli Schwartz (eschwartz) on 2020-10-13
tags: added: not-our-bug ubuntu-bug
removed: 20.04 startup ubuntu
Amr Ibrahim (amribrahim1987) wrote :

I have a kind request, if the bug does not affect the upstream project, instead of marking it as invalid, please change the affected package to the Ubuntu one, or duplicate the bug report to another that affects the Ubuntu package, otherwise the Ubuntu maintainers will not know about the bug, and duplicating identical bug reports increases their heat hence importance.

affects: calibre → calibre (Ubuntu)
Changed in calibre (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in calibre (Ubuntu):
status: New → Confirmed
elwood (elwood-b) on 2020-10-15
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers