Cannot start calibre

Bug #1884525 reported by Sunyata on 2020-06-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre (Ubuntu)
Undecided
Unassigned

Bug Description

OS: Lubuntu 20.04

When trying to start calibre i get the following output:

sunyata@bollingen:~$ calibre
Traceback (most recent call last):
  File "/usr/bin/calibre", line 20, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 73, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 529, in main
    app, opts, args = init_qt(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 114, in init_qt
    app = Application(args, override_program_name=override, windows_app_uid=MAIN_APP_UID)
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 875, in __init__
    raise RuntimeError('Failed to load the progress_indicator C extension, with error: {}'.format(pi_err))
RuntimeError: Failed to load the progress_indicator C extension, with error: PyCapsule_GetPointer called with incorrect name
sunyata@bollingen:~$

What i've tried:
* Restarting the computer

Frequency of error: 5/5 (on the computer where the error was found)

Please note: I have the same OS (Lubuntu 20.04) on another computer and there Calibre starts without problems

***

# Additional information

sunyata@bollingen:~$ calibre --version
calibre (calibre 4.99.4)
sunyata@bollingen:~$

Installed using "sudo apt-get install calibre"

Sunyata (tord-dellsen) on 2020-06-22
summary: - Cannot start calibre (using Lubuntu 20.04)
+ Cannot start calibre

> RuntimeError: Failed to load the progress_indicator C extension, with error: PyCapsule_GetPointer called with incorrect name

Your error indicates that the program has been built or installed
incorrectly.

> Installed using "sudo apt-get install calibre"

This means that the problem comes from the apt-get distributors (that is
to say, the Lubuntu packaging team, which apt-get downloads from).

If you instead download the standalone binary builds of calibre from
https://calibre-ebook.com/download_linux I suspect you will find that
they work fine.

Please report this bug to the Lubuntu developers. As a member of the
Debian/Ubuntu family of Linux distributions, they usually prefer bugs to
be reported directly to them -- then they will evaluate the bug, try to
figure out if it is a Ubuntu bug or a bug in calibre itself, and either
fix the bug within Ubuntu or forward it to the calibre developer.

(If, however, you have a problem with the standalone binary builds I
mentioned, then please report those here. Those do receive official
support directly from the calibre developer, and additionally can be
used as a test to reproduce bugs and determine if they are calibre bugs
rather than Ubuntu bugs.)

 status invalid

Changed in calibre:
status: New → Invalid
Sunyata (tord-dellsen) wrote :

The binary build that you gave worked for me, thank you!

I don't have experience with reporting bugs to Lubuntu/Ubuntu, where would i do that?

Thank you for your work with this application (i love it!)

Kind Regards,
Tord

Sunyata (tord-dellsen) wrote :

PS: It's strange though because the version of apt-get is the same on my desktop and laptop computers: apt 2.0.2ubuntu0.1

Eli Schwartz (eschwartz) wrote :

Actually according to https://phab.lubuntu.me/w/bugs/ it looks like
Lubuntu just tracks bugs via Ubuntu itself.

 affects ubuntu/calibre
 status new
 tag lubuntu

Eli Schwartz (eschwartz) on 2020-06-28
no longer affects: calibre
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers