calibre tries to create absurdly large window and fails to run, making unity unusable

Bug #1045344 reported by Rocko on 2012-09-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calibre (Ubuntu)
Undecided
Unassigned

Bug Description

When I run calibre, after it asks which directory to use, an endless sequence of window borders keep appearing and disappearing, preventing user input to any unity windows. The xsession log shows an endless sequence of messages like so:

compiz (opengl) - Info: Couldn't bind redirected window 0x3200004 to texture

compiz (opengl) - Warn: Bug in window 0x3200004 (identifying as calibre)
compiz (opengl) - Warn: This window tried to create an absurdly large window 16385 x 16412

compiz (opengl) - Warn: Unforunately, that's not supported on your hardware, because you have a maximum texture size of 8192
compiz (opengl) - Warn: you should probably file a bug against that application
compiz (opengl) - Warn: for now, we're going to hide tht window so that it doesn't break your desktop

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: calibre 0.8.51+dfsg-1ubuntu3
Uname: Linux 3.6.0-rc4-git-20120902.0814 x86_64
ApportVersion: 2.5.1-0ubuntu4
Architecture: amd64
Date: Mon Sep 3 21:56:18 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_AU:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: calibre
UpgradeStatus: No upgrade log present (probably fresh install)

Rocko (rockorequin) wrote :
Edward Donovan (edward.donovan) wrote :

If you run calibre like this:

  LIBOVERLAY_SCROLLBAR=0 calibre

does the problem go away? In that case, this looks like a form of bug 1005677. Thanks.

Rocko (rockorequin) wrote :

Yes, that's the one.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in calibre (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers