btrfs partioning with calamares results in unbootable system

Bug #1966774 reported by Leó Kolbeinsson
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
calamares (Ubuntu)
Status tracked in Kinetic
Jammy
In Progress
Medium
Simon Quigley
Kinetic
In Progress
Medium
Simon Quigley

Bug Description

Testing Lubuntu Jammy daily ISO 27.03.2022

Test machine AWOW NY41 Int.cel 4125

Selected manual partitioning at install to create btrfs custom partition

All went well with the install but after rebooting the system failed to boot

Received errors "Failed to start Snap Daemon" #Failed to Load Kernel Module drm" and others - see attached screen shot for this machine.

Performed other tests - xfs partitioning and also erase disk full installs with no errors

Also tested 3 other machines - all same failures if btrfs was used.

ProblemType: Bug
DistroRelease: Ubuntu 22.04
Package: calamares 3.2.41.1-0ubuntu3
ProcVersionSignature: Ubuntu 5.15.0-23.23-generic 5.15.27
Uname: Linux 5.15.0-23-generic x86_64
.etc.calamares.modules.finished.conf:
 ---
 restartNowMode: user-checked
 restartNowCommand: "systemctl -i reboot"
.etc.calamares.modules.shellprocess_logs.conf:
 ---
 dontChroot: true
 timeout: 30
 script:
     - calamares-logs-helper @@ROOT@@
.etc.calamares.modules.unpackfs.conf:
 ---
 unpack:
     - source: "/cdrom/casper/filesystem.squashfs"
         sourcefs: "squashfs"
         destination: ""
ApportVersion: 2.20.11-0ubuntu79
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.467
CurrentDesktop: LXQt
Date: Mon Mar 28 14:46:10 2022
LiveMediaBuild: Lubuntu 22.04 LTS "Jammy Jellyfish" - Alpha amd64 (20220327)
RelatedPackageVersions:
 calamares-settings-ubuntu-common 1:22.04.4
 calamares-settings-lubuntu 1:22.04.4
 xfsprogs 5.13.0-1ubuntu2
 btrfs-progs 5.16.2-1
SourcePackage: calamares
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Leó Kolbeinsson (leok) wrote :
Revision history for this message
Leó Kolbeinsson (leok) wrote :

Attached is a screenshot from Lenovo 14VILL machine also tested for btrfs partition and the boot errors.

description: updated
Revision history for this message
Leó Kolbeinsson (leok) wrote :
  • syslog Edit (242.6 KiB, application/octet-stream)

syslog attached

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1966774

tags: added: iso-testing
Revision history for this message
Thomas Ward (teward) wrote :

Tested similar BTRFS root partition layout here, and it exploded as stated here. I was testing in a VM with a fresh ZSync.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in calamares (Ubuntu):
status: New → Confirmed
Revision history for this message
Dan Simmons (kc2bez) wrote :

@leok or @teward do either of you have the Calamares install log? I am not seeing one attached to the bug.

Changed in calamares (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Leó Kolbeinsson (leok) wrote :

@kc2bez

Retested Jammy Beta Lubuntu ISO 20220328.1

Attached is syslog and session log in next comment

Revision history for this message
Leó Kolbeinsson (leok) wrote :

session log from install

Revision history for this message
Chris Guiver (guiverc) wrote (last edit ):

Same result on sony vaio svp112a1cw (lubuntu jammy daily 20220328.1)

install was good, but on reboot it's mostly [FAILED] Failed to start Snap Daemon.. final message was [FAILED] Failed to start Failure handling of the snapd snap.

booted live media again, and mounted to get /mnt/@/var/log/installer/syslog from internal ssd.

Note - it may not be calamares log I grabbed..

Changed in calamares (Ubuntu):
status: Incomplete → New
Revision history for this message
Chris Guiver (guiverc) wrote :

still from live media; mounted the internal ssd on sony vaio thingy
/mnt/@/var/log/installer/debug

Revision history for this message
Leó Kolbeinsson (leok) wrote :

This bug also affects Ubuntu Studio - tested daily ISO 29.1-03-2022 with the same result as in original report.

tags: added: studio
tags: added: ubuntustudio
removed: studio
tags: added: lubuntu
Changed in calamares (Ubuntu):
milestone: none → ubuntu-22.04
Revision history for this message
Erich Eickmeyer  (eeickmeyer) wrote :

Hello Leó or anyone else affected:

calamares 3.2.41.1-0ubuntu4 has been released into Jammy. Please test and report back if this fixes the problem and mark this bug as "Fix Released". If it does not fix the problem, report back, tag this bug as "verification-failed", at which point we'll look into other options.

Changed in calamares (Ubuntu):
status: New → Fix Committed
Revision history for this message
Leó Kolbeinsson (leok) wrote :

@eeickmeyer Erich

Test machine AWOW NY41 Int.cel 4125- Lubuntu Jammy daily ISO 01-04-2022 and same result as in original report - unbootable system after upgrade and reboot.

tags: added: verification-failed
Changed in calamares (Ubuntu):
status: Fix Committed → Confirmed
Revision history for this message
Leó Kolbeinsson (leok) wrote :

Tested Lubuntu Jammy 22.04 and performed the following :

Removed space_cache from btrfs mount options in ..modules/fstab/fstab.conf before installing as suggested by @tsimong2 -

Ran the install and successfully booted the system with a btrfs partition.

Machine tested Dell Optiplex 7040 running in UEFI mode

Simon Quigley (tsimonq2)
Changed in calamares (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
importance: Undecided → Medium
milestone: ubuntu-22.04 → jammy-updates
Changed in calamares (Ubuntu Jammy):
assignee: nobody → Simon Quigley (tsimonq2)
milestone: none → jammy-updates
Changed in calamares (Ubuntu Kinetic):
milestone: jammy-updates → ubuntu-22.05
Changed in calamares (Ubuntu Jammy):
importance: Undecided → Medium
status: New → In Progress
Changed in calamares (Ubuntu Kinetic):
status: Confirmed → In Progress
Revision history for this message
Aaron Rainbolt (arraybolt3) wrote :

Saw the IRC logs - I will update the workaround guide to instruct users to remove the option entirely.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Tested Lubuntu Kinetic daily iso 16-05-2022 and Ubuntu Studio Kinetic daily 15-05-2022 and btrfs install was successfull.

Test machine Dell Optiplex 7040 running in UEFI mode.

Revision history for this message
Aaron Rainbolt (arraybolt3) wrote :

Hardware: HP Z220 SFF Workstation, 32 GB RAM, Intel Xeon CPU, UEFI, no secure boot. Tested Lubuntu 2022-05-16 ISO in virt-manager (QEMU/KVM) with SeaBIOS, 4 GB RAM, 2 CPU cores, and 20 GB disk space, manual partitioning with btrfs install. All good, newly installed system was bootable with no need to modify config files or run special commands before, during, or after the installation.

To post a comment you must log in.