lubuntu focal.2 calamares fails to parse GeoIP results correctly in JSON (refile)

Bug #1908846 reported by Chris Guiver on 2020-12-21
This bug report is a duplicate of:  Bug #1904974: calamares selected wrong timezone. Edit Remove
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calamares (Ubuntu)
Undecided
Dan Simmons

Bug Description

This really is a re-file of https://bugs.launchpad.net/ubuntu/+source/calamares/+bug/1898501 which was closed as INVALID.

Lubuntu 20.04.2 daily QA-test install today has my location in calamares as New York US, not Melbourne AU.

This issue is MINOR, as it's easy for a person performing an install to click the location they live in & get around the issue (even if it takes me 2-3 clicks to select Melbourne; that's easy!)

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: calamares 3.2.20-0ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-59.65-generic 5.4.78
Uname: Linux 5.4.0-59-generic x86_64
.etc.calamares.modules.finished.conf:
 ---
 restartNowMode: user-checked
 restartNowCommand: "systemctl -i reboot"
.etc.calamares.modules.partition.conf:
 efiSystemPartition: "/boot/efi"
 enableLuksAutomatedPartitioning: true
 userSwapChoices: none
 drawNestedPartitions: true
 defaultFileSystemType: "ext4"
.etc.calamares.modules.shellprocess_logs.conf:
 ---
 dontChroot: true
 timeout: 30
 script:
     - calamares-logs-helper @@ROOT@@
.etc.calamares.modules.unpackfs.conf:
 ---
 unpack:
     - source: "/cdrom/casper/filesystem.squashfs"
         sourcefs: "squashfs"
         destination: ""
ApportVersion: 2.20.11-0ubuntu27.14
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.445.1
CurrentDesktop: LXQt
Date: Sun Dec 20 21:38:43 2020
LiveMediaBuild: Lubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20201220)
RelatedPackageVersions:
 calamares-settings-ubuntu-common 1:20.04.2
 calamares-settings-lubuntu 1:20.04.2
 xfsprogs 5.3.0-1ubuntu2
 btrfs-progs 5.4.1-2
SourcePackage: calamares
UpgradeStatus: No upgrade log present (probably fresh install)

Chris Guiver (guiverc) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1908846

tags: added: iso-testing
Chris Guiver (guiverc) wrote :

Lubuntu QA-test install of daily focal on dc7700 (for unrelated T181 testing purposes) had New York again shown as my location in calamares.

Opening firefox & exploring online had me located correctly in Melbourne according to web. No big issue to click Melbourne on map (miss & get Sydney, click again...)

Walter Lapchynski (wxl) wrote :

Am I correct that this is only problematic in Focal? Groovy and Hirsute are fine?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in calamares (Ubuntu):
status: New → Confirmed
Leó Kolbeinsson (leok) wrote :

I can also confirm this -- running ISO http://cdimage.ubuntu.com/lubuntu/focal/daily-live/20210105/focal-desktop-amd64.iso

I also receive New York as location (Reykjavik is correct)

I have only seen this in Focal.

Walter Lapchynski (wxl) wrote :

So I apologizing for the invalid status on the previous bug. I think it was a bit premature, although it may be appropriate after all. Let me explain a bit.

First off, as you can see in the issue, the problem was one specific to the GeoIP provider we were using, ipapi.co:
https://github.com/calamares/calamares/issues/1540

You will also see there that as of v3.2.32 of Calamares that there is now additional debug information (mentioned in the issue):
https://github.com/calamares/calamares/commit/d63e23b289f1f285d190c711ee296778bb7f5259

Unfortunately, that doesn't exist in versions before Hirsute, so I can't very well confirm that is the situation in this case, but it is highly likely.

Additionally, the two changes that resulted in using Ubuntu's GeoIP service that are ultimately the fix for this problem weren't added until after Focal:
https://phab.lubuntu.me/rCALASETTINGS01c0bcafc8f3b7c089a7e7d9a6ca2cb4b793e009
https://phab.lubuntu.me/rCALASETTINGS63230172e442ac55db7bc3ba0bd54f842c210edd

tl;dr if we're going to fix this, it would have to be via an SRU of calamares-settings-lubuntu. The problem is getting it on the ISO. That is much harder. I guess we could get it in a point release, but is that worth the effort? I'm kind of thinking not.

Leó Kolbeinsson (leok) wrote :

@wxl Walter

Thanks for your comments and further info. I agree with you and the OP that the issue is MINOR and the user can easily select the correct location during setup.

Walter Lapchynski (wxl) wrote :

It's remotely possible that we might SRU this, so it might end up appearing in further point release ISOs, but I'm not very much in favor of it.

Meanwhile, the "fix" will be updated release notes, which is in progress as we speak.

Going forward, we're going to look into some mechanism to update Calamares and its settings on launching the installer. This won't keep us from having to go through the SRU process, but it will mean that we won't have to respin ISOs to get installer-releated fixes in place.

Changed in calamares (Ubuntu):
assignee: nobody → Dan Simmons (kc2bez)
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.