calamares data entry; cursor jumps to end of field making editing difficult

Bug #1904266 reported by Chris Guiver
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Calamares
Fix Released
Unknown
calamares (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Lubuntu hirsute daily QA-test install, two boxes
- dell [optiplex] 755 (c2d-e8300, 8gb, amd/ati radeon rv610/radeon hd2400 pro/xt)
- hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

** To re-create

Start an install, get to the "user setup" entry fields where you enter "name, username, hostname, password.."

Enter values.. I noticed this on HOSTNAME.

Going to the hostname field, it was pre-loaded with something from the box firmware itself, I tried amending this..

** Expected behavior

Assume the hostname is preloaded with

"hpcompaqdc7700"

I move the cursor to the beginning of the field, with intention of adding "blah" to the start of it.

I expect either "blahhpcompaqdc7700" (inserted) or "blahmpaqdc7700" (replaced)

** Actual behavior

Instead I get the "bhpcompaqdc7700lah"

because on entry of the first character "b" of "blah", the cursor jumps to the end of the field for the subsequent characters.

This is occurring anywhere in the field (cursor jumps to the end after typing a letter).

I've NOT noticed this behavior before. It's annoying only (easily worked around)

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: calamares 3.2.32.1-0ubuntu1
ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
Uname: Linux 5.8.0-25-generic x86_64
.etc.calamares.modules.finished.conf:
 ---
 restartNowMode: user-checked
 restartNowCommand: "systemctl -i reboot"
.etc.calamares.modules.partition.conf:
 efiSystemPartition: "/boot/efi"
 enableLuksAutomatedPartitioning: true
 userSwapChoices: none
 drawNestedPartitions: true
 defaultFileSystemType: "ext4"
.etc.calamares.modules.shellprocess_logs.conf:
 ---
 dontChroot: true
 timeout: 30
 script:
     - calamares-logs-helper @@ROOT@@
.etc.calamares.modules.unpackfs.conf:
 ---
 unpack:
     - source: "/cdrom/casper/filesystem.squashfs"
         sourcefs: "squashfs"
         destination: ""
ApportVersion: 2.20.11-0ubuntu51
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.455
CurrentDesktop: LXQt
Date: Sat Nov 14 20:31:08 2020
LiveMediaBuild: Lubuntu 21.04 "Hirsute Hippo" - Alpha amd64 (20201113)
RelatedPackageVersions:
 calamares-settings-ubuntu-common 1:20.10.11
 calamares-settings-lubuntu 1:20.10.11
 xfsprogs 5.6.0-1ubuntu4
 btrfs-progs 5.9-1
SourcePackage: calamares
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Chris Guiver (guiverc) wrote :
Revision history for this message
Chris Guiver (guiverc) wrote :

I suspect of no use, but I started filing the bug before install completed.
The session.log is attached.

I've not noticed this behavior (cursor jumping to end of field) anywhere else, but I'll now look for it.

description: updated
description: updated
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1904266

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in calamares (Ubuntu):
status: New → Confirmed
Revision history for this message
Leó Kolbeinsson (leok) wrote :

I can confirm that this occurred on 2 boxes that I tested on Lubuntu 21.04 "Hirsute Hippo" - Alpha amd64 (20201113)

I noted that if I erased the host name suggested by Calamares then I could enter my preferred hos tanem as usual. This only occurred if I tried to add a prefix to the host name without stroking it completely out first - hope this understandable explanation.

Revision history for this message
Chris Guiver (guiverc) wrote :

I'm watching a StevesVeryOwn Coffee Klatch review of peppermint OS, and decided to install it. This issue occurs there (no surprise) ; alas older version of calamares to impish & jammy though (going by package version)

peplive@PepOS-Live:/usr/share/backgrounds$ apt-cache policy calamares
calamares:
  Installed: 3.2.36-1
  Candidate: 3.2.36-1
  Version table:
 *** 3.2.36-1 900
        900 http://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status

Changed in calamares:
status: Unknown → New
Revision history for this message
Chris Guiver (guiverc) wrote :
Changed in calamares:
status: New → Fix Released
Leó Kolbeinsson (leok)
tags: added: kinetic
Revision history for this message
Leó Kolbeinsson (leok) wrote :

Tag for kinetic removed - this is no longer present after update to calamares 3.2.57-1ubuntu1

tags: removed: kinetic
To post a comment you must log in.