Calamares failed: command 'mount' returned non-zero exit status 32.

Bug #1873950 reported by sudodus
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calamares (Ubuntu)
Undecided
Unassigned

Bug Description

Booting in my 'standard test computer' a Toshiba laptop, Calamares failed with the most basic mode, to use the whole drive for the new Lubuntu installation.

http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

Booted in BIOS mode. The partition table in the internal drive is MSDOS. There were two previous operating systems in the drive.

I tried a second time, this time with a clean drive (after the previous try, and this time Calamares worked). So either it was a temporary glitch, or there was some confusion in the first case because of the partition table (which contained and EFI system partition, not only root partitions for a dual boot system).

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: calamares 3.2.20-0ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-25.29-generic 5.4.30
Uname: Linux 5.4.0-25-generic x86_64
.etc.calamares.modules.finished.conf:
 ---
 restartNowMode: user-checked
 restartNowCommand: "systemctl -i reboot"
.etc.calamares.modules.partition.conf:
 efiSystemPartition: "/boot/efi"
 enableLuksAutomatedPartitioning: true
 userSwapChoices: none
 drawNestedPartitions: true
 defaultFileSystemType: "ext4"
.etc.calamares.modules.shellprocess_logs.conf:
 ---
 dontChroot: true
 timeout: 30
 script:
     - calamares-logs-helper @@ROOT@@
.etc.calamares.modules.unpackfs.conf:
 ---
 unpack:
     - source: "/cdrom/casper/filesystem.squashfs"
         sourcefs: "squashfs"
         destination: ""
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.445
CurrentDesktop: LXQt
Date: Mon Apr 20 21:25:04 2020
LiveMediaBuild: Lubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200420)
RelatedPackageVersions:
 calamares-settings-ubuntu-common 1:20.04.2
 calamares-settings-lubuntu 1:20.04.2
 xfsprogs 5.3.0-1ubuntu2
 btrfs-progs 5.4.1-2
SourcePackage: calamares
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
sudodus (nio-wiklund) wrote :
Revision history for this message
sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund)
description: updated
summary: - Command 'mount' returned non-zero exit status 32.
+ Calamares failed: command 'mount' returned non-zero exit status 32.
sudodus (nio-wiklund)
description: updated
description: updated
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1873950

tags: added: iso-testing
Revision history for this message
sudodus (nio-wiklund) wrote :

After further testing several times I think I pinned the problem:

The bug appears when booted 'toram'. With everything the same except the the boot option 'toram', Calamares can install Lubuntu. So this is an annoying glitch, but I think debugging it can wait until Lubuntu 20.04.1 LTS.

To post a comment you must log in.