Calamares fails 'Boost.Python error in job "machineid"' in Lubuntu Cosmic

Bug #1780984 reported by sudodus on 2018-07-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calamares (Ubuntu)
Undecided
Unassigned

Bug Description

This time I tried to install Lubuntu Next using as much default settings as possible (for example New York time and language). I used Manual partitioning, reused /dev/sda1 and formatted it. Otherwise it matches bug # 1780977 (where I tried Stockholm time and language (Swedish))

Installation failed

Boost.Python error in job "machineid".
<class 'OSError'>
[Errno 30] Read-only file system: '/tmp/calamares-root-7b09jli0/etc/machine-id'

Traceback:
File "/usr/lib/x86_64-linux-gnu/calamares/modules/machineid/main.py", line 56, in run
    os.remove(target_systemd_machineid_file)

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: calamares 3.2.1-1
ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
Uname: Linux 4.15.0-23-generic x86_64
ApportVersion: 2.20.10-0ubuntu5
Architecture: amd64
CasperVersion: 1.394
CurrentDesktop: LXQt
Date: Tue Jul 10 10:14:59 2018
LiveMediaBuild: Lubuntu 18.10 "Cosmic Cuttlefish" - Alpha amd64 (20180710)
SourcePackage: calamares
UpgradeStatus: No upgrade log present (probably fresh install)

sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund) wrote :
Simon Quigley (tsimonq2) wrote :

I can't reproduce this, and I've sent it upstream to confirm that this isn't something wrong with my settings, but my hunch is that you didn't format your drives correctly and it was just mounted read-only.

That being said, some extra verification should be added upstream, so let's wait for a comment from them.

Thanks.

sudodus (nio-wiklund) wrote :

Well Simon,

I figured your bugfixes for my other bugs were done early enough to get into the current daily iso file, so I zsynced and started testing :-P

And I think they were. Anyway this is my feedback about this bug, 'Boost.Python error in job "machineid"'.

I cannot reproduce it with the current daily iso file. I think your fix to wait longer before giving up helped.

The reason is that the test computer (from 2008 with the Athlon CPU) has a tired power supply unit, that has problems to supply power to 'everything'. But when I removed the internal hard disk drive, and connect a hard disk drive via eSATA and an external box, it has worked well. However, it seems that the corresponding linux driver in Cosmic is very slow (compared to running earlier versions of Lubuntu), and this makes Calamares very sluggish.

So I replaced the eSATA drive with an SSD (that needs a very small amount of power), that I could connect internally without overloading the tired power supply unit. And Calamares could finish and create a working installed system in the SSD :-)

After that I tried again with the HDD via eSATA, and with the current daily iso file Calamares could finish and create a working installed system in that drive too. But the installed system is very sluggish.

So I think, that your bugfixes for the other bug reports about Calamares fixed also this bug :-)

Simon Quigley (tsimonq2) wrote :

Great, thanks. :)

Changed in calamares (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers