clamares fails to install on a vm with gpt partition table and ext4

Bug #1771693 reported by Lyn Perrine on 2018-05-16

This bug report will be marked for expiration in 49 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calamares (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce run the latest lubuntu cosmic install. Then select manual partitioning and select manual partitioning. Then create a gpt partition table and select ext4 for the partition type as /. Then select install and it will continue installing until this error message.
Boost.Python error in job "packages".
<class 'subprocess.CalledProcessError'>
Command 'apt-get -q -y install linux-generic' returned non-zero exit status 100.
Traceback:
  File "/usr/lib/calamares/modules/packages/main.py", line 456, in run
    run_operations(pkgman, entry)

  File "/usr/lib/calamares/modules/packages/main.py", line 372, in run_operations
    pkgman.install(entry[key])

  File "/usr/lib/calamares/modules/packages/main.py", line 225, in install
    check_target_env_call(["apt-get", "-q", "-y", "install"] + pkgs)

  File "<string>", line 2, in <module>

Description: Ubuntu Cosmic Cuttlefish (development branch)
Release: 18.10
calamares:
  Installed: 3.1.12-1
  Candidate: 3.1.12-1
  Version table:
 *** 3.1.12-1 500
        500 http://archive.ubuntu.com/ubuntu cosmic/universe amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: calamares 3.1.12-1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.10-0ubuntu2
Architecture: amd64
CasperVersion: 1.394
CurrentDesktop: LXQt
Date: Wed May 16 18:33:27 2018
LiveMediaBuild: Lubuntu 18.10 "Cosmic Cuttlefish" - Alpha amd64 (20180513)
SourcePackage: calamares
UpgradeStatus: No upgrade log present (probably fresh install)

Lyn Perrine (walterorlin) wrote :
Lyn Perrine (walterorlin) wrote :
Walter Lapchynski (wxl) wrote :

Can't replicate in VirtualBox at least.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1771693

tags: added: iso-testing
Walter Lapchynski (wxl) wrote :

Calling this incomplete because I also can't replicate in QEMU/KVM.

Changed in calamares (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers