Package information is not updated during installation process

Bug #1947024 reported by Tomasz Dunal
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calamares-settings-ubuntu (Ubuntu)
Undecided
Unassigned

Bug Description

After the installation, the system is not aware of available software. In effect, no package can be installed or updated, and no bug can be reported as no package is recognized by ubuntu-bug as an official Ubuntu package until user manually runs "apt update". Due to the latter effect, the bug report was not filed as the issue was occurring, but after "apt update".

Hardware:
Lenovo Yoga 300-11IBR (Intel N3060 1.60 GHz, 2 GiB RAM, N3060 integrated graphics)

Setup:
Secure Boot, Boot Mode: UEFI, UEFI first

Steps to reproduce:
1. Use "Disks"/Restore Disk Image to prepare Lubuntu Impish Daily installation Medium
2. Boot the live session from the installation medium
3. Connect to internet over wi-fi
4. Launch installation process
  a) language: American English
  b) timezone: Warsaw
  c) Erase disk, swap to file, encrypt system
  d) Log in automatically
5. Finish the installation process
6. Reboot to the installed system
7. Open a terminal
8. Run 'ubuntu-bug qterminal'
9. Pay attention to the command output
10. Open Muon
11. Attempt to install new software

Expected result:
pt. 9: user is able to report a bug for qterminal
pt. 11: user is able to install new software from the default repositories

Actual result:
pt. 9: error message: "The problem cannot be reported: This does not seem to be an official Ubuntu package"
pt. 11: Muon only lists installed software, despite the fact that software sources are enabled (attaching screenshots)

Reproduction rate: 5/5.
Please note that the issue has been encountered on 3 different daily builds since 27 September 2021, but couldn't be reported earlier due to time constraints.
The ISO's checksums have been confirmed before installation.

ProblemType: Bug
DistroRelease: Ubuntu 21.10
Package: calamares-settings-lubuntu 1:21.10.2
ProcVersionSignature: Ubuntu 5.13.0-19.19-generic 5.13.14
Uname: Linux 5.13.0-19-generic x86_64
ApportVersion: 2.20.11-0ubuntu70
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: LXQt
Date: Wed Oct 13 19:28:44 2021
InstallationDate: Installed on 2021-10-13 (0 days ago)
InstallationMedia: Lubuntu 21.10 "Impish Indri" - Release amd64 (20211012)
PackageArchitecture: all
SourcePackage: calamares-settings-ubuntu
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Tomasz Dunal (gnomasz) wrote :
Revision history for this message
Tomasz Dunal (gnomasz) wrote :
Revision history for this message
Tomasz Dunal (gnomasz) wrote :
Revision history for this message
Tomasz Dunal (gnomasz) wrote :
Revision history for this message
Tomasz Dunal (gnomasz) wrote :
Revision history for this message
Tomasz Dunal (gnomasz) wrote :
Revision history for this message
Tomasz Dunal (gnomasz) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1947024

tags: added: iso-testing
Revision history for this message
Chris Guiver (guiverc) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Summary
- I get same result as Tomasz after a no-internet install
- I don't have an issue after a 'install using existing partition' install; NO replication of issue

I did a couple of QA-test installs with the ISO Tomasz refers to (http://iso.qa.ubuntu.com/qatracker/milestones/424/builds/238226/testcases/1701/results)

I booted an install on the dc7700 & it was unable to `ubuntu-bug qterminal` as Tomasz reports; however the install log reports my first test on that box was "no-internet" & it's likely that was the case on both tests for that box so it's an expected result on that box I believe. (expected confirmation; but no issue)

I also booted the d780 I also performed a QA-test on, and it was very happily willing to file a report on `ubuntu-bug qterminal` and there is no evidence I'd have `sudo apt update` (alas anything is possible) as commands evident are all local exploration of the system directories to verify the install itself.

The 'install using existing partition' though maybe is a different case; as the installer has to download & install packages to restore my additional packages - so had to update software lists to install `clementine` & my other non-Lubuntu default packages I used in that test. Issue doesn't exist here - no confirmation.

Revision history for this message
Chris Guiver (guiverc) wrote (last edit ):

I believe I can now confirm this issue.

I turned on
- sony vaio svp112a1cw (i5-9400u, 4gb, intel haswell-ULT)
which was used for a QA-test using [impish] RC dated 20211010

I often use `sudo apt update` to verify the network connection; but I must not have this time.. as I just encountered this issue when I tried to `sudo apt install nfs-common` to use the box for something

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in calamares-settings-ubuntu (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers