Calamares incorrectly reports no internet available when installing Lubuntu/Ubuntu Studio Jammy

Bug #1942638 reported by Leó Kolbeinsson
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calamares-settings-ubuntu (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

This now also affects Lubuntu Jammy 01-12-2021

Testing Lubuntu Impish daily 03.09.2021 on Dell optiplex 7060 box bare metal and in VirtualBox on another machine also connected to the Internet.

When installing Lubuntu - calamares reports no Internet available - However the box is connected via ethernet and when I advance to "location" the correct location is shown and the machine is connected.

The syslog is attached

Tags: iso-testing
Revision history for this message
Leó Kolbeinsson (leok) wrote :

Syslog attached

Leó Kolbeinsson (leok)
affects: ubuntu → calamares-settings-ubuntu (Ubuntu)
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1942638

tags: added: iso-testing
Revision history for this message
Leó Kolbeinsson (leok) wrote :

Not sure what happened at the time of my first report - but I have installed on several other boxes both with ethernet and WiFi connections and cannot reproduce the bug.

description: updated
Revision history for this message
Chris Guiver (guiverc) wrote :

Copied from Telegram

Dan Simmons, [04.09.21 11:05]
Fairly sure this bug was related to the lubuntu.me downtime. https://bugs.launchpad.net/bugs/1942638

Leó Kolbeinsson, [04.09.21 11:37]
ahh ,, timing seems about right..as noted - unable to reproduce.

Revision history for this message
Leó Kolbeinsson (leok) wrote (last edit ):

Testing Lubuntu Jammy daily ISO 01-12-2021 -

3 machines tested http://iso.qa.ubuntu.com/qatracker/milestones/429/builds/240584/testcases/1701/results/

1. InWin BL641 i5-10400 running in VirtualBox - ethernet connection
2. Lenovo V14 IIL i3-1005G1 - WiFi connected before install
3. Dell [ Optiplex] MT 7040 - ethernet connection before install

All 3 installs erroneously report : The system is not connected to the Internet -

Attached is the syslog for the Lenovo wifi install and I will also post the syslog for Dell 7040 box in another comment.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

And attached is the syslog for the Dell 7040 ethernet connected box

Leó Kolbeinsson (leok)
description: updated
summary: - Calamares incorrectly reports no internet available
+ Calamares incorrectly reports no internet available when installing
+ Lubuntu Jammy
Revision history for this message
Chris Guiver (guiverc) wrote : Re: Calamares incorrectly reports no internet available when installing Lubuntu Jammy

Lubuntu jammy; I just experienced this on
- hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)
box is connected to internet & I can ping external addresses from CLI/qterminal.

(sorry I forget what details I'm supposed to get for this condition & I can't find my .txt file that's supposed to remind me)

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Attached is the Calamares debug file for Lenovo V14 IIL i3-1005G1 - WiFi connected before install
test mentioned in comment # 5

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in calamares-settings-ubuntu (Ubuntu):
status: New → Confirmed
Revision history for this message
Leó Kolbeinsson (leok) wrote (last edit ):

Ubuntu Studio - tested http://iso.qa.ubuntu.com/qatracker/milestones/429/builds/240629/testcases/1303/results InWin BL641 i5-10400 running in Virtual Box

Opened Firefox and browsed the Internet then selected the Install Studio icon and the installer reports no Internet connection

summary: Calamares incorrectly reports no internet available when installing
- Lubuntu Jammy
+ Lubuntu/Ubuntu Studio Jammy
Revision history for this message
Rik Mills (rikmills) wrote (last edit ):
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.