Lubuntu Calamares install fails if loop0 already in use

Bug #1876950 reported by GT on 2020-05-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calamares-settings-ubuntu (Ubuntu)
Undecided
Unassigned

Bug Description

Using the Lubuntu 20.04 amd64 iso as a live USB:

To replicate:

1. edit the boot configuration to include the "toram" option to the linux command
2. try to install Lubuntu via the graphical installer

Outcome:
Calamares halts due to a subprocess error when .run() is called in unpackfs after finalizing partition info (it appears to create the appropriate filesystem and then fail)

Expected outcome:
Installation of Lubuntu

More info:
I tried to replicate what I believe, based on the calamares log, the subprocess that fails is doing: mounting a squashfs file in /cdrom to a tmp folder. The result is mount complaining that /dev/loop0 is already mounted and exiting with nonzero status.

Apologies for no verbatim error quoting but the platform I'm failing to install on I can only use mouse or keyboard at a time.

sudodus (nio-wiklund) wrote :

I have succeeded doing what you try to do, when I booted with the two boot options 'toram' and 'nopersistent' (both at the same boot) with the other Ubuntu flavours that use Ubiquity.

Installing with Calamares works for me (to install Lubuntu 20.04 LTS) without the boot option 'toram', for example with the default boot options and also with the extra boot option 'persistent'. But it fals for me too, when I use the boot option 'toram'.

My question is to you GT: Why do you want this? The only reason I can think of is to install into the same drive as you were booting from.

Maybe this is another manifestation of the bug I reported at

https://bugs.launchpad.net/ubuntu/+source/calamares/+bug/1873950

See also the following link,

https://help.ubuntu.com/community/mkusb/persistent#Installing_-_using_the_Install_icon_on_the_desktop

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in calamares-settings-ubuntu (Ubuntu):
status: New → Confirmed
GT (lazydemon) wrote :

I want to do this because I am installing on a laptop (Surface Laptop 3) whose keyboard/touchpad/touchscreen are not recognized by the installer as it is configured (it currently needs a small set of kernel patches to use normally), and which only has one USB port. I believe "toram" is used to avoid depending on the USB drive after the system boots so that the USB port can be used for an input device.

Regarding nopersistent option: my, uh, second attempt at this (first attempt used dd but the live usb launcher detected some broken file) I used rufus to create a live USB with persistent storage, but that caused a crash when I removed the USB drive. So the behavior reported happened with the third usb drive attempt, an installer with no persistent storage partition.

It's not identical to the linked bug; Calamares didn't report the exit status, just gave a 3 part pseudo python traceback (something in /usr/lib/x86_64-something/calamares/.../unpackfs.py called .run on an unpack object, which tried to mount, captured the exit status and raised a SubProcessError or something because the result of the mount attempt was nonzero).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers