Calamares aborts because of an AttributeError

Bug #1875476 reported by apt-ghetto on 2020-04-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calamares-settings-ubuntu (Ubuntu)
Undecided
Unassigned

Bug Description

[Summary]

During the installation process, the file /etc/apt/sources.list is generated from a template. If an HTTPError occurs, then instead of logging a message, an AttributeError is raised.

[Test Case]

Steps to reproduce
------------------

1. Start the installer.
2. When the automirror module is executed, provoke an HTTPError from
urllib.request.urlopen

Expected behaviour
------------------

The error is logged and the installer continues.

Current behaviour
-----------------

An AttributeError is raised.

[Regression Potential]

There shouldn't be any regression potential.

[Other Info]

This error seems to occur only under special conditions, because it was not noticed so far.

Existing forum post => https://discourse.lubuntu.me/t/installation-failed-class-attribute-error/1019

apt-ghetto (apt-ghetto) on 2020-04-27
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package calamares-settings-ubuntu - 1:20.10.1

---------------
calamares-settings-ubuntu (1:20.10.1) groovy; urgency=medium

  [ Erich Eickmeyer ]
  * Added Ubuntu Studio
  * Welcome to the Groovy Gorilla!

  [ apt-ghetto ]
  * Fix AttributeError in automirror module (LP: #1875476)

  [ Dan Simmons ]
  * Adjust Ubuntu Studio translations.
  * Add groovy to Lubuntu branding.
  * Drop debian/compat use debhelper-compat=13, no changes needed.

 -- Dan Simmons <email address hidden> Wed, 20 May 2020 20:40:13 -0400

Changed in calamares-settings-ubuntu (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers