lubuntu 18.10 - install ubuntu 18.10 icon won't execute

Bug #1797530 reported by Chris Guiver on 2018-10-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calamares-settings-ubuntu (Ubuntu)
Critical
Walter Lapchynski

Bug Description

Lubuntu 18.10 daily ISO (downloaded (11-oct-2018) x86 (32bit)

I can't execute the "Install LUbuntu 18.10" icon.

The thumb-drive was tested successfully earlier today (before d610 live test)
I've rebooted, and got the same result, and tried many times.

I can OPEN (opens in editor) the icon, I can CANCEL, but I cannot EXECUTE to test-install Lubuntu 18.10 for my test (calamares install) to /dev/sdc

In the menu, under System - I have an icon INSTALL SYSTEM - that does nothing too.

--
I've had a bad [pain] day & made lots of logic errors, so I'd like to blame me doing something wrong, but I cannot find it, and decided better to record here in case it's not me.

--
lubuntu@lubuntu:~$ cd Desktop/
lubuntu@lubuntu:~/Desktop$ ls -ltrha
total 4.0K
-rwxr-xr-x 1 lubuntu lubuntu 1.6K Oct 12 08:23 calamares.desktop
drwxr-xr-x 2 lubuntu lubuntu 60 Oct 12 08:23 .
drwxr-xr-x 15 lubuntu lubuntu 440 Oct 12 08:40 ..
lubuntu@lubuntu:~/Desktop$ stat calamares.desktop
  File: calamares.desktop
  Size: 1559 Blocks: 8 IO Block: 4096 regular file
Device: 18h/24d Inode: 62 Links: 1
Access: (0755/-rwxr-xr-x) Uid: ( 999/ lubuntu) Gid: ( 999/ lubuntu)
Access: 2018-10-12 08:24:20.922233383 +0000
Modify: 2018-10-12 08:23:52.618234417 +0000
Change: 2018-10-12 08:23:52.618234417 +0000
 Birth: -
lubuntu@lubuntu:~/Desktop$

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: calamares 3.2.2-0ubuntu1
ProcVersionSignature: Ubuntu 4.18.0-8.9-generic 4.18.7
Uname: Linux 4.18.0-8-generic i686
.etc.calamares.modules.automirror.conf:
 ---
 baseUrl: archive.ubuntu.com
 backend: apt
 distribution: Lubuntu
 mirrorList: https://mirrorlist.lubuntu.me/list.json
.etc.calamares.modules.finished.conf:
 ---
 restartNowChecked: true
 restartNowEnabled: true
 restartNowCommand: "systemctl -i reboot"
.etc.calamares.modules.partition.conf:
 efiSystemPartition: "/boot/efi"
 enableLuksAutomatedPartitioning: true
 neverCreateSwap: true
 drawNestedPartitions: true
.etc.calamares.modules.shellprocess_logs.conf:
 ---
 dontChroot: true
 timeout: 30
 script:
     - calamares-logs-helper @@ROOT@@
.etc.calamares.modules.unpackfs.conf:
 ---
 unpack:
     - source: "/cdrom/casper/filesystem.squashfs"
         sourcefs: "squashfs"
         destination: ""
ApportVersion: 2.20.10-0ubuntu11
Architecture: i386
CasperVersion: 1.397
CurrentDesktop: LXQt
Date: Fri Oct 12 08:29:14 2018
LiveMediaBuild: Lubuntu 18.10 "Cosmic Cuttlefish" - Beta i386 (20181011)
RelatedPackageVersions:
 calamares-settings-ubuntu-common 24
 calamares-settings-lubuntu 24
 xfsprogs 4.15.1-1ubuntu1
 btrfs-progs 4.16.1-2ubuntu1
SourcePackage: calamares
UpgradeStatus: No upgrade log present (probably fresh install)

Chris Guiver (guiverc) wrote :
tags: added: iso-testing
Leó Kolbeinsson (leok) wrote :

I can confirm bug 1797530 - same result as "guiverc" - after selecting icon and execute nothing happens- tested on Dell OPtiplex GX620 1 GB RAM

Chris Guiver (guiverc) wrote :

I tried booting on thinkpad sl510 - same issue. i can't get icon to execute (& start install)

lubuntu@lubuntu:~/Desktop$ file calamares.desktop
calamares.desktop: a /usr/bin/env xdg-open script, UTF-8 Unicode text executable

Hans P Möller (hmollercl) wrote :

yes known issue in yesterdays daily. It's because a calamares icon is missing. To workaraoun do:
$sudo touch /etc/calamares/branding/lubuntu/icon.png

Changed in calamares (Ubuntu):
status: New → Confirmed
Walter Lapchynski (wxl) wrote :

The other problem you'll have after the installation is completed is a notice that it failed (it really didn't). To keep that from showing up:
`sudo sed -i 's/false/true/' /etc/calamares/modules/before_bootloader_context.conf`

Changes are coming in calamares-settings-lubuntu 25.

Changed in calamares (Ubuntu):
status: Confirmed → Fix Committed
affects: calamares (Ubuntu) → calamares-settings-ubuntu (Ubuntu)
Changed in calamares-settings-ubuntu (Ubuntu):
assignee: nobody → Walter Lapchynski (wxl)
importance: Undecided → Critical
To post a comment you must log in.