Calamares fails in UEFI mode after external command in Lubuntu Cosmic - new bug

Bug #1783109 reported by sudodus on 2018-07-23
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calamares-settings-ubuntu (Ubuntu)
Critical
Simon Quigley

Bug Description

I tested in my Toshiba laptop (the same as in bug #1781015) and in the same way. There seems to be a new bug now. The installation proceeded a long way, but stopped with the following message:

---
Error

Installation failed

External command finished with errors.
Command calamares-logs-helper /tmp/calamares-root-ucej4awq finished with exit code 1. Output: + root=/tmp/calamares-root-ucej4awq + install_dir=/tmp/calamares-root-ucej4awq/var/log/installer + [ -d /tmp/calamares-root-ucej4awq/var/log/installer ] + mkdir -p /tmp/calamares-root-ucej4awq/var/log/installer + cp /home/lubuntu/.cache/calamares/session.log /tmp/calamares-root-ucej4awq/var/log/installer/debug cp: cannot stat '/home/lubuntu/.cache/calamares/session.log': No such file or directory
---

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: calamares 3.2.1-1
ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
Uname: Linux 4.15.0-23-generic x86_64
ApportVersion: 2.20.10-0ubuntu5
Architecture: amd64
CasperVersion: 1.394
CurrentDesktop: LXQt
Date: Mon Jul 23 12:35:49 2018
LiveMediaBuild: Lubuntu 18.10 "Cosmic Cuttlefish" - Alpha amd64 (20180723)
SourcePackage: calamares
UpgradeStatus: No upgrade log present (probably fresh install)

sudodus (nio-wiklund) wrote :
Simon Quigley (tsimonq2) wrote :

Another stupid mistake :)

cp: cannot stat '/home/lubuntu/.cache/calamares/session.log'

s/calamares/Calamares/

Fixing.

Changed in calamares (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
importance: Undecided → Critical
status: New → In Progress
sudodus (nio-wiklund) wrote :

Still does not work from the current daily file dated 2018-07-24 (this time partly in Swedish).

---
Fel

Installationen misslyckades

External command finished with errors.
Command calamares-logs-helper /tmp/calamares-root-9j9cj0yp finished with exit code 1. Output: + root=/tmp/calamares-root-9j9cj0yp + install_dir=/tmp/calamares-root-9j9cj0yp/var/log/installer + [ -d /tmp/calamares-root-9j9cj0yp/var/log/installer ] + mkdir -p /tmp/calamares-root-9j9cj0yp/var/log/installer + cp /home/lubuntu/.cache/calamares/session.log /tmp/calamares-root-9j9cj0yp/var/log/installer/debug cp: cannot stat '/home/lubuntu/.cache/calamares/session.log': No such file or directory
---

sudodus (nio-wiklund) wrote :

I tested with 'as much default' as possible (US English etc), and still got the same error (ending with

cp: cannot stat '/home/lubuntu/.cache/calamares/session.log': No such file or directory

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1783109

tags: added: iso-testing
Simon Quigley (tsimonq2) on 2018-07-25
affects: calamares (Ubuntu) → calamares-settings-ubuntu (Ubuntu)
Lugito (lugito) wrote :

This bug has been marked as fixed in the Git repository: https://phab.lubuntu.me/rCALASETTINGSb74b617312ac
The commit message is the following: Calamares is capitalized (LP: #1783109).

(Note: I am only a bot. If this message was received in error, please contact my owners on the Lubuntu Team.)

Changed in calamares-settings-ubuntu (Ubuntu):
status: In Progress → Fix Committed
Simon Quigley (tsimonq2) wrote :

Hey, it works. :D

Since this was set to calamares instead of calamares-settings-ubuntu, unfortunately LP didn't automatically close it... but the fix has been uploaded and has migrated already.

Changed in calamares-settings-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
sudodus (nio-wiklund) wrote :

Yes, it works for me (tested with as much default as possible) in my Toshiba

http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

from the current daily iso file dated 2018-07-25 :-)

sudodus (nio-wiklund) wrote :

I set UEFI to secure boot (and tested in Swedish, still 'only' with 'Erase disk') in my Toshiba.

The installation worked and the installed system works (with secure boot enabled, so now it is tested sucessfully too).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers