lubuntu cosmic installs ZRAM

Bug #1780585 reported by vmc on 2018-07-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calamares-settings-ubuntu (Ubuntu)
Critical
Simon Quigley

Bug Description

Lubuntu Cosmic v18.10

Partition: ID-1: / size: 95.62 GiB used: 5.34 GiB (5.6%) fs: ext4 dev: /dev/sda7
           ID-2: swap-1 size: 1.95 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5
           ID-3: swap-2 size: 923.3 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/zram0
           ID-4: swap-3 size: 923.3 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/zram1

ZRAM should not be installed by default

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1780585/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
vmc (vmclark) wrote :

package: zram-config

sudodus (nio-wiklund) wrote :

@vmc,

I zsynced the current daily iso file, dated 2018-07-07,

cosmic-desktop-amd64.iso

Then I tried to install Lubuntu Cosmic from a cloned USB pendrive, but failed. I tried with with the new 'Lubuntu installer' from the 'System' menu, alias Calamares. I tried in BIOS mode.

I tried with manual partitioning in a couple of ways and it failed in different ways.

I tried the most basic way (to use the whole drive), 'Erase disk'.

I tried in UEFI mode - and it wanted a DVD (failed to use the data in the pendrive).

I burned a DVD and it booted, but the installer failed (in UEFI mode and in BIOS mode).

---

How did you succeed to install it?

sudodus (nio-wiklund) wrote :

I tried via the Ubuntu mini.iso, and it worked.

There is no zram in this installed system. So I cannot confirm the bug.

vmc (vmclark) wrote :

I 'dd' my usb flash. Installed it that way. This is Lubuntu Cosmic ISO. Did you create Lubuntu from Ubuntu mini?

I installed to a available partition. I have BIOS mbr. Twice now I'm left with zram installed. Maybe open a terminal while its in progress to see when it get activated.

sudodus (nio-wiklund) wrote :

@vmc,

Did you install Lubuntu Cosmic into the internal drive by 'dd' from the iso file or USB flash drive?

Or did you use an installer (Calamares or Ubiquity or the text mode mode Debian installer or some other installer)?

When you boot Lubuntu from a 'dd'-installed system, you have a live system, which uses zram, and has used zram for years. Is this what you are running now?

When booted into a live system, and you *install* Lubuntu with an installer (Calamares or Ubiquity or the text mode mode Debian installer or some other installer), Lubuntu should get installed so that it will not use zram. If I am understanding correctly, it would be a bug, if zram is actively used by the installed system after such an installation. This is what I tried to test yesterday, but I failed to used the installer, Calamares, that is bundled with Lubuntu Cosmic, and when I booted from the Ubuntu mini.iso and used the Debian installer, the result was a working installed Lubuntu Cosmic system, that is *not* using zram.

So please describe with more details how you installed Lubuntu (which installer you used, and which steps you were taking (what you selected at which step) etc) and I will try to install Lubuntu in the same way.

vmc (vmclark) wrote :

OK, I see how you install lubuntu-cosmic.

 I dd to usb, booted usb, installed into internal HD using Calamares from booted usb. zram installed into system.[Ubiquity isn't available anymore]

Then, this is definitely a bug.

sudodus (nio-wiklund) wrote :

It will not be considered a bug until confirmed by someone else. Please help me confirm it by telling me how to use Calamares (with sufficient details for me to succeed).

vmc (vmclark) wrote :

Calamares works almost the same as Ubiquity. Just follow the prompts. I never use along-side-anything. I always have an available partition to use. Not sure if I can create snapshots of the install, but will try.

Simon Quigley (tsimonq2) wrote :

This is a wider problem with Calamares not removing all of the necessary packages that are included in the live ISO.

I'll fix it right now.

Thanks for reporting it.

no longer affects: ubuntu
affects: zram-config (Ubuntu) → calamares-settings-ubuntu (Ubuntu)
Changed in calamares-settings-ubuntu (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Simon Quigley (tsimonq2) wrote :
Changed in calamares-settings-ubuntu (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package calamares-settings-ubuntu - 4

---------------
calamares-settings-ubuntu (4) cosmic; urgency=medium

  * Don't fail to install the system on BIOS systems (LP: #1780875).
  * Remove the right live task (LP: #1780585).
  * Enable GeoIP support by default, to get accurate timezone readings.
  * Make image and text IDs unique in the slideshow.
  * Ensure that slideshow images correctly respond to their text.
  * Actually install the .desktop file.

 -- Simon Quigley <email address hidden> Mon, 09 Jul 2018 20:48:33 -0500

Changed in calamares-settings-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
vmc (vmclark) wrote :

Thank you Simon!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers