Folder color not working in Caja List View

Bug #1442681 reported by gravy45 on 2015-04-10
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
caja (Ubuntu)
Low
Martin Wimpress
Zesty
Low
Unassigned

Bug Description

[Impact]

 * The Folder Color extension doesn't change icons when Caja is in "List View".

 * This has been a long standing issue caja_file_get_gicon() which didn't return custom icons.

[Test Case]

 * Using Caja 1.18.1-0ubuntu1 switch to List View, right click a folder a use the Folder's Color context menu to change the icon color to Red. The folder color will not change. Not switch Caja to Icon View and you'll see the selected folder icon is now Red.

 * Using Caja 1.18.1-0ubuntu2 switch to List View, right click a folder a use the Folder's Color context menu to change the icon color to Red. The folder color will change to Red and will be Red in Icon View and Compact View too.

[Regression Potential]

 * It is possible this patch may introduce unanticipated behavior in Caja, none were observed in testing.

 * This patch has been tested and approved upstream.

 * A patched version of Caja has been built and tested in a PPA.

gravy45 (gravy45) on 2015-04-10
summary: - MATE 15.04 B2: Folder color not working in conjunction with Caja fly-out
- menus
+ MATE 15.04 B2: Folder color not working
description: updated
gravy45 (gravy45) on 2015-04-10
description: updated
gravy45 (gravy45) on 2015-04-19
summary: - MATE 15.04 B2: Folder color not working
+ MATE 15.04: Folder color not working

Hi gravy45!

> Virtualbox running Ubuntu MATE 15.04 Beta 2. All upgrades, updates and dist-uprgrade applied. Running Compiz as window manager. A reboot did not change the behavior.

Same here :)

> The folder color isn't changing in "List View", and the fly-out menus aren't setting correctly. See attached screenshots.

What is "fly-out" menus?
I'm afraid that the "List View" is overwriting any icon configuration because a Caja behavior.
I tried this (see screenshot.tar.gz file): Change the Pictures folder icon as a Terminal icon. You can see the Terminal icon in Icon & Compact views, but not in List view.

I can't reproduce your menu problem. I tried with compiz & marco, and it worked :O
Please, take a look to this video: https://youtu.be/SjbEwyTYXwE

Thanks for your feedback!
Best regards!

I found an icon issue in your screenshots. I created this bug for the icons in Compact view:
https://bugs.launchpad.net/folder-color/+bug/1446319

Changed in folder-color:
assignee: nobody → costales (costales)
gravy45 (gravy45) wrote :

Hi @costales, by fly-out menus I mean the ones that come out when you right-click. As shown in your video.

Apparently, the problem with the fly-out menus went away after Beta 2 because it isn't occurring now in with the 20150417.1/Final/RC whatever it is meant to be called. I call it confusing!

Other than that, I still see where the folder colors do not change in list view, but do change in compact and icon views.

I can't go to a low enough resolution to duplicate the icon issue you pointed out but it makes sense to me.

description: updated
costales (costales) wrote :

> As shown in your video.

Perfect then :)

> I still see where the folder colors do not change in list view, but do change in compact and icon views.

Yes, It's a Caja problem. It's appearing in the "Open" browse too, but it's not a Folder Color issue :( I can't do anything about that.
FYI: Folder Color is setting the icon for a folder, just that, if a program or extension is not reading it, I can't do anything.

> went away after Beta 2

I tested it before and it worked right too. I'm thinking it was about Compiz :O (?)

Thanks for your feedback! I keep this bug opened after the release. Maybe more users could give us more feedback. Is OK for you?

A hug gravy45!

gravy45 (gravy45) wrote :

Are you saying that the "Affects" should add Caja ?

> Are you saying that the "Affects" should add Caja ?

I'm not sure, probably will be a library instead.

As test, I tried Nemo file browser and it shows the colors and custom
icons (as the terminal) in the List view too.

Hi! Any news about this issue after the release? :)
Can I close it, then?
Best regards!

gravy45 (gravy45) wrote :

Unfortunately, it is still the same. No color on list view. I hope you don't close it. It is listed as affecting ubuntu-mate but beyond that I wouldn't know where to categorize it. Hopefully one of the MATE people will chime in here soon. I was going to take a look at the Caja code but if I recall it is C and I don't know C other than enough to read certain small parts of it.

costales (costales) wrote :

@gravy45: I was talking about this :P "fly-out menus weren't setting correctly up"

About the no icon (it's not a color problem) on list view is a Caja issue, because Nemo is showing them.

Changed in folder-color:
status: New → Invalid
costales (costales) wrote :

I unlinked from the Folder Color, because it's not an issue for that package, OK? :)
I was looking for a caja package, but I didn't find it.

gravy45 (gravy45) on 2015-05-17
Changed in ubuntu-mate:
status: New → Invalid
Changed in ubuntu-mate:
status: Invalid → New

Hi Martin :) Is not working now?

gravy45 (gravy45) on 2015-06-19
summary: - MATE 15.04: Folder color not working
+ MATE 15.04: Folder color not working in List View

@costales - have you or anyone had Folder Color running on Arch (List View working)?

Hi! No, I haven't it.
Could it work in Arch? It's global issue in the file browsers, they are
reading the system icon for that folder, but not its gvfs.
A hug!

So I'm confused. I had reported the issue here: https://github.com/mate-desktop/caja/issues
The MATE desktop in general/outside of Ubuntu does not use Folder Color, right? To my way of thinking it will be difficult to persuade them to make a change upstream in Caja so that Caja works fully with Folder Color. The same functionality didn't work in Linux Mint either, but as I understand it Clem is using a different (fork?).

Hi gravy45!

Yes, Folder Color is not an official extension of MATE.

The problem is this: Folder Color sets the icon as gvfs property, but Caja
is showing the default icon for each folder in the List View. I mean, for
"Images" folder, it's not showing the custom icon, it's showing the default
Images icon from the current theme.

But this is a problem in Nemo too (I think to rememeber that in Nautilus is
working).

Best regards!

Changed in ubuntu-mate:
status: New → Confirmed
status: Confirmed → Triaged
summary: - MATE 15.04: Folder color not working in List View
+ Folder color not working in Caja List View
Changed in ubuntu-mate:
importance: Undecided → Low
franco_bez (franco-bez) wrote :

Problem still persists in Ubuntu-mate 16.04 xenial - Caja 1.12.7

pioutw (pioutw-c) wrote :

Problem still persists in Mint 18.1 / MATE 1.16.1 / Caja 1.16.1
the same in Mint 18 / MATE 1.14.1 / Caja 1.14.2

i thing this bug still present in Ubuntu Mate 16.04.02

Changed in caja (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
importance: Undecided → Low
status: New → In Progress
Changed in ubuntu-mate:
status: Triaged → Invalid
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package caja - 1.18.2-0ubuntu1

---------------
caja (1.18.2-0ubuntu1) artful; urgency=medium

  * New upstream release.

 -- Martin Wimpress <email address hidden> Fri, 21 Apr 2017 19:56:32 +0100

Changed in caja (Ubuntu):
status: In Progress → Fix Released
Vlad Orlov (monsta) on 2017-04-23
tags: added: xenial yakkety zesty

Hello gravy45, or anyone else affected,

Accepted caja into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/caja/1.18.1-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in caja (Ubuntu Zesty):
status: New → Fix Committed
tags: added: verification-needed

I have tested Caja 1.18.1-0ubuntu2 from proposed on a clean, updated, Ubuntu MATE 17.04 VM and confirm this issue is resolved.

tags: added: verification-done
removed: verification-needed
Changed in caja (Ubuntu Zesty):
importance: Undecided → Low
affects: ubuntu-mate → ubuntu-translations
no longer affects: ubuntu-translations
affects: folder-color → ubuntu-translations
no longer affects: ubuntu-translations
gravy45 (gravy45) wrote :

Yes, I confirm that this works from 17.04 VM as well. Nice work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers