Caja-dropbox does not start on 18.04.1 LTS upgraded from 16.04.5 LTS

Bug #1785622 reported by Norbert on 2018-08-06
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
MATE Desktop
Fix Released
Unknown
Ubuntu MATE
Undecided
Unassigned
caja-dropbox (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
ubuntu-mate-settings (Ubuntu)
Medium
Martin Wimpress
Bionic
Undecided
Unassigned
Disco
Medium
Martin Wimpress

Bug Description

Steps to reproduce:
1. Have Ubuntu 16.04.5 LTS with `ubuntu-mate-desktop` and `caja-dropbox` installed
2. Upgrade it with `do-release-upgrade -d` to 18.04.1 LTS
3. Reboot after upgrade to new system, login and get no Dropbox icon in the tray.
4. Remove DropBox from the system (as in https://ubuntu-mate.community/t/problems-with-the-dropbox-icon-in-the-panel-um-18-04-1/17495/6 ):

killall dropbox
sudo apt-get purge caja-dropbox
rm -rf ~/.dropbox
sudo apt-get install caja-dropbox

5. Reboot and log-in again, still no DropBox icon.
6. Try to launch DropBox from terminal with `caja-dropbox start` and get the following output in the terminal (as in https://ubuntu-mate.community/t/problems-with-the-dropbox-icon-in-the-panel-um-18-04-1/17495/7):

$ caja-dropbox start
Starting Dropbox...dropbox: locating interpreter
dropbox: logging to /tmp/dropbox-antifreeze-YXAa3r
dropbox: initializing
dropbox: initializing python 3.5.4
dropbox: setting program path '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/dropbox'
dropbox: setting home path '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90'
dropbox: setting python path '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90:/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/python-packages-35.zip'
dropbox: python initialized
dropbox: running dropbox
dropbox: setting args
dropbox: applying overrides
dropbox: running main script
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/cryptography.hazmat.bindings._constant_time.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/cryptography.hazmat.bindings._openssl.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/cryptography.hazmat.bindings._padding.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/psutil._psutil_linux.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/psutil._psutil_posix.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/linuxffi.pthread._linuxffi_pthread.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/linuxffi.fcntl._linuxffi_fcntl.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/linuxffi.sys.compiled._linuxffi_sys.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/tornado.speedups.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/cpuid.compiled._cpuid.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/linuxffi.resolv.compiled._linuxffi_resolv.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/posixffi.libc._posixffi_libc.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/librsyncffi.compiled._librsyncffi.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/PyQt5.QtWebKit.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/PyQt5.QtCore.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/PyQt5.QtNetwork.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/PyQt5.QtGui.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/PyQt5.QtWebKitWidgets.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/PyQt5.QtWidgets.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/PyQt5.QtPrintSupport.cpython-35m-x86_64-linux-gnu.so'
Dropbox isn't running!
Done!
xenial@xenial-vb:~$ Gtk-Message: 15:44:51.977: Failed to load module "topmenu-gtk-module"
dropbox: load fq extension '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-54.4.90/PyQt5.QtDBus.cpython-35m-x86_64-linux-gnu.so'

(dropbox:2153): GLib-GObject-WARNING **: 15:44:52.271: cannot register existing type 'GdkDisplayManager'

(dropbox:2153): GLib-CRITICAL **: 15:44:52.271: g_once_init_leave: assertion 'result != 0' failed

(dropbox:2153): GLib-GObject-CRITICAL **: 15:44:52.271: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

Expected results: `caja-dropbox` works after upgrading from 16.04.5 LTS to 18.04.1 LTS.

Actual results: `caja-dropbox` does not work after upgrading from 16.04.5 LTS to 18.04.1 LTS.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: caja-dropbox 1.20.0-2
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: MATE
Date: Mon Aug 6 15:45:00 2018
InstallationDate: Installed on 2018-01-04 (213 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: caja-dropbox
UpgradeStatus: Upgraded to bionic on 2018-08-06 (0 days ago)

Norbert (nrbrtx) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in caja-dropbox (Ubuntu):
status: New → Confirmed
Changed in ubuntu-mate-settings (Ubuntu):
status: New → Confirmed
Changed in mate-desktop:
status: Unknown → New
Andis (andis-lazdins) wrote :

I can confirm this issue. I also upgraded from 16.04 to 18.04 and instead of Dropbox icon I have now question mark without dropbox menu. I also can't start dropbox from application menu using command dbus-launch caja-dropbox start -i. It only starts with ~/bin/dropbox.py start command, which I found in another web page.
It is especially nasty because dropbox sent notification that only Ext4 will be supported starting with November and I have dropbox files on Ntfs partition and there is no way to change settings without GUI. I would be very thankful for recommendation on how to change dropbox settings in this situation.

APolihron (apolitech) wrote :

The problem is that 16.04 was on gtk 2 and 18.04.x is on gtk 3. I will mark this as invalid because there is no proper fix beside removing and reinstalling the dropbox applet.

Changed in ubuntu-mate:
status: New → Invalid
Richard Lamont (richard-lamont) wrote :

I've seen a couple of other applications which produce the message: Failed to load module "topmenu-gtk-module"

This appears to be a problem with dist-upgrading ubuntu-mate-default-settings from 16.04 to 18.04. The upgrade installs /etc/X11/Xsession.d/80mate-environment but does not remove the older /etc/X11/Xsession.d/99mate-environment. Deleting the latter fixed the problem.

Changed in caja-dropbox (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-mate-settings (Ubuntu Disco):
status: Confirmed → In Progress
assignee: nobody → Martin Wimpress (flexiondotorg)
status: In Progress → Fix Committed
Changed in mate-desktop:
status: New → Fix Released
Changed in caja-dropbox (Ubuntu Bionic):
status: New → Invalid
Changed in ubuntu-mate-settings (Ubuntu Disco):
importance: Undecided → Medium
Norbert (nrbrtx) on 2019-04-21
tags: added: cosmic disco eoan
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.