Dropbox indicator is broken on non-Unity environments

Bug #1559249 reported by Eugene San on 2016-03-18
94
This bug affects 20 people
Affects Status Importance Assigned to Milestone
caja-dropbox (Ubuntu)
Medium
Martin Wimpress
nautilus-dropbox (Ubuntu)
High
Unassigned

Bug Description

Dropbox indicator is broken on non-Unity environments.
Distributed binaries got confused when XDG_CURRENT_DESKTOP defines than one environment.
The solution would be enforcing "pure" Unity mode when an environment have it as an option.

Patch with the fix attached.

Eugene San (eugenesan) wrote :

The attachment "fix-non-pure-unity.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus-dropbox (Ubuntu):
status: New → Confirmed
Changed in caja-dropbox (Ubuntu):
status: New → Confirmed
Changed in caja-dropbox (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in caja-dropbox (Ubuntu):
status: Fix Committed → Fix Released
Martin Wimpress (flexiondotorg) wrote :

This has regressed in caja-dropbox, preparing a revised fix.

Changed in caja-dropbox (Ubuntu):
status: Fix Released → Triaged
importance: Undecided → Medium
Changed in caja-dropbox (Ubuntu):
status: Triaged → Fix Committed
Martin Wimpress (flexiondotorg) wrote :

Attached is a debdiff for nautilus-dropbox that coerces XDG_CURRENT_DESKTOP for Unity environments to ensure the indicator icon and menu works correctly.

Changed in nautilus-dropbox (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-dropbox - 2015.10.28-1ubuntu1

---------------
nautilus-dropbox (2015.10.28-1ubuntu1) zesty; urgency=medium

  * debian/patches:
    + Add fix-unity-indicator-menu.patch. Coerce XDG_CURRENT_DESKTOP to report
      "Unity" ensuring the indicator icon and menu work correctly. (LP: #1559249)

 -- Martin Wimpress <email address hidden> Mon, 27 Mar 2017 19:11:18 +0100

Changed in nautilus-dropbox (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package caja-dropbox - 1.18.0-0ubuntu2

---------------
caja-dropbox (1.18.0-0ubuntu2) zesty; urgency=medium

  * debian/patches:
    + Replace 2003_execute_via_dbus_launch.patch with
      2003_fake_xdg_current_desktop.patch to coerce XDG_CURRENT_DESKTOP and
      ensure indicator icons and menus work. (LP: #1559249)

 -- Martin Wimpress <email address hidden> Sat, 25 Mar 2017 23:49:01 +0000

Changed in caja-dropbox (Ubuntu):
status: Fix Committed → Fix Released
Olivier Febwin (febcrash) wrote :

The problem with Dropbox indicator is still present while I have the package

Caja-dropbox / zesty 1.18.0-0ubuntu2 amd64

tags: removed: patch

The problem continue with dropbox indicator. Please fix-it

Jim Raredon (decoy-umd) wrote :

The change did not modify the behavior at all. The problem remains the same.

Robin (robingape) wrote :

The solution in the bug report is ineffective for non-Unity desktops. The bug is manifest in Ubuntu 16.04 LTS when using a desktop (GNOME 3 flashback) that is not Unity.

The patches in comments #1 and #7 are likely to *cause* a problem with non-Unity desktops.
[This is of relevance given the recent announcement that Unity is to be retired in favour of GNOME 3 with the 18.04 LTS release of Ubuntu.]

Jim Raredon (decoy-umd) wrote :

The bug also still exists in Unity, even on vanilla new installations of Ubuntu 17.04.

Ali Isingor (1-ali) wrote :

Bug still exist in 17.04 Unity and it's really annoying.

groby (groby) wrote :

same here on Lubuntu 17.04. Bug still exists.

Spindizzy (spindizzy-wizard) wrote :

Ping! Ubuntu 16.04, Gnome 3 Flashback, bug still here!

Robin (robingape) wrote :

This is frustrating. The patch *does not work*, yet the status is currently "Fix Released". Should a new bug be raised, or should the status be reverted to "Confirmed"?

The non-working status for the proposed fix is noted in comments 10-17.

I'd roll it back to Confirmed, if I could. If you can't, and no one else
can, then new bug.

On Jul 28, 2017 4:05 PM, "Robin" <email address hidden> wrote:

> This is frustrating. The patch *does not work*, yet the status is
> currently "Fix Released". Should a new bug be raised, or should the
> status be reverted to "Confirmed"?
>
> The non-working status for the proposed fix is noted in comments 10-17.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1559249
>
> Title:
> Dropbox indicator is broken on non-Unity environments
>
> Status in caja-dropbox package in Ubuntu:
> Fix Released
> Status in nautilus-dropbox package in Ubuntu:
> Fix Released
>
> Bug description:
> Dropbox indicator is broken on non-Unity environments.
> Distributed binaries got confused when XDG_CURRENT_DESKTOP defines than
> one environment.
> The solution would be enforcing "pure" Unity mode when an environment
> have it as an option.
>
> Patch with the fix attached.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/caja-dropbox/+
> bug/1559249/+subscriptions
>

Robin (robingape) wrote :

A fresh bug report has been raised, emphasising the problem for no-Unity desktops.

It would be helpful to sign up to https://bugs.launchpad.net/ubuntu/+source/nautilus-dropbox/+bug/1707313

Please note that the new bug report does not include any mention of a "fix".

Russ (russelldyson) wrote :

Still here for me on Xubuntu 17.04 amd64 clean install. Maybe 17.10 for fix? Fingers crossed!

Tried all kinds of 'fixes' and nothing is persistent. Have also emailed Dropbox support to ask if they'll code for notify rather than indicator, which is the whole problem as I understand it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers