cairocffi 0.7.2-2.1 FTBFS: cairocffi/test_xcb.py .Aborted (core dumped)

Bug #1704630 reported by Hans Joachim Desserud on 2017-07-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cairocffi (Ubuntu)
Undecided
Unassigned

Bug Description

cairocffi 0.7.2-2.1 currently fails to build on Ubuntu Artful when running the tests with the following error message:

cairocffi/test_cairo.py ......................................
cairocffi/test_pixbuf.py ....
cairocffi/test_xcb.py .Aborted (core dumped)
E: pybuild pybuild:283: test: plugin distutils failed with: exit code=134: cd /<<PKGBUILDDIR>>/.pybuild/pythonX.Y_2.7/build; python2.7 -m pytest
dh_auto_test: pybuild --test -i python{version} -p 2.7 returned exit code 13
debian/rules:14: recipe for target 'override_dh_auto_test' failed
make[1]: *** [override_dh_auto_test] Error 25
make[1]: Leaving directory '/<<PKGBUILDDIR>>'
debian/rules:11: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

(See https://launchpadlibrarian.net/328987948/buildlog_ubuntu-artful-amd64.cairocffi_0.7.2-2.1_BUILDING.txt.gz for more details)

Not sure why this particular test suite would cause a core dump, but I got the same result when attempting to build the package locally.

This is not reproducible on Debian Sid, so it looks like an Ubuntu-only issue.

Hans Joachim Desserud (hjd) wrote :

Presumably effectively fixed by https://bugs.launchpad.net/ubuntu/+source/cairocffi/0.8.0-0ubuntu2
which skips th xcb tests and built successfully.

Changed in cairocffi (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers