Ubuntu

gnome apps won't start via remote desktop (_pixel_to_solid)

Reported by Russell Robinson on 2010-12-08
60
This bug affects 8 people
Affects Status Importance Assigned to Milestone
cairo (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

TESTCASE: unsure, upstream defines the issue happening with "weird pixman formats", test that the update doesn't break anything and let users who had the bug see if that fixes it for them as well

Regression potential: cairo is used by lot of softwares through gtk, the patch mostly changes handling of errors which were leading to a code stop to be less strict though which shouldn't impact on any normal run case

(note that the patch is shipped in fedora for some months, debian experimental and quantal and is coming from upstream stable serie git)

Ubuntu 10.10

Apps that start fine on the console will not start when you connect via Remote Desktop.

Examples: gnome-terminal, "add or delete button" in users-admin

Unfortunately, no errors messages are shown (reminiscent of MS Windows) and there are no clues in files in /var/log.

I managed to start an xterm and then tried to run "gnome-terminal" from there.

Here's the error message:
gnome-terminal: /build/buildd/cairo-1.10.0/src/cairo-image-surface.c:1294: _pixel_to_solid: Assertion `!"reached"' failed.

The gnome-terminal problem is related to the desktop theme.

If you select "Dust", then gnome-terminal will not start.

However, if you select "Ambiance" or "Glider" gnome-terminal will start.

The problem buttons in users-admin is different and I'll post another bug report regarding that.

Fabio Marconi (fabiomarconi) wrote :

As reported it afflict only dust theme, so assign to gnome-colors

affects: ubuntu → gnome-colors (Ubuntu)
Chris Pruett (chris-pruett) wrote :

I have also seen this failure and it only occurs during a remote connection.

For me, changing the desktop theme did not allow gnome-terminal to start. I was using "Radiance" when I first encountered the issue. Switching to "Ambiance" did not help.

The problems occur in a remote session, using vncserver, not otherwise.

Same problem for me (only when login via vnc) and it actually was working before a reboot of the system.
Tried out with all available themes without success.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cairo (Ubuntu):
status: New → Confirmed
affects: gnome-colors (Ubuntu) → cairo (Ubuntu)
Changed in cairo (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cairo (Ubuntu):
status: New → Confirmed

This happens to me when connected with xrdp and when I do NOT have a background image set. Set a background image and it works. This is annoying as background images make the session much slower.

Changed in cairo (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cairo (Ubuntu Precise):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

The issue should be fixed with cairo 1.12 in quantal

Changed in cairo (Ubuntu Precise):
importance: Undecided → Low
status: Confirmed → Triaged
summary: - gnome apps won't start via remote desktop
+ gnome apps won't start via remote desktop (_pixel_to_solid)
description: updated
Changed in cairo (Ubuntu Precise):
status: Triaged → Fix Committed
description: updated
description: updated

Hello Russell, or anyone else affected,

Accepted cairo into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

Could somebody who reported one of those issues test the update so it can be moved to -updates?

Updated via proposed and both terminal and nautilus start as normal for me using vnc.

I cannot reproduce the original problem on the system in question. It was nearly 2 years ago, so I'm not sure what may have altered to avoid the problem occurring.

Also, that system is in production, so I can't just update it without detailed planning.

Hopefully others can verify.

Sebastien Bacher (seb128) wrote :

setting to verification done since comment #13 says it work and I've been running it for a week without issue

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo - 1.10.2-6.1ubuntu3

---------------
cairo (1.10.2-6.1ubuntu3) precise-proposed; urgency=low

  * debian/patches/git_support_weird_pixmap_formats.patch:
    - some users hit errors with some pixman datas, don't enforce the
      checking in the library but let the caller deal with those
      (lp: #686836)
 -- Sebastien Bacher <email address hidden> Fri, 25 May 2012 15:23:42 +0200

Changed in cairo (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.