exorbitant printing file size when print PDF

Bug #560939 reported by GophrenOli on 2010-04-11
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cairo (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

Hi, when I am trying to print the attached PDF-file to my laser printer (Samsung CLP-550), the file size "explodes" an printing failes. - I guess, a -ps.file reflects the final printing file size. The attached file has a size of about 3,3 MBytes, the resulting *.ps-file has a size of about 95 MBytes. My printer has 64 MBytes.

I cannot print the file. Well, I ca do, but by using Windows, then the file is printed immediately, while on Linux the printer is recieving and recieving..and then canceling.

"Solution": Buying special printer RAM for my laser for printing such huge files. To me, this is not really a solution as it should be.

ProblemType: Bug
Architecture: i386
Date: Sun Apr 11 21:42:45 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/evince
InstallationMedia: Xubuntu 9.10 "Karmic Koala" - Release i386 (20091028.3)
NonfreeKernelModules: fglrx
Package: evince 2.28.1-0ubuntu1.2
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic-pae
SourcePackage: evince
Uname: Linux 2.6.31-20-generic-pae i686
XsessionErrors:
 (xfce4-cpugraph-plugin:1693): Gtk-CRITICAL **: gtk_container_set_border_width: assertion `GTK_IS_CONTAINER (container)' failed
 (polkit-gnome-authentication-agent-1:1883): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (xfce4-terminal:3481): Terminal-WARNING **: Unable to load terminal preferences.
 (xfce4-terminal:3913): Terminal-WARNING **: Unable to load terminal preferences.
 (firefox:4113): GLib-WARNING **: g_set_prgname() called multiple times

GophrenOli (gophrenoli) wrote :
Pedro Villavicencio (pedro) wrote :

thanks for the report, could you test the same on Lucid and comment back? Thanks in advance.

Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
GophrenOli (gophrenoli) wrote :

Hi & yes, same result on Lucid: a huge .ps-file with a size of roundabout 95 MByte.

GophrenOli (gophrenoli) wrote :

printing with xpdf works fine, the resulting ps-file size is about 5 MBytes

GophrenOli (gophrenoli) wrote :

ubuntu 9.10 and 10.4: also the printing performance is quite low&slow when print PDFs with the option duplex + 2 PDF-pages on one paper-page - this takes several minutes.

When using xpdf in lucid, the print job with these options is done within seconds.

So, what's up with evince?

GophrenOli (gophrenoli) wrote :

This bug is still present in Xubuntu/LUCID.

Today I have checked this again on a fresh installation incl. all uptodate-updates. -> exorbitant printing file size.

Also I have checked the program Ocular, in addition to xpdf - both produce printing file size of max. 5 MBytes. So only evince has the problem with printing e.g. the attached file "steckbrief_jara--Drucker platzt.pdf" from above.

So, why is this report still in status "incomplete" since my answere on 2010-04-14? Which informations else do you need?
Evince-viewmode is pretty,but its printing has this big-size bug!

Changed in evince (Ubuntu):
status: Incomplete → New
Charlie Kravetz (charlie-tca) wrote :

 Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in evince (Ubuntu):
status: New → Confirmed
madbiologist (me-again) wrote :

There is a fix in cairo 1.10.0 for this problem. Can you test with Ubuntu 10.10 "Maverick Meerkat" and report back? If you don't want to install it you can use the Live CD.

affects: evince (Ubuntu) → cairo (Ubuntu)
Changed in cairo (Ubuntu):
status: Confirmed → Incomplete
GophrenOli (gophrenoli) wrote :

> There is a fix in cairo 1.10.0 for this problem. Can you test with Ubuntu 10.10 "Maverick Meerkat" and report back?

*SOLVED*, it works now: in 10.10 "Maverick Meerkat"

madbiologist (me-again) on 2010-10-22
Changed in cairo (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers