Ubuntu

evince doesn't print vector images in PDF

Reported by Jan Mynarik on 2008-10-11
62
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evince
Unknown
Medium
cairo (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Intrepid by Greg A
Nominated for Jaunty by Greg A

Bug Description

Binary package hint: evince

1) Open a PDF file with inner vector images, e.g. this one: http://korfbal.prostejov.cz/files/PVkorfbal%20zpravodaj%202008-10.pdf
2) The file is rendered OK on screen, in this specific PDF see the images/logos on top (these are vector images, originally SVGs, PDF created in Scribus)
3) Open Print preview (in Print dialog) OR print to PS file OR print on printer (in my case HP Photosmart C7280)

In all cases mentioned in 3) the result is without those vector images.

This is critical for me and definately a regression. It works OK in hardy. I upgraded to Intrepid just after beta went out and this bug appeared.

evince: 2.24.0-0ubuntu2

Sebastien Bacher (seb128) wrote :

thank you for your bug report, the bug is likely an upstream one, could you open it on bugzilla.gnome.org too where the evince hackers will read it?

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

don't abuse the title to specify the version you are using for example, that creates confusion and extra work and should rather be in the bug description

Jan Mynarik (jan-mynarik) wrote :

Sebastien, sorry about the title. I thought it helps.

Changed in evince:
status: Unknown → New
Changed in evince:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

upstream says that's a recently fixed cairo bug, cairo should be updated to 1.6 before intrepid

Changed in evince:
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

the new version is in intrepid now

Changed in cairo:
status: Fix Committed → Fix Released
Jan Mynarik (jan-mynarik) wrote :

Cairo 1.8.0-0ubuntu1 hadn't fixed this problem for me. Maybe it's not a cairo problem or it wasn't fixed properly in cairo.

Chris Wilson (ickle) wrote :

This regression only came to light after the 1.8.0 release, fixed with:
commit 3c18d95b293eddaa25232bc06398c78bc8043cb4
Author: Chris Wilson <email address hidden>
Date: Sun Sep 28 15:57:37 2008 +0100

    Compute device_transform_inverse.

    Because we can independently set either the device scale or the device
    offset, we need to be careful and recompute the inverse rather than simply
    assuming that the original contents of the device transform is identity.

    Fixes regression https://bugs.launchpad.net/inkscape/+bug/234546.

(Assuming I've identified the correct issue.)

Changed in cairo:
status: Fix Released → Fix Committed
Bordiga Giacomo (gbordiga) wrote :

Cairo 1.8.2 release available, that includes the commit Chris pointed.

Greg A (etulfetulf) wrote :

I would suggest that the importance of this bug be raised per https://wiki.ubuntu.com/Bugs/Importance

It does not fulfill any Low criteria:
    * Ones that can be easily worked around <- no workaround
    * Ones that affect unusual configurations or uncommon hardware <- everyone with a printer
    * A bug that has a moderate impact on a non-core application <- this is a core application
    * A cosmetic/usability issue that does not limit the functionality of an application <- this does limit the functionality

I would consider it Medium:
    * A bug that has a moderate impact on a core application.
    * A problem with a non-essential hardware component (network card, camera, webcam, music player, sound card, power management feature, printer, etc.)

benste (benste) wrote :

Thanks to Seb, I marked my own one as a duplicate.

Who gave it the label low?
For those who don't want to install Adobe Reader which is propriate software as far as I know, it's almost "critical"
Cause of that I would really like to see it as MEDIUM like Greg.

vmagnin (vincent-magnin) wrote :

I installed Okular, the PDF viewer of KDE4. It works with Gnome and I have no problem with it when printing.

benste (benste) wrote :

As I said In my duplicate,
official Adobe Reader works fine too

Sebastien Bacher (seb128) wrote :

the new version is in jaunty now, it should be uploaded to intrepid too if it works correctly

Changed in cairo:
status: Fix Committed → Fix Released
benste (benste) wrote :

I'll post asap as I see the change

Bordiga Giacomo (gbordiga) wrote :

I tried to install Fabien Tassin cairo 1.8.4 packages for jaunty from his PPA (https://launchpad.net/~fta/+archive), that should be the same as those uploaded to jaunty, but the install fails due to an unresolved dependency (libxcb, but not sure).
Then i installed cairo 1.8.2 compiled for intrepid, again from Fabien Tassin PPA and it installs correctly and the bug is fixed.

steve hardy (hardysteven) wrote :

I still have the same problem, only I also can't print images using the proprietary Adobe Reader.

- Evince prints OK, but leaves out the images
- Adobe Reader 8 just prints me a blank page

Does anyone have a reliable workaround for this - it's really starting to get inconvenient as I regularly need to print out forms on my primary work machine, and these forms now print incomplete. I don't have any M$ machine to use so it has to be an ubuntu based workaround.

Bordiga Giacomo (gbordiga) wrote :

Have you installed cairo 1.8.2 from Fabien Tassin's PPA? To do that add "deb http://ppa.launchpad.net/fta/ubuntu intrepid main" as a third party repository and update and upgrade only cairo packages and then disable the repository, to prevent not wanted upgrades.

steve hardy (hardysteven) wrote :

Thanks very much, upgrading to libcairo 1.8.2 has fixed it :

ii libcairo2 1.8.2-0ubuntu1~fta1~intrepid The Cairo 2D vector graphics library

For the benefit of others, after adding
deb http://ppa.launchpad.net/fta/ubuntu intrepid main

to my sources.list I just did
sudo apt-get update

then waited for the software update icon to appear in the taskbar. Then I chose *just* the libcairo package to be updated, as I was unsure what the other packages were.

Thanks again for the fix.

Changed in evince:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.