[QEMU] Corrupted desktop screen for raring desktop installation in QEMU guest (Cirrus graphics). Affects KVM but not VBox.

Bug #1080674 reported by Para Siva on 2012-11-19
114
This bug affects 20 people
Affects Status Importance Assigned to Milestone
cairo
Unknown
Medium
cairo (Ubuntu)
Medium
Unassigned

Bug Description

The desktop screen appears corrupted after raring desktop installation. Please see attached screenshot for how it looks. Going through System settings -> Appearance and selecting different wall papers does not solve the isssue.

Test Steps:
1. Install Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20121119)
2. Reboot after the installation and log in

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: unity 6.12.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.7.0-2.8-generic 3.7.0-rc5
Uname: Linux 3.7.0-2-generic i686
.tmp.unity.support.test.1:

ApportVersion: 2.6.2-0ubuntu3
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CurrentDmesg: [ 18.945219] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
Date: Mon Nov 19 12:26:26 2012
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
GraphicsCard:
 Cirrus Logic GD 5446 [1013:00b8] (prog-if 00 [VGA controller])
   Subsystem: Red Hat, Inc Device [1af4:1100]
InstallationDate: Installed on 2012-11-19 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20121119)
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Bochs Bochs
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.7.0-2-generic root=UUID=131c13a4-8227-4946-8a1f-2aaa6043670d ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/01/2007
dmi.bios.vendor: Bochs
dmi.bios.version: Bochs
dmi.chassis.type: 1
dmi.chassis.vendor: Bochs
dmi.modalias: dmi:bvnBochs:bvrBochs:bd01/01/2007:svnBochs:pnBochs:pvr:cvnBochs:ct1:cvr:
dmi.product.name: Bochs
dmi.sys.vendor: Bochs
version.compiz: compiz 1:0.9.8.4+bzr3412-0ubuntu1
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.0.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.4-0ubuntu1
xserver.bootTime: Mon Nov 19 12:23:11 2012
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input AT Translated Set 2 keyboard KEYBOARD, id 7
 input ImExPS/2 Generic Explorer Mouse MOUSE, id 8
xserver.errors: open /dev/dri/card0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.13.0-0ubuntu7

Para Siva (psivaa) wrote :
Daniel van Vugt (vanvugt) wrote :

If you open a window or application is it corrupted in the same way?

Changed in unity (Ubuntu):
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

Screenshots of windows open would be excellent, thanks.

Para Siva (psivaa) wrote :

No, the windows do not appear corrupted. Attached are two screen shots, one is with a window of a jpg image open and the other is the one is the desktop appearance when the same image being selected as the background

Para Siva (psivaa) wrote :
Changed in unity (Ubuntu):
status: Incomplete → New

Hmm, I was going to say it's a problem with Unity based on the first screenshot. But then the second and third show just a problem with the desktop... ?!

summary: - Corrupted desktop screen for raring desktop installation
+ [LLVMpipe] Corrupted desktop screen for raring desktop installation
tags: added: llvmpipe
summary: - [LLVMpipe] Corrupted desktop screen for raring desktop installation
+ [QEMU] [LLVMpipe] Corrupted desktop screen for raring desktop
+ installation
Daniel van Vugt (vanvugt) wrote :

Actually, I suspect it's a problem with the VM host... that is the QEMU/Bochs video BIOS.

Could you please try installing gnome-shell and gnome-session-fallback. Then log in to Gnome Shell and Gnome Classic and see if any similar problems occur... ?

affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: New → Incomplete
Para Siva (psivaa) wrote :

Logging in to Gnome Shell and Gnome Classic-(No effect version) show the same corrupted display behaviour. ( Gnome Classic does not let me log in for some reason)

The quantal and precise VMs on the same host are working fine. The displays for those VMs in the same host do not get corrupted. Additionally, a quantal VM which did not have this issue in the same host encountered this problem when it was upgraded to raring. So I am not sure if the host is the cause here.

Para Siva (psivaa) on 2012-11-20
Changed in compiz (Ubuntu):
status: Incomplete → New
Daniel van Vugt (vanvugt) wrote :

OK if quantal works and the corruption exists in Gnome Classic without effects then it's either a graphics driver problem in the guest, or a video BIOS problem in the host.

affects: compiz (Ubuntu) → mesa (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

I think I recall having seen similar corruption in QEMU with older versions of Ubuntu. And I think the fix was to switch the virtual video hardware using qemu option: -vga std

summary: - [QEMU] [LLVMpipe] Corrupted desktop screen for raring desktop
- installation
+ [QEMU] Corrupted desktop screen for raring desktop installation
tags: removed: llvmpipe
summary: - [QEMU] Corrupted desktop screen for raring desktop installation
+ [QEMU] Corrupted desktop screen for raring desktop installation in QEMU
+ guest (Cirrus graphics)

Right, thanks for the workaround. Raring VMs work fine when started with -vga std.

Bryce Harrington (bryce) wrote :

Since the behavior exhibits itself in gnome classic without effects, and since turning -vga std on works around the issue, it is sounding unlikely to be mesa, and more likely to be the video driver itself (-cirrus, or potentially the kernel).

Does booting the quantal kernel in the raring vm (without using the -vga std workaround) also work around the problem?

Changed in mesa (Ubuntu):
status: New → Invalid
Changed in xserver-xorg-video-cirrus (Ubuntu):
status: New → Incomplete
affects: mesa (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Invalid → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
Para Siva (psivaa) wrote :

@bryce:
Booting with quantal kernel does not work around the problem. The desktop is still corrupted. Please see attached image

Changed in linux (Ubuntu):
status: Incomplete → New
Changed in xserver-xorg-video-cirrus (Ubuntu):
status: Incomplete → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-cirrus (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

Ok, since quantal kernel doesn't resolve it, going to guess it's not the kernel for now.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Dave Gilbert (ubuntu-treblig) wrote :

Yeh I'm also seeing this; note that the cirrus driver is the same 1:1.5.1-0ubuntu2 Quantal (that works) and Raring (where it gets this corruption).

Note that Cirrus tends to run with 24bpp packed that always adds fun and excitement; and might explain the odd rhythmic patterning.

Para Siva (psivaa) wrote :

This only occurs with with KVM and not with VBox. The installation of 20121210 on VBox came up with correct desktop.

Dave Gilbert (ubuntu-treblig) wrote :

psivaa: Can you run an xdpyinfo in VBox and KVM and attach both the outputs?

Bryce Harrington (bryce) on 2012-12-18
summary: [QEMU] Corrupted desktop screen for raring desktop installation in QEMU
- guest (Cirrus graphics)
+ guest (Cirrus graphics). Affects KVM but not VBox.
Bryce Harrington (bryce) wrote :

Yes, it's true -cirrus hasn't changed. It could be a change in something underneath -cirrus that it depends on.

; in fact we haven't changed much of X in raring from quantal really: xserver is different but mainly just bug fixes, mesa the same (although since it affects gnome classic (no effects) it's not likely mesa's doing), libdrm has changed from 2.4.39 to 2.4.40 but DRI isn't being loaded so I doubt that's it:

[ 10.229] (II) AIGLX: Screen 0 is not DRI2 capable
[ 10.229] (II) AIGLX: Screen 0 is not DRI capable
[ 10.683] (II) AIGLX: Loaded and initialized swrast
[ 10.683] (II) GLX: Initialized DRISWRAST GL provider for screen 0

But I'm supposing that's going to be the same on quantal too. Reboot into quantal where you're not seeing the corruption, and collect Xorg.0.log (and why not dmesg too while you're at it.) Maybe the difference between those files will tell us something.

Changed in xserver-xorg-video-cirrus (Ubuntu):
status: Confirmed → Incomplete
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1080674

tags: added: iso-testing
Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :

Bryce,

Attached are the files you requested. The xorg log files are pretty different...

Changed in xserver-xorg-video-cirrus (Ubuntu):
status: Incomplete → Confirmed
Marc Deslauriers (mdeslaur) wrote :

Here is an Xorg log file from the raring VM after booting with "nomodeset". The Xorg log is now similar to Quantal, but still displays the corruption.

Marc Deslauriers (mdeslaur) wrote :

Hrm, I've reverted kernel, libdrm, xorg-server and mesa to the quantal versions and I'm still seeing this...not sure what to try next...

Marc Deslauriers (mdeslaur) wrote :

GAH! It's cairo.

Downgrading to these two fixes the issue:

libcairo2_1.12.2-1ubuntu2_amd64.deb
libcairo-gobject2_1.12.2-1ubuntu2_amd64.deb

Bad cairo, bad!

Marc Deslauriers (mdeslaur) wrote :

Looks like this regressed in 1.12.4.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cairo (Ubuntu):
status: New → Confirmed

Created attachment 71854
screenshot with cairo 1.12.4 and later

When using the cirrus graphics driver while running Ubuntu in a kvm virtual machine, cairo 1.12.4 and later (including 1.12.8) corrupts pixmaps. Downgrading to 1.12.2 seems to solve this issue. See attached screenshots.

Created attachment 71855
screenshot with cairo 1.12.2

The change is the use of ShmPixmaps/ShmImage.

Changed in cairo:
importance: Unknown → Medium
status: Unknown → Confirmed
Maarten Lankhorst (mlankhorst) wrote :

Since it happens in cirrus, could you test if the recent xserver-xorg-video-cirrus 1:1.5.2-0ubuntu1 fixes it?

Para Siva (psivaa) wrote :
Para Siva (psivaa) wrote :

xserver-xorg-video-cirrus 1:1.5.2-0ubuntu1 has NOT fixed the issue. Please see the screenshot attached above. Thanks

Maarten Lankhorst (mlankhorst) wrote :

This should be fixed with xserver-xorg-video-modesetting 0.7.0-0ubuntu2, but really, use qxl!

Changed in xserver-xorg-video-cirrus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Won't Fix
Marc Deslauriers (mdeslaur) wrote :

xserver-xorg-video-modesetting 0.7.0-0ubuntu2 has definitely not fixed it for me.

Download full text (3.9 KiB)

progress?

On 5 April 2013 00:15, Launchpad Bug Tracker <email address hidden>wrote:

> ** Branch linked: lp:ubuntu/raring-proposed/xserver-xorg-video-
> modesetting
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1088692).
> https://bugs.launchpad.net/bugs/1080674
>
> Title:
> [QEMU] Corrupted desktop screen for raring desktop installation in
> QEMU guest (Cirrus graphics). Affects KVM but not VBox.
>
> Status in Cairo Graphics Library:
> Confirmed
> Status in “cairo” package in Ubuntu:
> Confirmed
> Status in “linux” package in Ubuntu:
> Invalid
> Status in “xserver-xorg-video-cirrus” package in Ubuntu:
> Won't Fix
>
> Bug description:
> The desktop screen appears corrupted after raring desktop
> installation. Please see attached screenshot for how it looks. Going
> through System settings -> Appearance and selecting different wall
> papers does not solve the isssue.
>
> Test Steps:
> 1. Install Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20121119)
> 2. Reboot after the installation and log in
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.04
> Package: unity 6.12.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.7.0-2.8-generic 3.7.0-rc5
> Uname: Linux 3.7.0-2-generic i686
> .tmp.unity.support.test.1:
>
> ApportVersion: 2.6.2-0ubuntu3
> Architecture: i386
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CurrentDmesg: [ 18.945219] hda-intel: IRQ timing workaround is
> activated for card #0. Suggest a bigger bdl_pos_adj.
> Date: Mon Nov 19 12:26:26 2012
> DistUpgraded: Fresh install
> DistroCodename: raring
> DistroVariant: ubuntu
> GraphicsCard:
> Cirrus Logic GD 5446 [1013:00b8] (prog-if 00 [VGA controller])
> Subsystem: Red Hat, Inc Device [1af4:1100]
> InstallationDate: Installed on 2012-11-19 (0 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20121119)
> Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> MachineType: Bochs Bochs
> MarkForUpload: True
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.7.0-2-generic
> root=UUID=131c13a4-8227-4946-8a1f-2aaa6043670d ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 01/01/2007
> dmi.bios.vendor: Bochs
> dmi.bios.version: Bochs
> dmi.chassis.type: 1
> dmi.chassis.vendor: Bochs
> dmi.modalias:
> dmi:bvnBochs:bvrBochs:bd01/01/2007:svnBochs:pnBochs:pvr:cvnBochs:ct1:cvr:
> dmi.product.name: Bochs
> dmi.sys.vendor: Bochs
> version.compiz: compiz 1:0.9.8.4+bzr3412-0ubuntu1
> version.libdrm2: libdrm2 2.4.39-0ubuntu1
> version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu2
> version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
> version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu2
> version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu7
> version.xserver-xorg-input-evdev: xserver-xorg-input-evdev
> 1:2.7.3-0ubuntu2
> version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.0.0-0ubuntu1
> version.xserver...

Read more...

Phill Whiteside (phillw) wrote :

cirrus boots with corrupt graphics, qxl simply uses CPU time but gives no display (as no grub menu). So, comment #39 is not an option either. I have also tried installing the newer version as per #38 (By using vga).

Phill Whiteside (phillw) wrote :

vmvga seems the best option at current, grub screen is a bit large, but the desktop appears at a size that does not require me making the VM window full size.

Dave Gilbert (ubuntu-treblig) wrote :

Still present in current Saucy ISO on a raring host.

hamish (hamish-b) wrote :

Hi, still see it on ubuntu 13.04 VMs run from kvm (in this case the host OS is debian/squeeze), including Mint15-Cinnamon.

Interestingly gnome-terminal is corrupted, but xterm and rxvt are not. pop-up alpha channel overlays which want to 1/2 shade the screen dark are also corrupted.

Tested with 'kvm -vga std' and indeed that works-around the issue, but for me (on a fast 6core with plenty of RAM) running Squeeze the VM is then very slow to render, to the point where it is no longer usable for anything other than debugging. Using Precise as a host makes '-vga std' work ok though (even when using kvm via tunnelled X).

'-vga qxl' on Precise just drops me to the qemu text box terminal, doesn't boot. the qxl xserver xorg video driver package is installed on the VM client, so I'm not sure what's going wrong there. But at least the '-vga std' + 12.04 host combo is a good one.

thanks,
Hamish

Peter Lieven (plieven) wrote :

Are you sure that the problem is between libcairo 1.12.2 and 1.12.4? I recechecked with Ubuntu 12.04.3 LTS 64bit Desktop CDROM with is based on libcario 1.10.2 and it also shows this bug.

Peter Lieven (plieven) wrote :

And has anyone tested this with a real Cirrus Logic graphic card? I still wonder if this is an emulation bug in qemu or a driver problem.

Peter Lieven (plieven) wrote :

Looking further it seems that the root cause is that the CIRRUS driver cannot be used in 12.04.3 because of this

[ 579.647] (EE) cirrus: The PCI device 0xb8 at 00@00:02:0 has a kernel module claiming it.
[ 579.647] (EE) cirrus: This driver cannot operate until it has been unloaded.

It seems that this is caused by the DRM driver:

[ 579.639] (II) config/udev: Adding drm device (/dev/dri/card0)
[ 579.642] (--) PCI:*(0:0:2:0) 1013:00b8:1af4:1100 rev 0, Mem @ 0xfc000000/33554432, 0xfebf0000/4096, BIOS @ 0x????????/65536

The DRM driver is not presend/loaded in Ubuntu 12.04.2. Subsequently the CIRRUS module loads fine
and the graphic is working as expected.

I will try if the resolution for this bug here fixes the problem:
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/982889

hamish (hamish-b) wrote :

Hi, still see the corruption on ubuntu 14.04 VMs run from kvm (in this case the host OS is debian/wheezy).

I see the same "(EE) cirrus: This driver cannot operate until it has been unloaded." error in Xorg.0.log.

I also see "(II) AIGLX: Screen 0 is not DRI2 capable" and "(EE) AIGLX: reverting to software rendering" further down in the log.

lsmod shows drm_kms_helper, drm, and cirrus kernel modules loaded.

thanks,
Hamish

hamish (hamish-b) wrote :

For an xubuntu 14.04 VM, '-vga vmware' and '-vga qxl' work (yay), but '-vga std' and '-vga cirrus' are still corrupted.

(host qemu-kvm is running in debian/wheezy, version 1.1.2+dfsg-6+deb7u1)

Hamish

Phill Whiteside (phillw) wrote :
Download full text (4.3 KiB)

Don't go complaining to me.. they marked it as won't fix... all I do is
tell people the workaroud,,,, it was, and still an WTF moment that they
will refuse to even look at the issue --- but there you go... a couple of
extra steps... choose 'extra' switch the video mode to SVGA. click on 'OK
(or what ever it is) and then click on start installation (top left)

Regards,

Phill.

On 22 April 2014 07:25, hamish <email address hidden> wrote:

> For an xubuntu 14.04 VM, '-vga vmware' and '-vga qxl' work (yay), but
> '-vga std' and '-vga cirrus' are still corrupted.
>
> (host qemu-kvm is running in debian/wheezy, version 1.1.2+dfsg-6+deb7u1)
>
>
> Hamish
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1088692).
> https://bugs.launchpad.net/bugs/1080674
>
> Title:
> [QEMU] Corrupted desktop screen for raring desktop installation in
> QEMU guest (Cirrus graphics). Affects KVM but not VBox.
>
> Status in Cairo Graphics Library:
> Confirmed
> Status in "cairo" package in Ubuntu:
> Confirmed
> Status in "linux" package in Ubuntu:
> Invalid
> Status in "xserver-xorg-video-cirrus" package in Ubuntu:
> Won't Fix
>
> Bug description:
> The desktop screen appears corrupted after raring desktop
> installation. Please see attached screenshot for how it looks. Going
> through System settings -> Appearance and selecting different wall
> papers does not solve the isssue.
>
> Test Steps:
> 1. Install Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20121119)
> 2. Reboot after the installation and log in
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.04
> Package: unity 6.12.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.7.0-2.8-generic 3.7.0-rc5
> Uname: Linux 3.7.0-2-generic i686
> .tmp.unity.support.test.1:
>
> ApportVersion: 2.6.2-0ubuntu3
> Architecture: i386
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CurrentDmesg: [ 18.945219] hda-intel: IRQ timing workaround is
> activated for card #0. Suggest a bigger bdl_pos_adj.
> Date: Mon Nov 19 12:26:26 2012
> DistUpgraded: Fresh install
> DistroCodename: raring
> DistroVariant: ubuntu
> GraphicsCard:
> Cirrus Logic GD 5446 [1013:00b8] (prog-if 00 [VGA controller])
> Subsystem: Red Hat, Inc Device [1af4:1100]
> InstallationDate: Installed on 2012-11-19 (0 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20121119)
> Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> MachineType: Bochs Bochs
> MarkForUpload: True
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.7.0-2-generic
> root=UUID=131c13a4-8227-4946-8a1f-2aaa6043670d ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 01/01/2007
> dmi.bios.vendor: Bochs
> dmi.bios.version: Bochs
> dmi.chassis.type: 1
> dmi.chassis.vendor: Bochs
> dmi.modalias:
> dmi:bvnBochs:bvrBochs:bd01/01/2007:svnBochs:pnBochs:pvr:cvnBochs:ct1:cvr:
> dmi.product.name: Bochs
> dmi.sys.vendor: Bochs
> version.compiz: compiz 1:0.9.8.4+bzr341...

Read more...

Kevin Masaryk (kevin-masaryk) wrote :

I don't understand why mlankhorst marked this "won't fix" when it's still clearly an outstanding issue. Because qxl is also broken (and I always has been in Ubuntu in my experience) this doesn't leave many/any? options for running an Ubuntu virt under KVM.

Phill Whiteside (phillw) wrote :
Download full text (4.3 KiB)

Go drum up some support and nag https://launchpad.net/~mlankhorst to
actually fix it. He knows the fix, just will not commit time to it.

Get it passed around the heat built up.... (that is get people to mark it
as 'affects me')

Regards,

Phill.

On 23 May 2014 20:27, Kevin Masaryk <email address hidden> wrote:

> I don't understand why mlankhorst marked this "won't fix" when it's
> still clearly an outstanding issue. Because qxl is also broken (and I
> always has been in Ubuntu in my experience) this doesn't leave many/any?
> options for running an Ubuntu virt under KVM.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1088692).
> https://bugs.launchpad.net/bugs/1080674
>
> Title:
> [QEMU] Corrupted desktop screen for raring desktop installation in
> QEMU guest (Cirrus graphics). Affects KVM but not VBox.
>
> Status in Cairo Graphics Library:
> Confirmed
> Status in "cairo" package in Ubuntu:
> Confirmed
> Status in "linux" package in Ubuntu:
> Invalid
> Status in "xserver-xorg-video-cirrus" package in Ubuntu:
> Won't Fix
>
> Bug description:
> The desktop screen appears corrupted after raring desktop
> installation. Please see attached screenshot for how it looks. Going
> through System settings -> Appearance and selecting different wall
> papers does not solve the isssue.
>
> Test Steps:
> 1. Install Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20121119)
> 2. Reboot after the installation and log in
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.04
> Package: unity 6.12.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.7.0-2.8-generic 3.7.0-rc5
> Uname: Linux 3.7.0-2-generic i686
> .tmp.unity.support.test.1:
>
> ApportVersion: 2.6.2-0ubuntu3
> Architecture: i386
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CurrentDmesg: [ 18.945219] hda-intel: IRQ timing workaround is
> activated for card #0. Suggest a bigger bdl_pos_adj.
> Date: Mon Nov 19 12:26:26 2012
> DistUpgraded: Fresh install
> DistroCodename: raring
> DistroVariant: ubuntu
> GraphicsCard:
> Cirrus Logic GD 5446 [1013:00b8] (prog-if 00 [VGA controller])
> Subsystem: Red Hat, Inc Device [1af4:1100]
> InstallationDate: Installed on 2012-11-19 (0 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20121119)
> Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> MachineType: Bochs Bochs
> MarkForUpload: True
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.7.0-2-generic
> root=UUID=131c13a4-8227-4946-8a1f-2aaa6043670d ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 01/01/2007
> dmi.bios.vendor: Bochs
> dmi.bios.version: Bochs
> dmi.chassis.type: 1
> dmi.chassis.vendor: Bochs
> dmi.modalias:
> dmi:bvnBochs:bvrBochs:bd01/01/2007:svnBochs:pnBochs:pvr:cvnBochs:ct1:cvr:
> dmi.product.name: Bochs
> dmi.sys.vendor: Bochs
> version.compiz: compiz 1:0.9.8.4+bzr3412-0ubuntu1
> version.libdrm2: libdrm2 2.4.39-0ubuntu1
> version.libgl1-...

Read more...

hamish (hamish-b) wrote :

Maarten Lankhorst wrote, on 2013-04-03:
>> This should be fixed with xserver-xorg-video-modesetting
>> 0.7.0-0ubuntu2, but really, use qxl!
...
>> Changed in xserver-xorg-video-cirrus (Ubuntu):
>> importance: Undecided -> Low
>> status: Confirmed -> Won't Fix

Kevin wrote last week:
> I don't understand why mlankhorst marked this "won't fix" when
> it's still clearly an outstanding issue. Because qxl is also
> broken (and I always has been in Ubuntu in my experience) this
> doesn't leave many/any? options for running an Ubuntu virt under KVM.

I believe that Maarten marked it as 'won't fix' at a time when he
thought that 0.7.0-0ubuntu2 (the version in raring) would resolve
it, so in marking that he was saying earlier versions (i.e. precise, LT*S)
was abandoned but it would automagically be ok in future releases.

But that hope turned out to be wrong -- here we are in trusty and
it's still broken, and so any one of us can justifiably click on the
'won't fix' at the top of this ticket and return it to 'confirmed',
since positive action is in fact still required and it won't automagically
fix itself in the next release.

regards,
Hamish

Dennis Knorr (dennis-knorr) wrote :

Hi,
this happens still in Trusty with all updates (todate: 13.07.2014, 20:00) and kvm is unusable with this. We wanted to use kvm instead of virtualbox/vmware but with this, you can forget that.
Why on Earth is it a wontfix?

Dennis Knorr (dennis-knorr) wrote :

Hi,
this problem happens (not very fast, but too) with QXL and Spice, just fyi

Same for Xubuntu 14.04 guest running on two different hosts: x64 Intel laptop and x86 AMD workstation. Desktop and windows are corrupted. qemu-1.6.2-4.5.1

Hans Deragon (deragon) wrote :

Same problem. Both host and guest are running Ubuntu 14.04 LTS Trusty Tahr. Switching to 'vga' video card works, but rendering is slower.

Fu Xuewei (fxwgit) wrote :

Met with the same problem. Guest are running Ubuntu 14.04 kylin . "vmware" video card works well. "cirrgus" , "qxl" and "std" make the desktop corrupted.

Vincenzo Costa (cvincenzo16) wrote :

I have a similar problem using qemu-kvm in kubuntu 14.04.1, while running linux-mint 17.1 or elementary os 0.3 beta 1 in the virtual machine.
In the case of linux mint, the desktop is more or less ok, but some objects are corrupted.
If you look at the first attached screenshot you will see three windows, two are ok (calculator and software manager) and one is corrupted (system monitor).
In the second screenshot you will see the elementary os desktop which is almost unreadable.

Vincenzo Costa (cvincenzo16) wrote :
Vincenzo Costa (cvincenzo16) wrote :
R. Steve McKown (rsmckown) wrote :

Same results as Vincenzo #60. Xubuntu 14.04.1 amd64 host, freshly created xubuntu 14.04 (not .1) amd64 guest. Some windows and display widgets render badly using either cirrus or vga display devices. The VMVGA display device seems to be working OK, but with little testing so far.

Note I have a windows 7 KVM VM also on this machine, with similar resources configured but using standard vga device driver, and it seems to be fine. The windows VM was created a looong time ago and migrated forward.

Norbert (nrbrtx) wrote :

I can confirm this bug on Ubuntu 12.04.5 host with the following guests:
* Ubuntu 12.04.5 i386 guest (default qemu-kvm = "kvm -m 1024 -cdrom ubuntu-12.04.5-desktop-i386.iso" )

Norbert (nrbrtx) wrote :

With the same Ubuntu 12.04.5 host (qemu-kvm 1.0+noroms-0ubuntu14.21) I got the following test results.

For Ubuntu 12.04.5 LTS i386 guest I got:
* without "-vga" I got screen corruption (see comment 64)
* with "-vga std" and "-vga vmware" it works as expected
* with "-vga qxl" QEMU boots to its console

For Ubuntu 14.04.2 LTS i386 guest I got:
* without "-vga" I got screen corruption (Unity looks better, but others - not)
* with "-vga std" and "-vga vmware" it works as expected
* with "-vga qxl" QEMU boots to its console

For Ubuntu 14.10 i386 guest I got:
* without "-vga" I got screen corruption (Unity looks better, but others - not)
* with "-vga std" and "-vga vmware" it works as expected
* with "-vga qxl" QEMU boots to its console

For Ubuntu 15.04 beta2 i386 guest I got:
* without "-vga" it does not boot to Unity session (see bug 1437740)
* with "-vga std" and "-vga vmware" it works as expected
* with "-vga qxl" QEMU boots to its console

With "-vga wmvare" I always got the highest screen resolution.
I summarized test results in Google Docs table ( see https://docs.google.com/spreadsheets/d/1WsjQ8nz3b6dhYGdM3xxkdxZHp27j9ggvrRPcZbm9Cao/edit?usp=sharing ).

So I suggest you to add simple "boot livecd/liveusb in kvm" test to livecd/liveusb testing procedure.
Ubuntu should not use "cirrus" driver while being guest, it should use "vesa".
Thank you!

tags: added: precise trusty utopic vivid
Changed in cairo (Ubuntu):
importance: Undecided → Medium
no longer affects: xserver-xorg-video-cirrus (Ubuntu)
no longer affects: linux (Ubuntu)

-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-cirrus/issues/3.

Changed in cairo:
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.