Port from legacy Xlib to modern XCB

Bug #1030022 reported by Fred on 2012-07-27
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Wishlist
Unassigned
9wm (Ubuntu)
Undecided
Unassigned
aewm (Ubuntu)
Undecided
Unassigned
aewm++ (Ubuntu)
Undecided
Unassigned
afterstep (Ubuntu)
Undecided
Unassigned
amiwm (Ubuntu)
Undecided
Lenin
blackbox (Ubuntu)
Undecided
Unassigned
cairo (Ubuntu)
Undecided
Unassigned
compiz (Ubuntu)
Wishlist
Unassigned
ctwm (Ubuntu)
Undecided
Unassigned
dwm (Ubuntu)
Undecided
Unassigned
enlightenment (Ubuntu)
Undecided
Unassigned
fvwm (Ubuntu)
Undecided
Unassigned
fvwm1 (Ubuntu)
Undecided
Unassigned
gtk+3.0 (Ubuntu)
Undecided
Unassigned
icewm (Ubuntu)
Undecided
Unassigned
jwm (Ubuntu)
Undecided
Samuel Henrique
larswm (Ubuntu)
Undecided
Unassigned
lwm (Ubuntu)
Undecided
Unassigned
matchbox-window-manager (Ubuntu)
Undecided
Unassigned
metacity (Ubuntu)
Undecided
Unassigned
miwm (Ubuntu)
Undecided
Unassigned
muffin (Ubuntu)
Undecided
Unassigned
mutter (Ubuntu)
Undecided
Unassigned
pekwm (Ubuntu)
Undecided
Unassigned
ratpoison (Ubuntu)
Undecided
Unassigned
sapphire (Ubuntu)
Undecided
Unassigned
sawfish (Ubuntu)
Undecided
Unassigned
spectrwm (Ubuntu)
Undecided
Unassigned
tinywm (Ubuntu)
Undecided
Unassigned
tritium (Ubuntu)
Undecided
Unassigned
twm (Ubuntu)
Undecided
Unassigned
vtwm (Ubuntu)
Undecided
Unassigned
w9wm (Ubuntu)
Undecided
Unassigned
windowlab (Ubuntu)
Undecided
Unassigned
wm2 (Ubuntu)
Undecided
Unassigned
wmaker (Ubuntu)
Undecided
Unassigned
xmonad (Ubuntu)
Undecided
Unassigned

Bug Description

Port/rewrite the window manager to use the modern XCB (X C Binding) library instead of the old legacy Xlib.

Scott Kitterman (kitterman) wrote :

Deleted the kdebase-workspace task since this is an upstream issue and we don't track upstream KDE issues in Launchpad. Users interested in getting issues resolved in KDE packages should file bugs at bugs.kde.org.

no longer affects: kdebase-workspace (Ubuntu)
Mathias Gumz (akira-9) wrote :

upstream issue, fluxbox.org has it's own bugtracker as well:

http://sourceforge.net/tracker/?group_id=35398&atid=413963

Changed in fluxbox (Ubuntu):
status: New → Invalid
Paul Tagliamonte (paultag) wrote :

Deleted the Fluxbox entry. It's upstream and borderline absurd. Xlib is not deprecated. The gains from XCB are not worth the instability in porting it.

no longer affects: fluxbox (Ubuntu)
no longer affects: xfwm4 (Ubuntu)
Changed in herbstluftwm (Ubuntu):
status: New → Invalid
no longer affects: herbstluftwm (Ubuntu)
Fred (eldmannen+launchpad) wrote :

herbstluftwm developer is using Xlib on purpose and considers it a feature.

Changed in herbstluftwm (Ubuntu):
status: New → Opinion
Daniel van Vugt (vanvugt) wrote :

Clarified bug description. Xlib is asynchronous already, by design. The real difference with XCB is mentioned here: http://xcb.freedesktop.org/

Changed in compiz (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
description: updated
description: updated
Changed in compiz:
importance: Undecided → Wishlist
status: New → Triaged
Christoph Kappel (unexist) wrote :

There's just no gain in porting subtle from xlib to xcb and I personally don't like the concept behind xcb at all.

Changed in subtle (Ubuntu):
status: New → Invalid
Ronny Cardona (rcart) wrote :

Hello,

Spectrwm has moved from Xlib to XCB in upstream. Debian Maintainer is a little busy right now and will update it as soon as he can.

I think that Spectrwm 2.X (XCB version) will not reach Quantal Quetzal, but I'm thinking to keep it updated in my PPA (or request a merge for it).

Changed in spectrwm (Ubuntu):
status: New → In Progress
Fred (eldmannen+launchpad) wrote :

Kwin (KDE)

Fredrik merged in the initial port from XLib to XCB. This is an important step on the road towards Qt 5 support inside KWin and will probably require still quite some work during the 4.11 cycle.

http://blog.martin-graesslin.com/blog/2012/11/this-week-in-kwin-2012-week-44-45/

Fred (eldmannen+launchpad) wrote :

Fredrik merged in the initial port from XLib to XCB.

Changed in kdebase-workspace (Ubuntu):
status: New → Fix Committed
affects: gtk (Ubuntu) → gtk+3.0 (Ubuntu)
affects: qt5 (Ubuntu) → qt4-x11 (Ubuntu)
Changed in qt4-x11 (Ubuntu):
status: New → Won't Fix
no longer affects: qt4-x11 (Ubuntu)
no longer affects: kdebase-workspace (Ubuntu)
no longer affects: wmii (Ubuntu)
Adolfo Jayme (fitojb) on 2013-05-27
no longer affects: subtle (Ubuntu)
Mateusz Łukasik (mati75) wrote :

It's total stupid idea.

Changed in evilwm (Ubuntu):
assignee: nobody → Mateusz Łukasik (mati75)
status: New → Opinion
assignee: Mateusz Łukasik (mati75) → nobody
status: Opinion → Confirmed
raboof (arnouten) wrote :

Xlib is not deprecated and XCB is not obviously superior.

'This bug affects 1 person.'

Removing notion from the list - shouldn't this bug report be removed entirely?

Changed in notion (Ubuntu):
status: New → Opinion
Fred (eldmannen+launchpad) wrote :

Xlib is synchronous.
XCB is asynchronous.

Asynchronous is superior to synchronous because it executes things in parallel without waiting hence is faster, has less delay/latency and is more responsive.

Changed in evilwm (Ubuntu):
status: Confirmed → Invalid
Changed in openbox (Ubuntu):
status: New → Opinion
Axel Beckert (xtaran) wrote :

flwm does not use xlib directly but through FLTK. Hence flwm is the wrong place to file such a bug report.

Changed in flwm (Ubuntu):
status: New → Invalid
Albin Tonnerre (lutin) wrote :

This bug is not applicable to dvtm: it's a terminal-only program

Changed in dvtm (Ubuntu):
status: New → Invalid
affects: dvtm (Ubuntu) → ubuntu
Albin Tonnerre (lutin) on 2014-01-04
affects: ubuntu → dvtm (Ubuntu)
Adolfo Jayme (fitojb) on 2014-05-04
no longer affects: dvtm (Ubuntu)
no longer affects: notion (Ubuntu)
no longer affects: herbstluftwm (Ubuntu)
no longer affects: openbox (Ubuntu)
affects: libcairo (Ubuntu) → cairo (Ubuntu)
Adolfo Jayme (fitojb) on 2015-01-07
no longer affects: evilwm (Ubuntu)
no longer affects: flwm (Ubuntu)
no longer affects: clutter (Ubuntu)
Adolfo Jayme (fitojb) on 2015-01-07
Changed in spectrwm (Ubuntu):
status: In Progress → Fix Released
Hugo Lefeuvre (hlef) on 2016-07-30
Changed in dwm (Ubuntu):
status: New → Opinion

Not planned.

Changed in metacity (Ubuntu):
status: New → Invalid
summary: - Port from legacy Xlib to to modern XCB
+ Port from legacy Xlib to modern XCB
Samuel Henrique (samueloph) wrote :
Changed in jwm (Ubuntu):
assignee: nobody → Samuel Henrique (samueloph)
status: New → Invalid
Doug Torrance (profzoom) on 2017-03-12
Changed in wmaker (Ubuntu):
status: New → Opinion
Lenin (gagarin) on 2017-04-18
Changed in amiwm (Ubuntu):
assignee: nobody → Lenin (gagarin)
Lenin (gagarin) on 2017-04-19
Changed in amiwm (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.