Dock's menu: don't hide the dock if it is raised and don't try to check if the mouse has left the dock if the menu is raised

Bug #988102 reported by Matthieu Baerts on 2012-04-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cairo-dock (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Impact]
The bug is very frequent (in each right-click), and therefore is very annoying.

[Text Case]

1.Open an application and maximise its window: the dock is now hidden (except if you've modified the visibility option). Now move the mouse to display the dock and do a right click on it.

Broken Behavior: You'll see a menu but the dock will disappear
Fixed Behavior: It should be visible to have an interaction with the dock and to show the changes, etc.

2. Do a right click on the dock (or a left click on the Applications Menu applet or Status-Notifier applet, etc.) and quickly move the mouse somewhere else on the dock.

Broken Behavior: You should see something like that: http://i.imgur.com/lrZGX.png (here we can see two icons of musicPlayer applet instead of one and Clipper icon has been partially hidden)
Fixed Behavior: Should see one icon for the applet and other shouldn't be hidden.

[Regression Potential]
The 2 bugs are actually regressions of the previous versions (in previous versions, when the menu was raised, the dock was frozen, which is the correct behavior, and the dock didn't disappear when the menu was raised, which is also the correct behavior everybody would expect).
So there is no possible regression, but the opposite.

[Original Report]
Hello

The Cairo-Dock team is proposing a new patch to fix two bugs with Cairo-Dock's menus:
 * don't hide the dock if this dock is raised
 * don't try to check if the mouse has left the dock if the menu is raised

How to reproduce these bugs:
 * open an application and maximise its window: the dock is now hidden (except if you've modified the visibility option). Now move the mouse to display the dock and do a right click on it. You'll see a menu but the dock will disappear (it should be visible to have an interaction with the dock and to show the changes, etc.)
 * do a right click on the dock (or a left click on the Applications Menu applet or Status-Notifier applet, etc.) and quickly move the mouse somewhere else on the dock. You should see something like that: http://i.imgur.com/lrZGX.png (here we can see two icons of musicPlayer applet instead of one and Clipper icon has been partially hidden)

This patch is available there: lp:cairo-dock-core/3.0 => https://bazaar.launchpad.net/~cairo-dock-team/cairo-dock-core/3.0.x/revision/1070

This bzr branch has been linked to this bug report: lp:~cairo-dock-team/ubuntu/precise/cairo-dock/988102
This branch should be ready to be pushed on lp:ubuntu/cairo-dock

Thank you for your help! ;)

Related branches

description: updated
Matthieu Baerts (matttbe) wrote :

I hope it's not too late to fix this bug for this package in Universe repositories due to the final freeze (1.5 days before the release date?)

Stefano Rivera (stefanor) wrote :

Unsubscribing the release team, this missed precise. I suggest SRUing anything of importance.

https://wiki.ubuntu.com/StableReleaseUpdates

Bryce Harrington (bryce) on 2012-05-17
description: updated
Changed in cairo-dock (Ubuntu):
status: New → Triaged
Changed in cairo-dock (Ubuntu Precise):
status: New → Triaged
description: updated

This fails to build in quantal:

In file included from /tmp/buildd/cairo-dock-3.0.0.1/src/gldit/cairo-dock-keybinder.h:34:0,
                 from /tmp/buildd/cairo-dock-3.0.0.1/src/gldit/cairo-dock-core.c:35:
/usr/include/glib-2.0/glib/gtypes.h:28:2: error: #error "Only <glib.h> can be included directly."
/tmp/buildd/cairo-dock-3.0.0.1/src/gldit/cairo-dock-core.c: In function 'gldi_init':
/tmp/buildd/cairo-dock-3.0.0.1/src/gldit/cairo-dock-core.c:80:3: warning: 'g_thread_init' is deprecated (declared at /usr/include/glib-2.0/glib/deprecated/gthread.h:259) [-Wdeprecated-declarations]

Full build log attached.

If you're interested in getting this into precise as an SRU, please fill out the needed information above as described in https://wiki.ubuntu.com/StableReleaseUpdates#Procedure and I'd be happy to sponsor the upload. (Of course it needs to be fixed in quantal first.)

Thanks!

Matthieu Baerts (matttbe) wrote :

Yes, this bug has been already fixed in the 3.0.1 version. This is the patch: https://bazaar.launchpad.net/~cairo-dock-team/cairo-dock-core/cairo-dock/revision/1073
(but it compiles fine on Precise without this patch ;) )

BTW, thank you for your help :)
I (or fabounet) will try to fill the description of the bug report for the SRU ASAP!
I will also propose the new bug-fix version (3.0.1 or the next 3.0.2 scheduled for soon I think) for Quantal (and Precise if it's possible)

Fabounet (fabounet03) on 2012-06-04
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock - 3.0.0.1-0ubuntu2

---------------
cairo-dock (3.0.0.1-0ubuntu2) quantal; urgency=low

  * debian/patches/01-bzr_dock-s_menu.patch: don't hide the dock if it's raised
    and don't try to check if the mouse has left the dock if the menu is raised
    (LP: #988102)
   - It's an uptream patch (lp:cairo-dock-core/3.0 - rev 1070)
  * debian/patches/02-bzr_fixed_compilation_error.patch:
   - Fixed a compilation error with GLib >= 2.33
 -- Matthieu Baerts (matttbe) <email address hidden> Wed, 25 Apr 2012 01:29:46 +0200

Changed in cairo-dock (Ubuntu):
status: Triaged → Fix Released

Uploaded to quantal w/ the patch fixing the FTBFS, and uploaded to precise-proposed w/ just the original patch fixing the issue documented above. Thanks!

Changed in cairo-dock (Ubuntu Precise):
status: Triaged → Fix Committed
Matthieu Baerts (matttbe) wrote :

Thank you for your help!

Hello Matthieu, or anyone else affected,

Accepted cairo-dock into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Matthieu Baerts (matttbe) wrote :

I confirm that the bug is fixed and I just want to note that a new bug-fix version is available, it can be interesting to upload this new version in Precise too ;) => bug #1014801

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock - 3.0.0.1-0ubuntu1.1

---------------
cairo-dock (3.0.0.1-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/01-bzr_dock-s_menu.patch: don't hide the dock if it's raised
    and don't try to check if the mouse has left the dock if the menu is raised
    (LP: #988102)
   - It's an uptream patch (lp:cairo-dock-core/3.0 - rev 1070)
 -- Matthieu Baerts (matttbe) <email address hidden> Wed, 25 Apr 2012 01:29:46 +0200

Changed in cairo-dock (Ubuntu Precise):
status: Fix Committed → Fix Released
Scott Kitterman (kitterman) wrote :

Copied to precise-updates.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers