Please update Cairo-Dock (core) to 2.4.0~1 version (bugs fixed version)

Bug #859982 reported by Matthieu Baerts on 2011-09-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cairo-dock (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

The Cairo-Dock team proposes a new version of its Cairo-Dock packages.

This is the Upstream (short) ChangeLog:
 * Upstream (short) ChangeLog (2.4.0~0beta2 -> 2.4.0~1):
   - Improved support of the new Gnome 3 session
      (to avoid conflicts with the new Gnome-Panel).
   - Code cleaned and re-organised a few functions
      (e.g. with cairo-dock-overlay, cairo-dock.c, etc.)
   - Updating translations
   - Improved the support of XFCE and LXDE environments
   - Removed invalid launcher desktop files
   - Used a default icon if the path set by the user is wrong
   - Fixed the possibility to sticky a desklet (bug due to a Xorg update)
   - GUI: fixed the list-entry widget
   - Fixed support of the Widget Layer in Compiz >= 0.9
   - Compiz type filter: replaced type=utility by type=Utility
   - Fixed a small refresh bug in cairo mode
      (with icons that are always visible)
   - Improved the placement of icons when avoiding the mouse
      (when something is being dropped onto the dock)
   - Updated the default theme in order to use new applications
   - Gauge implementation: Rewritten to use CairoDockImageBuffer
      and fixed the problem with png images
   - Graphs: Improved the drawing and added more precisions
   - Improved the 'lock' option description
   - GUI simple: fixed a bad update of the parameters
      when switching back to the previous value
   - Fixed the path of the preview for the default view
   - Help: Fixed the problem with tips
   - Default-theme: .conf files: fixed lintian warnings
   - Fixed a few warnings at the compilation
   - Removed a few useless output messages
   - Fixed these LP bugs:
    + Cairo-dock corrupts Kdenlive monitor display LP: #729970
    + Can't play videos in kaffeine LP: #475375
   - And fixed a lot of tiny bugs, please have a look to bzr logs.

Note that this is the stable version of the 2.4 branch. It fixes a lot of bugs of the previous version (2.4.0~0beta2).

This bzr branch has been linked to this bug report: lp:~cairo-dock-team/ubuntu/oneiric/cairo-dock/2.4.0-1
This branch should be ready to be pushed on lp:ubuntu/cairo-dock (except the UNRELEASED version in debian/changelog)

Thank you for your help! :)

PS: Don't forget to upload this package AND THE PLUGINS ( LP: #859984 )

Related branches

description: updated
description: updated
Fabrice Coutadeur (fabricesp) wrote :

Hi,

As we are actually in Feature Freeze period (and very near from the release date), and given that this is a new upstream release, please follow the FFe process describe at https://wiki.ubuntu.com/FreezeExceptionProcess.

As soon as you get the FFe, please subscribe again the sponsors.

Thanks,
Fabrice

Changed in cairo-dock (Ubuntu):
status: New → Incomplete
Matthieu Baerts (matttbe) wrote :

@ubuntu-release team: It seems we have to follow the FFe process but this is a bug fixed version (the previous version was the second beta release of this new 2.4.0 version)
Translations are much better and it fixes a few annoying problems (see the ChangeLog here above). Please upload this version because the previous one was a beta version.
Please help us because due to all the recent changes in Ubuntu, we need this version to keep the program running well in Oneiric
(I'm thinking of all the changes in the DBus interfaces for instance, Compiz, Messaging-Menu, the Gnome-Panel, XFCE, Gnome3 and others). Cairo-Dock 2.3 just can't run in Oneiric, and 2.4.0-beta ... well, is a beta and many things have changed just before the FF!

This new version is also available on this ppa:cairo-dock-team/ppa and used by many people. We use this version on our ppa and it's not so different than the previous beta version with a lot of fixed bugs and many improvements!

About the build log, this file has been joined to this bug report: cairo-dock_2.4.0~2-0ubuntu1.build.log.gz

Thank you for your help

PS: don't forget our plug-ins ( LP: #859984 )

Matthieu Baerts (matttbe) wrote :
Changed in cairo-dock (Ubuntu):
status: Incomplete → New
Martin Pitt (pitti) wrote :

This looks fine to me, approved. Please upload it as soon as possible, thanks!

Changed in cairo-dock (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package cairo-dock - 2.4.0~2-0ubuntu1

---------------
cairo-dock (2.4.0~2-0ubuntu1) oneiric; urgency=low

  [ Matthieu Baerts (matttbe) ]
  * New upstream bug fix release. (LP: #859982)
  * Upstream (short) ChangeLog (2.4.0~0beta2 -> 2.4.0~1):
   - Improved support of the new Gnome 3 session
      (to avoid conflicts with the new Gnome-Panel).
   - Code cleaned and re-organised a few functions
      (e.g. with cairo-dock-overlay, cairo-dock.c, etc.)
   - Updating translations
   - Improved the support of XFCE and LXDE environments
   - Removed invalid launcher desktop files
   - Used a default icon if the path set by the user is wrong
   - Fixed the possibility to sticky a desklet (bug due to a Xorg update)
   - GUI: fixed the list-entry widget
   - Fixed support of the Widget Layer in Compiz >= 0.9
   - Compiz type filter: replaced type=utility by type=Utility
   - Fixed a small refresh bug in cairo mode
      (with icons that are always visible)
   - Improved the placement of icons when avoiding the mouse
      (when something is being dropped onto the dock)
   - Updated the default theme in order to use new applications
   - Gauge implementation: Rewritten to use CairoDockImageBuffer
      and fixed the problem with png images
   - Graphs: Improved the drawing and added more precisions
   - Improved the 'lock' option description
   - GUI simple: fixed a bad update of the parameters
      when switching back to the previous value
   - Fixed the path of the preview for the default view
   - Help: Fixed the problem with tips
   - Default-theme: .conf files: fixed lintian warnings
   - Fixed a few warnings at the compilation
   - Removed a few useless output messages
   - Fixed these LP bugs:
    + Cairo-dock corrupts Kdenlive monitor display LP: #729970
    + Can't play videos in kaffeine LP: #475375
   - And fixed a lot of tiny bugs, please have a look to bzr logs.
  * Upstream (short) ChangeLog (2.4.0~1 -> 2.4.0~2):
   - Fixed a bug with the detection of compiz plugins
   - doc: used the right version
   - Fixed a possible crash with an empty dock LP: #861725
   - FlyingContainer: draw the icon correctly
  * debian/patches:
   - Removed 01-musicPlayer_with_banshee: now in upstream
  * debian/copyright:
   - Updated and fixed lintian warnings: old-fsf-address-in-copyright-file
  * debian/rules and debian/cairo-dock-data.install:
   - Added support of the new Gnome 3 session.
  * debian/control:
   - Fixed lintian warning: description-synopsis-starts-with-article
   - Fixed lintian error: version-substvar-for-external-package
  * debian/cairo-dock-data.lintian-overrides:
   - Removed old warnings (fixed)
   - Added binary-without-manpage (custom scripts used)
  * debian/cairo-dock-core.install and debian/cairo-dock-dev.install:
   - Fixed a lintian warning: non-dev-pkg-with-shlib-symlink
  * debian/patches/01-improved-cairo-dock-session.patch:
   - Improved the launch of our Cairo-Dock session (by removing Unity
      Compiz plugin and by launching the dock with a short delay)
   - Fixed lintian error: shell-script-fails-syntax-check
      (it seems I made wrong manipulation with vim...)
  * debian/patches/02-manpag...

Read more...

Changed in cairo-dock (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers