Can't play videos in kaffeine, dragon player, gwenview and smplayer using the "xv" driver after running cairo-dock

Bug #475375 reported by Marcelo on 2009-11-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Undecided
Matthieu Baerts
Gwenview
New
Undecided
Unassigned
Kaffeine
New
Undecided
Unassigned
SMPlayer
New
Undecided
Unassigned
cairo-dock (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cairo-dock

After running cairo-dock (with opengl support) in KDE 4.3.2 (Kubuntu 9.10), it is no longer possible to play videos in kaffeine, dragon player, gwenview and smplayer using the "xv" video driver. smplayer can still play videos if I switch to "gl" or "gl2" video drivers. I can hear the sound and the progress bar moves as if the video was playing, but there is no image. With desktop effects on, the area of the window where the video should be displayed in these applications is shown as a transparent gray rectangle. With desktop effects off, it is a solid black rectangle.

Strangely enough, mplayer and xine can still play videos using the "xv" driver if I run them directly, but not if embedded in the above mentioned front ends (and others).

Everything gets back to normal if I log out KDE and then log in again without running cairo-dock.

I have a nvidia 9600GT video card and am running the proprietary driver from ubuntu repos.

ProblemType: Bug
Architecture: i386
CompositingMetacity: No value set for `/apps/metacity/general/compositing_manager'
Date: Thu Nov 5 10:14:33 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: cairo-dock 2.0.9-0ubuntu1
PackageArchitecture: all
PciDisplay: 01:00.0 VGA compatible controller [0300]: nVidia Corporation G86 [GeForce 8500 GT] [10de:0421] (rev a1)
ProcEnviron:
 LANGUAGE=pt_BR:pt:en
 PATH=(custom, user)
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: cairo-dock
Uname: Linux 2.6.31-14-generic i686
WM: No value set for `/desktop/gnome/applications/window_manager/current'
glxinfo: Error: [Errno 2] Arquivo ou diretório não encontrado
system: distro = Ubuntu, architecture = i686, kernel = 2.6.31-14-generic

Related branches

Marcelo (mmtsales) wrote :
Marcelo (mmtsales) wrote :

Hello,

I've tried to run smplayer as indicated in that web page:
export XLIB_SKIP_ARGB_VISUALS=1
smplayer &

But the problem persists. If I select the "gl" driver it works, as I had mentioned in the bug report. However, it is slower than "xv "and if the video area of the smplayer window and the video being played are in different proportions, the extra space is filled with a transparent gray background, which is horrible. The other Qt applications do not offer an option to use other video driver, so they simply do not play videos.
Is there anything else I should test?

Thanks,

Marcelo

Matthieu Baerts (matttbe) wrote :

> Is there anything else I should test?
I think that the best thing to do is to confirm this bug #416294 and post a new bug report there: http://bugreports.qt.nokia.com/secure/Dashboard.jspa

Thanks for your help!

Marcelo (mmtsales) wrote :

I filed a bug in Nokias bug tracker (http://bugreports.qt.nokia.com/browse/QTBUG-5464). Don't know if they will pay attention to it, however, because I don't know of any application other than cairo-dock that triggers this bug.
On the other hand, I've noticed that if I run cairo-dock without opengl support, the problem does not occur. So, I can live with it.

Matthieu Baerts (matttbe) wrote :

Thanks for your help ! I hope that this new bug will be fixed soon !

Matthieu Baerts (matttbe) wrote :

(It's not a new bug but a new bug report. We already posted this bug on their tracker but without any answers !)

Changed in cairo-dock-core:
status: New → Incomplete
Changed in cairo-dock (Ubuntu):
status: New → Incomplete
Poyntz (poyntz) wrote :

this bug also affects dragon player 2 in kde 4.3.2

Changed in cairo-dock-core:
status: Incomplete → Confirmed
Matthieu Baerts (matttbe) wrote :

@ Francisco, this is not a bug in Cairo-Dock but in Qt.
There is a workaround (http://bit.ly/dpzRmq => http://www.glx-dock.org/ww_page.php?p=Recurrents%20problems&lang=en#7-Others%20apps%20based%20on%20Qt4%20like%20VirtualBox,%20Skype,%20VLC).
E.g. vlc has added it in its source code, so other apps can do that too. (Please, change the status of these other apps ;) )

Changed in cairo-dock-core:
status: Confirmed → Invalid
Fabounet (fabounet03) wrote :

this bug has been worked around a few months ago.

Changed in cairo-dock (Ubuntu):
status: Incomplete → Fix Committed
Changed in cairo-dock-core:
status: Invalid → Fix Committed
Marcelo (mmtsales) wrote :

The Qt developers examined the problem and suggested a workaround, but also proved that the problem is indeed in cairo-dock.
This problem isn't fixed yet, so I think this bug should not be closed, much less being marked as invalid.
The possible workaround requires the user to load cairo-dock in a way that's not easy for the average user and such workaround should not be needed any way.
Cairo-dock needs to be fixed.

This is the workaround suggested by Qt people (see http://bugreports.qt.nokia.com/browse/QTBUG-5464):

"The bug is NOT in Qt.
The reason is that something in cairo-dock or its supporting libs sets a custom colormap - on the root window...

The proper workaround is NOT to disable ARGB clients (this would eg. break plasma or translucent UI styles) but to remove the property once cairo-dock has started and (if possible) before anything else starts up.

xprop -root -remove RGB_DEFAULT_MAP"

Matthieu Baerts (matttbe) wrote :

Hello,

In fact, the bug is in gtkglext ( LP: #701977 ) and a workaround has been added in Cairo-Dock. For the Cairo-Dock team, this bug is fixed... but not in gtkglext of course.

Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package cairo-dock - 2.4.0~2-0ubuntu1

---------------
cairo-dock (2.4.0~2-0ubuntu1) oneiric; urgency=low

  [ Matthieu Baerts (matttbe) ]
  * New upstream bug fix release. (LP: #859982)
  * Upstream (short) ChangeLog (2.4.0~0beta2 -> 2.4.0~1):
   - Improved support of the new Gnome 3 session
      (to avoid conflicts with the new Gnome-Panel).
   - Code cleaned and re-organised a few functions
      (e.g. with cairo-dock-overlay, cairo-dock.c, etc.)
   - Updating translations
   - Improved the support of XFCE and LXDE environments
   - Removed invalid launcher desktop files
   - Used a default icon if the path set by the user is wrong
   - Fixed the possibility to sticky a desklet (bug due to a Xorg update)
   - GUI: fixed the list-entry widget
   - Fixed support of the Widget Layer in Compiz >= 0.9
   - Compiz type filter: replaced type=utility by type=Utility
   - Fixed a small refresh bug in cairo mode
      (with icons that are always visible)
   - Improved the placement of icons when avoiding the mouse
      (when something is being dropped onto the dock)
   - Updated the default theme in order to use new applications
   - Gauge implementation: Rewritten to use CairoDockImageBuffer
      and fixed the problem with png images
   - Graphs: Improved the drawing and added more precisions
   - Improved the 'lock' option description
   - GUI simple: fixed a bad update of the parameters
      when switching back to the previous value
   - Fixed the path of the preview for the default view
   - Help: Fixed the problem with tips
   - Default-theme: .conf files: fixed lintian warnings
   - Fixed a few warnings at the compilation
   - Removed a few useless output messages
   - Fixed these LP bugs:
    + Cairo-dock corrupts Kdenlive monitor display LP: #729970
    + Can't play videos in kaffeine LP: #475375
   - And fixed a lot of tiny bugs, please have a look to bzr logs.
  * Upstream (short) ChangeLog (2.4.0~1 -> 2.4.0~2):
   - Fixed a bug with the detection of compiz plugins
   - doc: used the right version
   - Fixed a possible crash with an empty dock LP: #861725
   - FlyingContainer: draw the icon correctly
  * debian/patches:
   - Removed 01-musicPlayer_with_banshee: now in upstream
  * debian/copyright:
   - Updated and fixed lintian warnings: old-fsf-address-in-copyright-file
  * debian/rules and debian/cairo-dock-data.install:
   - Added support of the new Gnome 3 session.
  * debian/control:
   - Fixed lintian warning: description-synopsis-starts-with-article
   - Fixed lintian error: version-substvar-for-external-package
  * debian/cairo-dock-data.lintian-overrides:
   - Removed old warnings (fixed)
   - Added binary-without-manpage (custom scripts used)
  * debian/cairo-dock-core.install and debian/cairo-dock-dev.install:
   - Fixed a lintian warning: non-dev-pkg-with-shlib-symlink
  * debian/patches/01-improved-cairo-dock-session.patch:
   - Improved the launch of our Cairo-Dock session (by removing Unity
      Compiz plugin and by launching the dock with a short delay)
   - Fixed lintian error: shell-script-fails-syntax-check
      (it seems I made wrong manipulation with vim...)
  * debian/patches/02-manpag...

Read more...

Changed in cairo-dock (Ubuntu):
status: Fix Committed → Fix Released
Changed in cairo-dock-core:
status: Fix Committed → Fix Released
assignee: nobody → Matthieu Baerts (matttbe)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers