[SRU] OpenGL backend is wrongly blocked and menus are over the dock

Bug #1329090 reported by Matthieu Baerts on 2014-06-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cairo-dock (Ubuntu)
High
Matthieu Baerts
Trusty
High
Unassigned
Utopic
High
Matthieu Baerts

Bug Description

Hello,

== 1st Bug: Wrong blacklisting ==

It seems that the patch 'bzr1719_unblacklist_intel_hd4000.patch' has a typo: the blacklist was not fully removed. The blacklist of the Intel 4000HD video card is no longer needed because this bug has been fixed thanks to the 10.1 version of Mesa.
But this patch wrongly removes the blacklist and then it's possible that you'll need to force the OpenGL backend (with the '-o' option) to use it even if you don't have this Intel 4000HD video card and you choose to use it.

== 2nd Bug: Menus are not correctly positioned ==

There is also a bug with the menus: It seems that the behaviour of menus with a custom position has changed since using GTK 3.10: https://bugzilla.gnome.org/show_bug.cgi?id=721094
We now have to use the 'natural' size instead of the 'minimum' size:

    - gtk_widget_get_preferred_size (GTK_WIDGET (menu), &requisition, NULL);
    + gtk_widget_get_preferred_size (GTK_WIDGET (menu), NULL, &requisition);

A branch has been linked to this bug report and it fixes these 2 bugs: lp:~cairo-dock-team/ubuntu/trusty/cairo-dock/1329090

[Test Case]

For the first bug: You should be able to reproduce this bug when using Free and Open Source video drivers. Simply launch the dock for the first time from a terminal:

    $ cairo-dock
    (or if it's not the first time: $ cairo-dock -A)

You should see a window to confirm that you want to use the OpenGL backend: click on this "Yes" button. Then you should see on the terminal that you're not using the OpenGL backend: "Running with OpenGL: 0"

For the second bug: simply do a right click on the dock and you should see that the menu is over the dock instead of on top of it. Cairo-Dock's menus should not overlap the dock.

[Regression Potential]

The only possible regression that I see is that this OpenGL backend could maybe be accidentally blocked for some users which have an old, exotic and badly supported video card. If these users enable this OpenGL backend, the dock can look strange but this is why there is a message the first time you launch the dock ;-)
But in other words, it seems there is no regression, just a correct behaviour (if the user wants to use the hardware acceleration, he will be able to use it as requested)

Note that these two patches have been tested and added in our unstable and stable PPAs and in the official Utopic repositories one month ago.

description: updated
Changed in cairo-dock (Ubuntu Utopic):
status: New → Fix Released
importance: Undecided → High
Changed in cairo-dock (Ubuntu Trusty):
importance: Undecided → High
Changed in cairo-dock (Ubuntu Utopic):
assignee: nobody → Matthieu Baerts (matttbe)
milestone: none → ubuntu-14.05
Changed in cairo-dock (Ubuntu Trusty):
milestone: none → ubuntu-14.04.1
Changed in cairo-dock (Ubuntu Trusty):
status: New → In Progress

Hello Matthieu, or anyone else affected,

Accepted cairo-dock into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cairo-dock/3.3.99.beta1.2.really.3.3.2-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cairo-dock (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Matthieu Baerts (matttbe) wrote :

Hello Brian,

Thank you for you help!

I just re-tested this new package on Ubuntu Trusty and I confirm that these bugs are fixed as expected!

tags: added: verification-done
removed: verification-needed

I've tested it on my ultra-custom cairo-dock and the bugs are fixed ;p

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock - 3.3.99.beta1.2.really.3.3.2-0ubuntu2.1

---------------
cairo-dock (3.3.99.beta1.2.really.3.3.2-0ubuntu2.1) trusty-proposed; urgency=medium

  * New 'bug-fix' version to fix 2 bugs (LP: #1329090)
  * debian/patches/bzr1719_unblacklist_intel_hd4000.patch: fixed typo:
    the blacklist was not fully removed.
  * debian/patches/bzr1750_get_preferred_size_has_changed_in_gtk3.10.patch:
    - Menus: use the natural size to retrieve the height of a menu, because
      gtk_widget_get_preferred_size() function has changed in GTK3.10.
      (All GTK menus were no longer at the right position)
 -- Matthieu Baerts (matttbe) <email address hidden> Thu, 12 Jun 2014 00:35:59 +0200

Changed in cairo-dock (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cairo-dock has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in cairo-dock (Ubuntu Utopic):
milestone: ubuntu-14.05 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers