[SRU] Please update Cairo-Dock and its plugins to the version 3.3.2 (bug-fix version)

Bug #1250221 reported by Matthieu Baerts on 2013-11-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cairo-dock (Ubuntu)
High
Matthieu Baerts
Saucy
High
Matthieu Baerts
Trusty
High
Matthieu Baerts

Bug Description

Hello,

A new version of Cairo-Dock is available: v. 3.3.2. It's a bug-fix version. Here is the detailed ChangeLog:

* Cairo-Dock:
    - Class: implemented a workaround for Chromium and Google Chrome web apps (the same as used in Bamf)
    - Docks: fixed 2 bugs when reloading a dock: when changing the visibility from 'keep hidden' to 'hide when overlapping a window' and when changing the offset from the screen edges, there were no visual changes until the next session.
    - Launching animation: don't stop it when the dock hides itself
    - Menus: correctly setup the menu during its initial state: default menu entry of some menus was not selected
    - Taskbar:
      - Fixed a regression when the application changes its class
      - Removed 'opening animation' option: was not working and it was duplicated in plugins (Animated-Icons and Icon-effect)
    - Translations: imported translations from Launchpad

* Plugins:
    - Animated-icons: show the option to disable the 'opening animations' in Animated-icons' settings (was in the core but it was not working)
    - DBus: third-party: init: register the applets after having set the text domain for gettext (titles was not translated)
    - Dock-rendering: panel view: fixed the input shape when there is a single group of icons (no separator) LP: #1089052
    - GMenu:
      - Apps: fixed tiny memory leak when stopping the applet
      - Apps: New app: avoid multiple dialogues and select the first item in the list (very annoying when installing a lot of apps)
      - Entry: with GTK 3.10: both the entry and the menu receive the signal that a key is pressed. This caused a bug: each character was doubled
      - Menus: added a workaround for libgnomemenu if XDG_CURRENT_DESKTOP is not defined (e.g. when using XFCE, the menu layout was wrong)
    - Icon Effect: config: move 'opening animation' option to 'when clicking on a launcher' section
    - MusicPlayer: fixed a bug when changing the player (the icon was not updated) and fixed a few small memory leaks
    - System Monitor:
      - SWAP percent was computed twice
      - Fixed crash if we want to display more than 4 values in a graph view [HIGH]
    - Shortcuts: bookmarks file:
      - If the file doesn't exist, first create the directory before creating an empty file (fixed crash on non-GNOME desktop environment if ~/.config/gtk-3.0 dir was not available) LP: #1244997 [HIGH]
      - Check for the existence of the old and new bookmark files to decide which one to use (to avoid empty bookmark list on some DE: XFCE, Linux Mint)
    - Weather: on double-click on the main icon, show the hourly forecast instead of doing nothing
    - Translations: imported translations from Launchpad. LP: #1243608

(most of the bug reports linked to these changes are available in Cairo-Dock's forum: forum.glx-dock.org)

[Impact]

1) As you can see, this new version fixes a few bugs (some are more annoying than other) and it also fixes two crashes.
The most important bug here is detailed on LP: #1244997 : on some non-GNOME DE (e.g. KDE), '~/.config/gtk-3.0' dir is not available: it is unreadable or not created and this problem causes a crash.

2) Inside docks, icons can be aligned (to the middle, right or left of the screen's border)
When using the "panel" mode, separators expand to fill the screen width (which separates icons in distinct groups), but when there is no separator, all icons are grouped together, and in this case, they didn't respect the alignment parameter.
This can be quite annoying in some cases for instance, this prevents the user from being able to move the icons away from the top-left corner of the screen, which is where window's controls are on Ubuntu.
The fix was to correctly take into account the alignment in this particular case.

[Test Case]

1) On a fresh installation of KUbuntu (or remove/rename/change owner/change rights/... of this dir: '~/.config/gtk-3.0'):
* Install Cairo-Dock 3.3.1 (from Ubuntu repos)
* Launch it (with the default theme)
* It crashes
* Install the 3.3.2 version (e.g by adding the official ppa: ppa:cairo-dock-team/ppa and update the system)
* Re-launch the dock
* no more crashes.

2) create a dock with an icon inside, set this dock with the "panel" view, and then try to change the alignment to the right: it won't work

[Regression Potential]

This new version (3.3.2) has been released a few weeks ago (2013-10-29). It is used by many people (on 2013-11-11, ~27.700 users have downloaded this version from our ppa according to the stats given by Launchpad) and it seems there is no regression due to this version.

2) it only concerns the position of icons in docks with "panel" view and no separator in the dock, which is by itself not a common use case.
we checked that it didn't influence the placement of icons when there is at least 1 separator, and that icons can be placed on the left, middle and right when there is no separator.

Changed in cairo-dock (Ubuntu Saucy):
status: New → Triaged
Changed in cairo-dock (Ubuntu Trusty):
status: New → Fix Released
importance: Undecided → High
Changed in cairo-dock (Ubuntu Saucy):
importance: Undecided → High
assignee: nobody → Matthieu Baerts (matttbe)
Changed in cairo-dock (Ubuntu Trusty):
assignee: nobody → Matthieu Baerts (matttbe)
Changed in cairo-dock (Ubuntu Saucy):
milestone: none → saucy-updates
Changed in cairo-dock (Ubuntu Trusty):
milestone: none → ubuntu-14.01
description: updated
description: updated
Changed in cairo-dock (Ubuntu Saucy):
status: Triaged → In Progress
Fabounet (fabounet03) wrote :

On Brian Murray's demand, I'm adding some information about the bug LP #1089052:

* Impact:
in docks, icons can be aligned (to the middle, right or left of the screen's border)
in "panel" mode, separators expand to fill the screen width (which separates icons in distinct groups), but when there is no separator, all icons are grouped togather, and in this case, they didn't respect the alignment parameter.

this can be quite annoying in some cases
for instance, this prevents the user from being able to move the icons away from the top-left corner of the screen, which is where window's controls are on Ubuntu.

The fix was to correctly take into account the alignment in this particular case.

* Test Case:
create a dock with an icon inside, set this dock with the "panel" view, and then try to change the alignment to the right: it won't work

* Regression Potential: it only concerns the position of icons in docks with "panel" view and no separator in the dock, which is by itself not a common use case.
we checked that it didn't influence the placement of icons when there is at least 1 separator, and that icons can be placed on the left, middle and right when there is no separator.

description: updated

Hello Matthieu, or anyone else affected,

Accepted cairo-dock into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cairo-dock/3.3.2-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cairo-dock (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
Matthieu Baerts (matttbe) wrote :

Hello Chris,

I confirm that this new version (3.3.2-0ubuntu0.1) works fined on Ubuntu Saucy , thank you for your help!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock - 3.3.2-0ubuntu0.1

---------------
cairo-dock (3.3.2-0ubuntu0.1) saucy-proposed; urgency=low

  * New upstream release. (bug-fix version) LP: #1250221
  * Detailed Upstream ChangeLog (3.3.1 -> 3.3.2)
    - Class: implemented a workaround for Chromium and Google Chrome web apps
    - Docks: fixed 2 bugs when reloading a dock: when changing the
      visibility from 'keep hidden' to 'hide when overlapping a window'
      and when changing the offset from the screen edges
    - Launching animation: don't stop it when the dock hides itself
    - Menus: correctly setup the menu during its init
    - Taskbar:
      - Fixed a regression when the application changes its class
      - Removed 'opening animation' option: now in plugins (Animated-Icons
        and Icon-effect)
    - Translations: imported translations from Launchpad
  * debian/control:
    - bumped plug-ins versions
    - bumped Standards-Version to 3.9.4 (no change needed)
 -- Matthieu Baerts (matttbe) <email address hidden> Mon, 25 Nov 2013 01:37:40 +0100

Changed in cairo-dock (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cairo-dock has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers